summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-08-23 16:00:43 +0000
committerSamuli Suominen <drac@gentoo.org>2007-08-23 16:00:43 +0000
commit1450dfc664d72b6a987a2b9e7f8e18bf4e343340 (patch)
tree625ee0642a257779540e26df29f9313196d5f5d1 /net-p2p
parentNew USE flag, xfce, for net-p2p/linkage. (diff)
downloadgentoo-2-1450dfc664d72b6a987a2b9e7f8e18bf4e343340.tar.gz
gentoo-2-1450dfc664d72b6a987a2b9e7f8e18bf4e343340.tar.bz2
gentoo-2-1450dfc664d72b6a987a2b9e7f8e18bf4e343340.zip
Version bump for bug 189920.
(Portage version: 2.1.3.6)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/linkage/ChangeLog7
-rw-r--r--net-p2p/linkage/files/digest-linkage-0.1.43
-rw-r--r--net-p2p/linkage/linkage-0.1.4.ebuild38
3 files changed, 47 insertions, 1 deletions
diff --git a/net-p2p/linkage/ChangeLog b/net-p2p/linkage/ChangeLog
index 2d892b92d363..2537720add06 100644
--- a/net-p2p/linkage/ChangeLog
+++ b/net-p2p/linkage/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/linkage
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/linkage/ChangeLog,v 1.3 2007/07/22 16:28:56 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/linkage/ChangeLog,v 1.4 2007/08/23 16:00:43 drac Exp $
+
+*linkage-0.1.4 (23 Aug 2007)
+
+ 23 Aug 2007; Samuli Suominen <drac@gentoo.org> +linkage-0.1.4.ebuild:
+ Version bump for bug 189920.
22 Jul 2007; Samuli Suominen <drac@gentoo.org>
+files/linkage-0.1.2-enable-disable-upnp.patch, linkage-0.1.2.ebuild:
diff --git a/net-p2p/linkage/files/digest-linkage-0.1.4 b/net-p2p/linkage/files/digest-linkage-0.1.4
new file mode 100644
index 000000000000..80d077d71f63
--- /dev/null
+++ b/net-p2p/linkage/files/digest-linkage-0.1.4
@@ -0,0 +1,3 @@
+MD5 8c208ec71db1e6db58897d19e953256f linkage-0.1.4.tar.gz 605105
+RMD160 8fd3168ac0d2b52750e3f46e4686f56a89667671 linkage-0.1.4.tar.gz 605105
+SHA256 7cf1de1b1b29ec653c72c89366d1ae95de6ab8d6c74c61a2568de52a9bf432d0 linkage-0.1.4.tar.gz 605105
diff --git a/net-p2p/linkage/linkage-0.1.4.ebuild b/net-p2p/linkage/linkage-0.1.4.ebuild
new file mode 100644
index 000000000000..e599b98f4224
--- /dev/null
+++ b/net-p2p/linkage/linkage-0.1.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/linkage/linkage-0.1.4.ebuild,v 1.1 2007/08/23 16:00:43 drac Exp $
+
+SCROLLKEEPER_UPDATE="no"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="BitTorrent client written in C++ using gtkmm and libtorrent."
+HOMEPAGE="http://code.google.com/p/linkage"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="curl gnome upnp xfce"
+
+RDEPEND=">=net-libs/rb_libtorrent-0.12
+ >=dev-cpp/gtkmm-2.10
+ >=dev-cpp/gconfmm-2.6
+ >=dev-cpp/libglademm-2.6
+ >=x11-libs/libnotify-0.4.4
+ >=dev-libs/dbus-glib-0.73
+ curl? ( >=net-misc/curl-7.14 )
+ gnome? ( >=dev-cpp/libgnomemm-2.16
+ >=dev-cpp/gnome-vfsmm-2.16
+ >=dev-cpp/libgnomeuimm-2.16 )
+ xfce? ( >=xfce-extra/exo-0.3 )
+ upnp? ( >=net-libs/gupnp-0.4 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+GCONF2="${GCONF2} $(use_with curl) $(use_with gnome) \
+ $(use_with upnp gupnp) $(use_with xfce exo)"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"