summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-12-25 10:47:23 +0000
committerMichał Górny <mgorny@gentoo.org>2014-12-25 10:47:23 +0000
commit2811a8667effd25b7de27f3c176e789326a84988 (patch)
tree8f808d0f0dc3872f392b999db01a092499ce1e9b /net-p2p
parentAdd dev-qt/linguist-tools:5 dependency for qt5 lrelease (bug #532962). (diff)
downloadgentoo-2-2811a8667effd25b7de27f3c176e789326a84988.tar.gz
gentoo-2-2811a8667effd25b7de27f3c176e789326a84988.tar.bz2
gentoo-2-2811a8667effd25b7de27f3c176e789326a84988.zip
Convert to distutils-r1.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bittorrent/ChangeLog7
-rw-r--r--net-p2p/bittorrent/bittorrent-4.4.0-r3.ebuild86
2 files changed, 92 insertions, 1 deletions
diff --git a/net-p2p/bittorrent/ChangeLog b/net-p2p/bittorrent/ChangeLog
index 30cb6996d022..bea95bc6d3d2 100644
--- a/net-p2p/bittorrent/ChangeLog
+++ b/net-p2p/bittorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/bittorrent
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/ChangeLog,v 1.152 2014/03/09 03:44:03 rhill Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/ChangeLog,v 1.153 2014/12/25 10:47:23 mgorny Exp $
+
+*bittorrent-4.4.0-r3 (25 Dec 2014)
+
+ 25 Dec 2014; Michał Górny <mgorny@gentoo.org> +bittorrent-4.4.0-r3.ebuild:
+ Convert to distutils-r1.
09 Mar 2014; Ryan Hill <rhill@gentoo.org> metadata.xml:
Change my email.
diff --git a/net-p2p/bittorrent/bittorrent-4.4.0-r3.ebuild b/net-p2p/bittorrent/bittorrent-4.4.0-r3.ebuild
new file mode 100644
index 000000000000..f8db613a8183
--- /dev/null
+++ b/net-p2p/bittorrent/bittorrent-4.4.0-r3.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/bittorrent-4.4.0-r3.ebuild,v 1.1 2014/12/25 10:47:23 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE='threads'
+
+# Maintainer note:
+# keep this package at 4.4.0.
+# 5.x - requires wxpython-2.6 which we don't carry
+# 6.x - binary-only non-free crap
+# Fedora has also frozen bittorrent at 4.4.0 and is a good source of patches
+# http://pkgs.fedoraproject.org/gitweb/?p=bittorrent.git
+
+inherit distutils-r1 eutils fdo-mime
+
+MY_P="${P/bittorrent/BitTorrent}"
+
+DESCRIPTION="Tool for distributing files via a distributed network of nodes"
+HOMEPAGE="http://www.bittorrent.com/"
+SRC_URI="http://www.bittorrent.com/dl/${MY_P}.tar.gz"
+
+LICENSE="BitTorrent"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+IUSE="aqua gtk"
+
+RDEPEND=">=dev-python/pycrypto-2.0[${PYTHON_USEDEP}]
+ gtk? ( >=x11-libs/gtk+-2.6:2
+ >=dev-python/pygtk-2.6:2[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}"
+# dev-python/dnspython"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( credits.txt credits-l10n.txt README.txt TRACKERLESS.txt )
+
+python_prepare_all() {
+ epatch "${FILESDIR}"/${P}-no-version-check.patch
+ epatch "${FILESDIR}"/${P}-pkidir.patch
+ epatch "${FILESDIR}"/${P}-fastresume.patch
+ epatch "${FILESDIR}"/${P}-pygtk-thread-warnings.patch
+ epatch "${FILESDIR}"/${P}-python26-syntax.patch
+ epatch "${FILESDIR}"/${P}-bencode-float.patch
+ epatch "${FILESDIR}"/${P}-keyerror.patch
+ epatch "${FILESDIR}"/${P}-hashlib.patch
+
+ # fix doc path #109743
+ sed -i -e "/dp.*appdir/ s:appdir:'${PF}':" BitTorrent/platform.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ if ! use gtk && ! use aqua; then
+ rm -f "${ED}"usr/bn/{bit,make}torrent || die
+ rm -f "${D}$(python_get_scriptdir)"/{bit,make}torrent || die
+ fi
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use gtk; then
+ doicon images/bittorrent.ico
+ domenu "${FILESDIR}"/${PN}.desktop
+ fi
+
+ insinto /etc/pki/bittorrent/
+ doins public.key
+
+ newinitd "${FILESDIR}"/bittorrent-tracker.initd bittorrent-tracker
+ newconfd "${FILESDIR}"/bittorrent-tracker.confd bittorrent-tracker
+}
+
+pkg_postinst() {
+ use gtk && fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ use gtk && fdo-mime_desktop_database_update
+}