summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2006-08-11 12:36:04 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2006-08-11 12:36:04 +0000
commit80679614cb398f75a623173af1f86b2b5bc6456d (patch)
treebde0f92c7021df0eb722241322ccaafe73170e3f /net-p2p
parentStable on sparc. Works fine, so this is mostly bookkeeping. (diff)
downloadgentoo-2-80679614cb398f75a623173af1f86b2b5bc6456d.tar.gz
gentoo-2-80679614cb398f75a623173af1f86b2b5bc6456d.tar.bz2
gentoo-2-80679614cb398f75a623173af1f86b2b5bc6456d.zip
Added MimeType for application/x-bittorrent to the installed desktop entry. Fixes bug #143486. Thanks to <nathanegge@yahoo.com>.
(Portage version: 2.1.1_pre4-r2)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/azureus/ChangeLog9
-rw-r--r--net-p2p/azureus/azureus-2.4.0.2-r2.ebuild123
-rw-r--r--net-p2p/azureus/files/azureus.desktop1
-rw-r--r--net-p2p/azureus/files/digest-azureus-2.4.0.2-r23
4 files changed, 135 insertions, 1 deletions
diff --git a/net-p2p/azureus/ChangeLog b/net-p2p/azureus/ChangeLog
index dd7c057fd0f0..15d946919386 100644
--- a/net-p2p/azureus/ChangeLog
+++ b/net-p2p/azureus/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-p2p/azureus
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus/ChangeLog,v 1.21 2006/08/05 13:06:58 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus/ChangeLog,v 1.22 2006/08/11 12:36:04 betelgeuse Exp $
+
+*azureus-2.4.0.2-r2 (11 Aug 2006)
+
+ 11 Aug 2006; Petteri Räty <betelgeuse@gentoo.org> files/azureus.desktop,
+ +azureus-2.4.0.2-r2.ebuild:
+ Added MimeType for application/x-bittorrent to the installed desktop entry.
+ Fixes bug #143486. Thanks to <nathanegge@yahoo.com>.
05 Aug 2006; Tobias Scherbaum <dertobi123@gentoo.org>
azureus-2.4.0.2-r1.ebuild:
diff --git a/net-p2p/azureus/azureus-2.4.0.2-r2.ebuild b/net-p2p/azureus/azureus-2.4.0.2-r2.ebuild
new file mode 100644
index 000000000000..c82e1ed4be8a
--- /dev/null
+++ b/net-p2p/azureus/azureus-2.4.0.2-r2.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus/azureus-2.4.0.2-r2.ebuild,v 1.1 2006/08/11 12:36:04 betelgeuse Exp $
+
+inherit eutils fdo-mime java-pkg-2 java-ant-2
+
+DESCRIPTION="Azureus - Java BitTorrent Client"
+HOMEPAGE="http://azureus.sourceforge.net/"
+SRC_URI="mirror://sourceforge/azureus/Azureus_${PV}_source.zip"
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="source"
+
+RDEPEND=">=virtual/jre-1.4
+ >dev-java/swt-3.2_pre1
+ >=dev-java/log4j-1.2.8
+ >=dev-java/commons-cli-1.0
+ >=dev-java/bcprov-1.31
+ !net-p2p/azureus-bin"
+DEPEND=">=virtual/jdk-1.4
+ ${RDEPEND}
+ dev-util/desktop-file-utils
+ >=dev-java/ant-core-1.6.2
+ amd64? ( =dev-java/eclipse-ecj-3.1* )
+ >=app-arch/unzip-5.0"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ mkdir ${S}
+ cd ${S}
+ unpack ${A}
+
+ EPATCH_SUFFIX="patch" EPATCH_FORCE="yes" \
+ epatch ${FILESDIR}/fedora/
+
+ # patch to make hide popup buttons work again with >=gtk+-2.8.17
+ # see bug #132578
+ # courtesy of debian, taken from their azureus_2.4.0.2-3.diff.gz
+ epatch ${FILESDIR}/${P}-popup-hide-debian.patch
+
+ #removing osx files and entries
+ rm -fr org/gudy/azureus2/ui/swt/osx org/gudy/azureus2/platform/macosx
+ #removing windows files
+ rm -fr org/gudy/azureus2/platform/win32
+ #removing test files
+ rm -fr org/gudy/azureus2/ui/swt/test
+ rm -f org/gudy/azureus2/ui/console/multiuser/TestUserManager.java
+ #removing bouncycastle
+ rm -fr org/bouncycastle
+
+ mkdir -p build/libs
+ cd build/libs
+ java-pkg_jar-from log4j
+ java-pkg_jar-from commons-cli-1
+ java-pkg_jar-from swt-3
+ java-pkg_jar-from bcprov
+}
+
+src_compile() {
+ # TODO test if this is still needed, and if so, use java-config --runtime
+ # instead
+ # Figure out correct boot classpath for IBM jdk.
+ if [ ! -z "$(java-config --java-version | grep IBM)" ] ; then
+ # IBM JRE
+ ant_extra_opts="-Dbootclasspath=$(java-config --jdk-home)/jre/lib/core.jar:$(java-config --jdk-home)/jre/lib/xml.jar:$(java-config --jdk-home)/jre/lib/graphics.jar"
+ fi
+
+ # amd64 runs out of memory with javac... use ecj instead
+ use amd64 && java-pkg_force-compiler ecj-3.1
+
+ eant ${ant_extra_opts} jar
+}
+
+src_install() {
+ java-pkg_dojar dist/Azureus2.jar || die "dojar failed"
+
+
+ java-pkg_dolauncher ${PN} \
+ --main org.gudy.azureus2.ui.swt.Main \
+ -pre ${FILESDIR}/${P}-pre
+
+ doicon "${FILESDIR}/azureus.png"
+ domenu "${FILESDIR}/azureus.desktop"
+ use source && java-pkg_dosrc ${S}/{com,org}
+}
+
+pkg_postinst() {
+ echo
+ einfo "Due to the nature of the portage system, we recommend"
+ einfo "that users check portage for new versions of Azureus"
+ einfo "instead of attempting to use the auto-update feature."
+ einfo "You can disable auto-update in"
+ einfo "Tools->Options...->Interface->Start"
+ echo
+ einfo "After running azureus for the first time, configuration"
+ einfo "options will be placed in ~/.azureus/gentoo.config"
+ einfo "It is recommended that you modify this file rather than"
+ einfo "the azureus startup script directly."
+ echo
+ einfo "As of this version, the new ui type 'console' is supported,"
+ einfo "and this may be set in ~/.azureus/gentoo.config."
+ echo
+ ewarn "If you are upgrading, and the menu in azureus has entries like"
+ ewarn "\"!MainWindow.menu.transfers!\" then you have a stray"
+ ewarn "MessageBundle.properties file,"
+ ewarn "and you may safely delete ~/.azureus/MessagesBundle.properties"
+ echo
+ einfo "It's recommended to use Sun's Java version 1.5 or later."
+ einfo "If you're experiencing problems running azureus and you've"
+ einfo "using an older version of Java, try to upgrading to a new version. "
+ echo
+ ewarn "Please, do not run azureus as root!"
+ ewarn "Azureus has not been developed for multi-user environments!"
+
+ fdo-mime_desktop_database_update
+}
+
+pkg_prerm() {
+ fdo-mime_desktop_database_update
+}
diff --git a/net-p2p/azureus/files/azureus.desktop b/net-p2p/azureus/files/azureus.desktop
index 7a45c5e9d52d..c1d77563fe0a 100644
--- a/net-p2p/azureus/files/azureus.desktop
+++ b/net-p2p/azureus/files/azureus.desktop
@@ -6,3 +6,4 @@ Icon=azureus.png
Terminal=0
Categories=Application;Network;
Type=Application
+MimeType=application/x-bittorrent
diff --git a/net-p2p/azureus/files/digest-azureus-2.4.0.2-r2 b/net-p2p/azureus/files/digest-azureus-2.4.0.2-r2
new file mode 100644
index 000000000000..432788e32da0
--- /dev/null
+++ b/net-p2p/azureus/files/digest-azureus-2.4.0.2-r2
@@ -0,0 +1,3 @@
+MD5 f79a2c3664fe26a21d208551bfac4b6f Azureus_2.4.0.2_source.zip 5188679
+RMD160 60b260bc34ce06ace1ae16dad330548b2db3cea7 Azureus_2.4.0.2_source.zip 5188679
+SHA256 3c25d6560110b64acf7b395950f1b9b2553a365215a0e3fb6bce3d2414147099 Azureus_2.4.0.2_source.zip 5188679