summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-11-21 09:48:26 +0000
committerMike Frysinger <vapier@gentoo.org>2014-11-21 09:48:26 +0000
commit876cd97092229797fbfcbf2cf18472079ec4e957 (patch)
tree4cbee1d8ce5669c757252564b68c3606819bd4e6 /net-p2p
parentRename zsh-completion to gentoo-zsh-completions. (diff)
downloadgentoo-2-876cd97092229797fbfcbf2cf18472079ec4e957.tar.gz
gentoo-2-876cd97092229797fbfcbf2cf18472079ec4e957.tar.bz2
gentoo-2-876cd97092229797fbfcbf2cf18472079ec4e957.zip
Use makeopts_jobs instead of parsing MAKEOPTS by hand & note this needs converting to escons.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/linuxdcpp/ChangeLog10
-rw-r--r--net-p2p/linuxdcpp/linuxdcpp-1.0.3-r1.ebuild11
-rw-r--r--net-p2p/linuxdcpp/linuxdcpp-1.0.3.ebuild5
-rw-r--r--net-p2p/linuxdcpp/linuxdcpp-9999.ebuild11
4 files changed, 20 insertions, 17 deletions
diff --git a/net-p2p/linuxdcpp/ChangeLog b/net-p2p/linuxdcpp/ChangeLog
index 0cd79c7e5c34..b58620979bec 100644
--- a/net-p2p/linuxdcpp/ChangeLog
+++ b/net-p2p/linuxdcpp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/linuxdcpp
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/linuxdcpp/ChangeLog,v 1.44 2012/05/04 06:33:34 jdhore Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/linuxdcpp/ChangeLog,v 1.45 2014/11/21 09:48:26 vapier Exp $
+
+ 21 Nov 2014; Mike Frysinger <vapier@gentoo.org> linuxdcpp-1.0.3-r1.ebuild,
+ linuxdcpp-1.0.3.ebuild, linuxdcpp-9999.ebuild:
+ Use makeopts_jobs instead of parsing MAKEOPTS by hand & note this needs
+ converting to escons.
04 May 2012; Jeff Horelick <jdhore@gentoo.org> linuxdcpp-1.0.3.ebuild,
linuxdcpp-1.0.3-r1.ebuild, linuxdcpp-9999.ebuild:
@@ -199,4 +204,3 @@
17 Jan 2007; Raúl Porcel <armin76@gentoo.org> +metadata.xml,
+linuxdcpp-20070117.ebuild:
New ebuild, bug 102733
-
diff --git a/net-p2p/linuxdcpp/linuxdcpp-1.0.3-r1.ebuild b/net-p2p/linuxdcpp/linuxdcpp-1.0.3-r1.ebuild
index 3821579aee00..6e2b66afb5ff 100644
--- a/net-p2p/linuxdcpp/linuxdcpp-1.0.3-r1.ebuild
+++ b/net-p2p/linuxdcpp/linuxdcpp-1.0.3-r1.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/linuxdcpp/linuxdcpp-1.0.3-r1.ebuild,v 1.5 2012/05/04 06:33:34 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/linuxdcpp/linuxdcpp-1.0.3-r1.ebuild,v 1.6 2014/11/21 09:48:26 vapier Exp $
EAPI=2
-inherit eutils
+# TODO: This needs to use the escons eclass.
+inherit eutils multiprocessing
DESCRIPTION="Direct connect client, looks and works like famous DC++"
HOMEPAGE="https://launchpad.net/linuxdcpp"
@@ -29,12 +30,10 @@ src_prepare() {
}
src_compile() {
- local sconsopts=$(echo "${MAKEOPTS}" | sed -ne "/-j/ { s/.*\(-j[[:space:]]*[0-9]\+\).*/\1/; p }")
-
local myconf=""
use debug && myconf="${myconf} debug=1"
- scons ${myconf} ${sconsopts} CXXFLAGS="${CXXFLAGS}" PREFIX=/usr || die "scons failed"
+ scons ${myconf} -j$(makeopts_jobs) CXXFLAGS="${CXXFLAGS}" PREFIX=/usr || die "scons failed"
}
src_install() {
diff --git a/net-p2p/linuxdcpp/linuxdcpp-1.0.3.ebuild b/net-p2p/linuxdcpp/linuxdcpp-1.0.3.ebuild
index d0ee4354a0c9..f0f40808cbc1 100644
--- a/net-p2p/linuxdcpp/linuxdcpp-1.0.3.ebuild
+++ b/net-p2p/linuxdcpp/linuxdcpp-1.0.3.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/linuxdcpp/linuxdcpp-1.0.3.ebuild,v 1.6 2012/05/04 06:33:34 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/linuxdcpp/linuxdcpp-1.0.3.ebuild,v 1.7 2014/11/21 09:48:26 vapier Exp $
EAPI="1"
+# TODO: This needs to use the escons eclass.
inherit eutils
DESCRIPTION="Direct connect client, looks and works like famous DC++"
diff --git a/net-p2p/linuxdcpp/linuxdcpp-9999.ebuild b/net-p2p/linuxdcpp/linuxdcpp-9999.ebuild
index 472a974da007..1162a8a88400 100644
--- a/net-p2p/linuxdcpp/linuxdcpp-9999.ebuild
+++ b/net-p2p/linuxdcpp/linuxdcpp-9999.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/linuxdcpp/linuxdcpp-9999.ebuild,v 1.16 2012/05/04 06:33:34 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/linuxdcpp/linuxdcpp-9999.ebuild,v 1.17 2014/11/21 09:48:26 vapier Exp $
EAPI="1"
-inherit bzr eutils
+# TODO: This needs to use the escons eclass.
+inherit bzr eutils multiprocessing
DESCRIPTION="Direct connect client, looks and works like famous DC++"
HOMEPAGE="https://launchpad.net/linuxdcpp"
@@ -29,12 +30,10 @@ DEPEND="${RDEPEND}
>=dev-libs/boost-1.35.0-r2"
src_compile() {
- local sconsopts=$(echo "${MAKEOPTS}" | sed -ne "/-j/ { s/.*\(-j[[:space:]]*[0-9]\+\).*/\1/; p }")
-
local myconf=""
use debug && myconf="${myconf} debug=1"
- scons ${myconf} ${sconsopts} CXXFLAGS="${CXXFLAGS}" PREFIX=/usr || die "scons failed"
+ scons ${myconf} -j$(makeopts_jobs) CXXFLAGS="${CXXFLAGS}" PREFIX=/usr || die "scons failed"
}
src_install() {