summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-01-29 14:10:41 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-01-29 14:10:41 +0000
commit997dd329f9c58b413521b524f97561f0b0604326 (patch)
tree9b5044c747ae65809e53e0eb58e0db2710e7a0eb /net-p2p
parentDrop unnecessary src_configure phase, stuff gets moved from phase to phase (diff)
downloadgentoo-2-997dd329f9c58b413521b524f97561f0b0604326.tar.gz
gentoo-2-997dd329f9c58b413521b524f97561f0b0604326.tar.bz2
gentoo-2-997dd329f9c58b413521b524f97561f0b0604326.zip
Fix building with x11-libs/libnotify >= 0.7 wrt #352128 by Priit Laes.
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/transmission/ChangeLog8
-rw-r--r--net-p2p/transmission/files/transmission-2.13-libnotify-0.7.patch18
-rw-r--r--net-p2p/transmission/transmission-2.13.ebuild6
3 files changed, 28 insertions, 4 deletions
diff --git a/net-p2p/transmission/ChangeLog b/net-p2p/transmission/ChangeLog
index a743267d0d87..8f1d59d6fb3c 100644
--- a/net-p2p/transmission/ChangeLog
+++ b/net-p2p/transmission/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/transmission
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/ChangeLog,v 1.137 2010/12/20 00:52:36 hwoarang Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/ChangeLog,v 1.138 2011/01/29 14:10:41 ssuominen Exp $
+
+ 29 Jan 2011; Samuli Suominen <ssuominen@gentoo.org> transmission-2.13.ebuild,
+ +files/transmission-2.13-libnotify-0.7.patch:
+ Fix building with x11-libs/libnotify >= 0.7 wrt #352128 by Priit Laes.
20 Dec 2010; Markos Chandras <hwoarang@gentoo.org> transmission-2.12.ebuild:
Stable on amd64 wrt bug #349079
diff --git a/net-p2p/transmission/files/transmission-2.13-libnotify-0.7.patch b/net-p2p/transmission/files/transmission-2.13-libnotify-0.7.patch
new file mode 100644
index 000000000000..7e92ededae6c
--- /dev/null
+++ b/net-p2p/transmission/files/transmission-2.13-libnotify-0.7.patch
@@ -0,0 +1,18 @@
+http://bugs.gentoo.org/352128
+
+--- gtk/notify.c
++++ gtk/notify.c
+@@ -160,7 +160,12 @@ tr_notify_added( const char * name )
+ if( pref_flag_get( PREF_KEY_SHOW_DESKTOP_NOTIFICATION ) )
+ {
+ NotifyNotification * n = notify_notification_new(
+- _( "Torrent Added" ), name, NULL, NULL );
++ _( "Torrent Added" ), name, NULL
++/* the fourth argument was removed in libnotify 0.7.0 */
++#if !defined(NOTIFY_VERSION_MINOR) || (NOTIFY_VERSION_MAJOR == 0 && NOTIFY_VERSION_MINOR < 7)
++ , NULL
++#endif
++ );
+ addIcon( n );
+ notify_notification_set_timeout( n, NOTIFY_EXPIRES_DEFAULT );
+ notify_notification_show( n, NULL );
diff --git a/net-p2p/transmission/transmission-2.13.ebuild b/net-p2p/transmission/transmission-2.13.ebuild
index 7dd0be753c93..c631b62cae6f 100644
--- a/net-p2p/transmission/transmission-2.13.ebuild
+++ b/net-p2p/transmission/transmission-2.13.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/transmission-2.13.ebuild,v 1.1 2010/12/19 14:44:51 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/transmission-2.13.ebuild,v 1.2 2011/01/29 14:10:41 ssuominen Exp $
EAPI=2
inherit eutils fdo-mime gnome2-utils qt4-r2
@@ -41,6 +41,8 @@ pkg_setup() {
}
src_prepare() {
+ epatch "${FILESDIR}"/${P}-libnotify-0.7.patch
+
sed -i -e 's:-ggdb3::g' configure || die
# Magnet link support
if use kde; then