summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-08-16 18:39:15 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-08-16 18:39:15 +0000
commitb3a5b67cc1fd0dfb30d6da5e9118dceb12c04563 (patch)
treec01ef1697f8102757bfc9b5da06d824d2c6ad20e /net-p2p
parentMask dev-ruby/programming-ruby (diff)
downloadgentoo-2-b3a5b67cc1fd0dfb30d6da5e9118dceb12c04563.tar.gz
gentoo-2-b3a5b67cc1fd0dfb30d6da5e9118dceb12c04563.tar.bz2
gentoo-2-b3a5b67cc1fd0dfb30d6da5e9118dceb12c04563.zip
Fix bashcompletion
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bitcoind/ChangeLog6
-rw-r--r--net-p2p/bitcoind/bitcoind-0.8.3-r1.ebuild7
-rw-r--r--net-p2p/bitcoind/bitcoind-0.8.3.ebuild7
3 files changed, 11 insertions, 9 deletions
diff --git a/net-p2p/bitcoind/ChangeLog b/net-p2p/bitcoind/ChangeLog
index 7c862a6b7ebe..11b87b6b000c 100644
--- a/net-p2p/bitcoind/ChangeLog
+++ b/net-p2p/bitcoind/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/bitcoind
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/ChangeLog,v 1.69 2013/08/03 16:25:04 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/ChangeLog,v 1.70 2013/08/16 18:39:15 blueness Exp $
+
+ 16 Aug 2013; Anthony G. Basile <blueness@gentoo.org> bitcoind-0.8.3-r1.ebuild,
+ bitcoind-0.8.3.ebuild:
+ Fix bashcompletion
03 Aug 2013; Anthony G. Basile <blueness@gentoo.org>
files/0.8.2-sys_leveldb.patch:
diff --git a/net-p2p/bitcoind/bitcoind-0.8.3-r1.ebuild b/net-p2p/bitcoind/bitcoind-0.8.3-r1.ebuild
index e88955ca66b1..77e11f1de543 100644
--- a/net-p2p/bitcoind/bitcoind-0.8.3-r1.ebuild
+++ b/net-p2p/bitcoind/bitcoind-0.8.3-r1.ebuild
@@ -1,12 +1,12 @@
# Copyright 2010-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.8.3-r1.ebuild,v 1.1 2013/07/27 07:26:40 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.8.3-r1.ebuild,v 1.2 2013/08/16 18:39:15 blueness Exp $
EAPI="4"
DB_VER="4.8"
-inherit db-use eutils versionator systemd toolchain-funcs
+inherit bash-completion-r1 db-use eutils versionator systemd toolchain-funcs
MyPV="${PV/_/}"
MyPN="bitcoin"
@@ -107,8 +107,7 @@ src_install() {
doman contrib/debian/manpages/{bitcoind.1,bitcoin.conf.5}
if use bash-completion; then
- insinto /usr/share/bash-completion
- newins contrib/bitcoind.bash-completion bitcoind
+ newbashcomp contrib/${PN}.bash-completion ${PN}
fi
if use examples; then
diff --git a/net-p2p/bitcoind/bitcoind-0.8.3.ebuild b/net-p2p/bitcoind/bitcoind-0.8.3.ebuild
index 828838fb34a3..b4af83020286 100644
--- a/net-p2p/bitcoind/bitcoind-0.8.3.ebuild
+++ b/net-p2p/bitcoind/bitcoind-0.8.3.ebuild
@@ -1,12 +1,12 @@
# Copyright 2010-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.8.3.ebuild,v 1.1 2013/07/16 10:18:50 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.8.3.ebuild,v 1.2 2013/08/16 18:39:15 blueness Exp $
EAPI="4"
DB_VER="4.8"
-inherit db-use eutils versionator toolchain-funcs
+inherit bash-completion-r1 db-use eutils versionator toolchain-funcs
MyPV="${PV/_/}"
MyPN="bitcoin"
@@ -106,8 +106,7 @@ src_install() {
doman contrib/debian/manpages/{bitcoind.1,bitcoin.conf.5}
if use bash-completion; then
- insinto /usr/share/bash-completion
- newins contrib/bitcoind.bash-completion bitcoind
+ newbashcomp contrib/${PN}.bash-completion ${PN}
fi
if use examples; then