summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-09-09 12:57:37 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-09-09 12:57:37 +0000
commitd921440a879292e64206299cef2e2b9fc363025e (patch)
treec89f09e377a237550d849fdd192c4fe4e14a253f /net-p2p
parentAdded ipod detection patch from Frittella Laurento <mrfree@infinito.it>. (diff)
downloadgentoo-2-d921440a879292e64206299cef2e2b9fc363025e.tar.gz
gentoo-2-d921440a879292e64206299cef2e2b9fc363025e.tar.bz2
gentoo-2-d921440a879292e64206299cef2e2b9fc363025e.zip
Add missing build-time dependency on bc as per bug #146845.
(Portage version: 2.1.1)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/rtorrent/ChangeLog6
-rw-r--r--net-p2p/rtorrent/rtorrent-0.6.0.ebuild6
-rw-r--r--net-p2p/rtorrent/rtorrent-0.6.1.ebuild6
3 files changed, 13 insertions, 5 deletions
diff --git a/net-p2p/rtorrent/ChangeLog b/net-p2p/rtorrent/ChangeLog
index 0508b3a0ed2b..738ce2015fb1 100644
--- a/net-p2p/rtorrent/ChangeLog
+++ b/net-p2p/rtorrent/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/rtorrent
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.57 2006/09/09 12:23:09 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.58 2006/09/09 12:57:37 flameeyes Exp $
+
+ 09 Sep 2006; Diego Pettenò <flameeyes@gentoo.org> rtorrent-0.6.0.ebuild,
+ rtorrent-0.6.1.ebuild:
+ Add missing build-time dependency on bc as per bug #146845.
09 Sep 2006; Torsten Veller <tove@gentoo.org> rtorrent-0.6.0.ebuild:
Stable on x86 (#146845)
diff --git a/net-p2p/rtorrent/rtorrent-0.6.0.ebuild b/net-p2p/rtorrent/rtorrent-0.6.0.ebuild
index 6ada1417b8e6..b512982af072 100644
--- a/net-p2p/rtorrent/rtorrent-0.6.0.ebuild
+++ b/net-p2p/rtorrent/rtorrent-0.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.6.0.ebuild,v 1.4 2006/09/09 12:23:09 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.6.0.ebuild,v 1.5 2006/09/09 12:57:37 flameeyes Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -13,10 +13,12 @@ SLOT="0"
KEYWORDS="amd64 ~ppc ppc64 ~sparc x86 ~x86-fbsd"
IUSE="debug"
-DEPEND=">=net-libs/libtorrent-0.10.0
+RDEPEND=">=net-libs/libtorrent-0.10.0
>=dev-libs/libsigc++-2.0
>=net-misc/curl-7.12
sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ sys-devel/bc"
src_compile() {
[[ $(tc-arch) = "x86" ]] && filter-flags -fomit-frame-pointer
diff --git a/net-p2p/rtorrent/rtorrent-0.6.1.ebuild b/net-p2p/rtorrent/rtorrent-0.6.1.ebuild
index 64a5a57f50e9..99b3b00b9918 100644
--- a/net-p2p/rtorrent/rtorrent-0.6.1.ebuild
+++ b/net-p2p/rtorrent/rtorrent-0.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.6.1.ebuild,v 1.2 2006/09/02 12:25:17 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.6.1.ebuild,v 1.3 2006/09/09 12:57:37 flameeyes Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -13,10 +13,12 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="debug"
-DEPEND=">=net-libs/libtorrent-0.10.1
+RDEPEND=">=net-libs/libtorrent-0.10.1
>=dev-libs/libsigc++-2.0
>=net-misc/curl-7.12
sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ sys-devel/bc"
src_compile() {
[[ $(tc-arch) = "x86" ]] && filter-flags -fomit-frame-pointer