summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-04-10 09:02:48 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-04-10 09:02:48 +0000
commite65e8e7140153f7e2a80335ab32445867989ec2c (patch)
tree249e8bc0fd062764e95ac11ea0f32b55d521c1dc /net-p2p
parentMask new qbittorrent beta releases (diff)
downloadgentoo-2-e65e8e7140153f7e2a80335ab32445867989ec2c.tar.gz
gentoo-2-e65e8e7140153f7e2a80335ab32445867989ec2c.tar.bz2
gentoo-2-e65e8e7140153f7e2a80335ab32445867989ec2c.zip
Version bump
(Portage version: 2.1.9.44/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/ChangeLog8
-rw-r--r--net-p2p/qbittorrent/qbittorrent-2.8.0_beta1.ebuild62
2 files changed, 69 insertions, 1 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index 17849c0019d6..762dd18b32c2 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/qbittorrent
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.147 2011/04/08 07:52:10 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.148 2011/04/10 09:02:48 hwoarang Exp $
+
+*qbittorrent-2.8.0_beta1 (10 Apr 2011)
+
+ 10 Apr 2011; Markos Chandras <hwoarang@gentoo.org>
+ +qbittorrent-2.8.0_beta1.ebuild:
+ Version bump
08 Apr 2011; Markos Chandras <hwoarang@gentoo.org> qbittorrent-2.7.2.ebuild,
qbittorrent-9999.ebuild:
diff --git a/net-p2p/qbittorrent/qbittorrent-2.8.0_beta1.ebuild b/net-p2p/qbittorrent/qbittorrent-2.8.0_beta1.ebuild
new file mode 100644
index 000000000000..6c480e22d905
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-2.8.0_beta1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-2.8.0_beta1.ebuild,v 1.1 2011/04/10 09:02:48 hwoarang Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+
+inherit python qt4-r2 versionator
+
+MY_P="${P/_/}"
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="http://www.qbittorrent.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus +X geoip"
+
+QT_MIN="4.7.1"
+# boost version so that we always have thread support
+CDEPEND="net-libs/rb_libtorrent
+ >=x11-libs/qt-core-${QT_MIN}:4
+ X? ( >=x11-libs/qt-gui-${QT_MIN}:4 )
+ dbus? ( >=x11-libs/qt-dbus-${QT_MIN}:4 )
+ dev-libs/boost"
+DEPEND="${CDEPEND}
+ dev-util/pkgconfig"
+RDEPEND="${CDEPEND}
+ geoip? ( dev-libs/geoip )"
+
+DOCS="AUTHORS Changelog NEWS README TODO"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # Respect LDFLAGS
+ sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ local myconf
+ use X || myconf+=" --disable-gui"
+ use geoip || myconf+=" --disable-geoip-database"
+ use dbus || myconf+=" --disable-qt-dbus"
+
+ # slotted boost detection, bug #309415
+ BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ myconf+=" --with-libboost-inc=/usr/include/boost-${BOOST_VER}"
+
+ # econf fails, since this uses qconf
+ ./configure --prefix=/usr --qtdir=/usr ${myconf} || die "configure failed"
+ eqmake4
+}