summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-10-02 10:11:03 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-10-02 10:11:03 +0000
commitf2dd0022720f76302f87f5520368e7293984ed33 (patch)
treedb0e118c1333beecc4718bfbb7be146570ee502c /net-p2p
parents390 stable (diff)
downloadgentoo-2-f2dd0022720f76302f87f5520368e7293984ed33.tar.gz
gentoo-2-f2dd0022720f76302f87f5520368e7293984ed33.tar.bz2
gentoo-2-f2dd0022720f76302f87f5520368e7293984ed33.zip
Version bump
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bitcoind/ChangeLog8
-rw-r--r--net-p2p/bitcoind/bitcoind-0.9.3.ebuild112
-rw-r--r--net-p2p/bitcoind/metadata.xml1
3 files changed, 120 insertions, 1 deletions
diff --git a/net-p2p/bitcoind/ChangeLog b/net-p2p/bitcoind/ChangeLog
index 6c18c2a69757..b3ba3be7c233 100644
--- a/net-p2p/bitcoind/ChangeLog
+++ b/net-p2p/bitcoind/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/bitcoind
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/ChangeLog,v 1.89 2014/08/29 00:46:19 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/ChangeLog,v 1.90 2014/10/02 10:11:03 blueness Exp $
+
+*bitcoind-0.9.3 (02 Oct 2014)
+
+ 02 Oct 2014; Anthony G. Basile <blueness@gentoo.org> +bitcoind-0.9.3.ebuild,
+ metadata.xml:
+ Version bump
29 Aug 2014; Anthony G. Basile <blueness@gentoo.org> bitcoind-0.9.2.1.ebuild:
Switch from einstall to emake, bug #521440
diff --git a/net-p2p/bitcoind/bitcoind-0.9.3.ebuild b/net-p2p/bitcoind/bitcoind-0.9.3.ebuild
new file mode 100644
index 000000000000..422189c6ed7e
--- /dev/null
+++ b/net-p2p/bitcoind/bitcoind-0.9.3.ebuild
@@ -0,0 +1,112 @@
+# Copyright 2010-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.9.3.ebuild,v 1.1 2014/10/02 10:11:03 blueness Exp $
+
+EAPI=4
+
+DB_VER="4.8"
+
+inherit autotools bash-completion-r1 db-use eutils user versionator systemd
+
+MyPV="${PV/_/}"
+MyPN="bitcoin"
+MyP="${MyPN}-${MyPV}"
+LJR_PV="${PV}.ljr20141002"
+LJR_PATCH="bitcoin-${LJR_PV}.patch"
+
+DESCRIPTION="Original Bitcoin crypto-currency wallet for automated services"
+HOMEPAGE="http://bitcoin.org/"
+SRC_URI="https://github.com/${MyPN}/${MyPN}/archive/v${MyPV}.tar.gz -> ${MyPN}-v${PV}.tgz
+ ljr? ( http://luke.dashjr.org/programs/bitcoin/files/bitcoind/luke-jr/0.9.x/${LJR_PV}/${LJR_PATCH}.xz )
+"
+
+LICENSE="MIT ISC GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="examples +ljr logrotate test upnp +wallet"
+
+RDEPEND="
+ >=dev-libs/boost-1.53.0[threads(+)]
+ dev-libs/openssl:0[-bindist]
+ logrotate? (
+ app-admin/logrotate
+ )
+ upnp? (
+ net-libs/miniupnpc
+ )
+ wallet? (
+ sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
+ )
+ virtual/bitcoin-leveldb
+"
+DEPEND="${RDEPEND}
+ >=app-shells/bash-4.1
+ sys-apps/sed
+"
+
+S="${WORKDIR}/${MyP}"
+
+pkg_setup() {
+ local UG='bitcoin'
+ enewgroup "${UG}"
+ enewuser "${UG}" -1 -1 /var/lib/bitcoin "${UG}"
+}
+
+src_prepare() {
+ if use ljr; then
+ epatch "${WORKDIR}/${LJR_PATCH}"
+ else
+ epatch "${FILESDIR}/0.9.0-sys_leveldb.patch"
+ fi
+ rm -r src/leveldb
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with upnp miniupnpc) $(use_enable upnp upnp-default) \
+ $(use_enable test tests) \
+ $(use_enable wallet) \
+ --with-system-leveldb \
+ --without-cli \
+ --without-gui
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ insinto /etc/bitcoin
+ newins "${FILESDIR}/bitcoin.conf" bitcoin.conf
+ fowners bitcoin:bitcoin /etc/bitcoin/bitcoin.conf
+ fperms 600 /etc/bitcoin/bitcoin.conf
+
+ newconfd "${FILESDIR}/bitcoin.confd" ${PN}
+ newinitd "${FILESDIR}/bitcoin.initd-r1" ${PN}
+ systemd_dounit "${FILESDIR}/bitcoind.service"
+
+ keepdir /var/lib/bitcoin/.bitcoin
+ fperms 700 /var/lib/bitcoin
+ fowners bitcoin:bitcoin /var/lib/bitcoin/
+ fowners bitcoin:bitcoin /var/lib/bitcoin/.bitcoin
+ dosym /etc/bitcoin/bitcoin.conf /var/lib/bitcoin/.bitcoin/bitcoin.conf
+
+ dodoc doc/README.md doc/release-notes.md
+ dodoc doc/assets-attribution.md doc/tor.md
+ doman contrib/debian/manpages/{bitcoind.1,bitcoin.conf.5}
+
+ newbashcomp contrib/${PN}.bash-completion ${PN}
+
+ if use examples; then
+ docinto examples
+ dodoc -r contrib/{bitrpc,pyminer,qos,spendfrom,tidy_datadir.sh}
+ fi
+
+ if use logrotate; then
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/bitcoind.logrotate" bitcoind
+ fi
+}
diff --git a/net-p2p/bitcoind/metadata.xml b/net-p2p/bitcoind/metadata.xml
index d4285805920e..55f71df5bd2b 100644
--- a/net-p2p/bitcoind/metadata.xml
+++ b/net-p2p/bitcoind/metadata.xml
@@ -11,6 +11,7 @@
<name>Luke Dashjr</name>
</maintainer>
<use>
+ <flag name='ljr'>Enable Luke Dashjr's patches</flag>
<flag name='logrotate'>Use app-admin/logrotate for rotating logs</flag>
<flag name='upnp'>Enable Universal Plug and Play</flag>
<flag name='wallet'>Enable wallet support</flag>