summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Gurr <tgurr@gentoo.org>2008-07-15 20:42:16 +0000
committerTimo Gurr <tgurr@gentoo.org>2008-07-15 20:42:16 +0000
commit59ec193078522d86d012abe6b33f7383a83af3f4 (patch)
tree6a013bac73203a5a05f7b7d3005097f506e538d2 /net-print/cups-pdf
parentFix compilation with -x86emu and klibc-1.5.12 (bug #231839). (diff)
downloadgentoo-2-59ec193078522d86d012abe6b33f7383a83af3f4.tar.gz
gentoo-2-59ec193078522d86d012abe6b33f7383a83af3f4.tar.bz2
gentoo-2-59ec193078522d86d012abe6b33f7383a83af3f4.zip
Version bump.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-gentoo-r5 x86_64)
Diffstat (limited to 'net-print/cups-pdf')
-rw-r--r--net-print/cups-pdf/ChangeLog7
-rw-r--r--net-print/cups-pdf/cups-pdf-2.4.8.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/net-print/cups-pdf/ChangeLog b/net-print/cups-pdf/ChangeLog
index 6c445426f3bc..bf95d066a152 100644
--- a/net-print/cups-pdf/ChangeLog
+++ b/net-print/cups-pdf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-print/cups-pdf
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/cups-pdf/ChangeLog,v 1.36 2008/06/01 20:36:40 tgurr Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups-pdf/ChangeLog,v 1.37 2008/07/15 20:42:16 tgurr Exp $
+
+*cups-pdf-2.4.8 (15 Jul 2008)
+
+ 15 Jul 2008; Timo Gurr <tgurr@gentoo.org> +cups-pdf-2.4.8.ebuild:
+ Version bump.
*cups-pdf-2.4.7 (01 Jun 2008)
diff --git a/net-print/cups-pdf/cups-pdf-2.4.8.ebuild b/net-print/cups-pdf/cups-pdf-2.4.8.ebuild
new file mode 100644
index 000000000000..181ef8eae6b2
--- /dev/null
+++ b/net-print/cups-pdf/cups-pdf-2.4.8.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups-pdf/cups-pdf-2.4.8.ebuild,v 1.1 2008/07/15 20:42:16 tgurr Exp $
+
+inherit toolchain-funcs multilib
+
+DESCRIPTION="Provides a virtual printer for CUPS to produce PDF files."
+HOMEPAGE="http://www.cups-pdf.de/"
+SRC_URI="http://www.cups-pdf.de/src/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="net-print/cups
+ virtual/ghostscript"
+
+src_compile() {
+ cd src
+ $(tc-getCC) ${CFLAGS} -o cups-pdf cups-pdf.c || die "Compilation failed."
+}
+
+src_install () {
+ exeinto $(cups-config --serverbin)/backend
+ has_version '>=net-print/cups-1.2' && exeopts -m0700
+ doexe src/cups-pdf
+
+ insinto /usr/share/cups/model
+ doins extra/CUPS-PDF.ppd
+
+ insinto /etc/cups
+ doins extra/cups-pdf.conf
+
+ dodoc ChangeLog README
+ newdoc contrib/Contents contrib_Contents
+}
+
+pkg_postinst () {
+ einfo "Please view both the README and contrib_Contents files"
+ einfo "as you may want to adjust some settings and/or use"
+ einfo "contributed software. In the latter case you may need"
+ einfo "to extract some files from the ${P} distfile."
+}