summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-10-30 17:17:55 +0000
committerNick Hadaway <raker@gentoo.org>2002-10-30 17:17:55 +0000
commit1bd2e9bec99039d4a41710cce5b3de2a7f9c8a20 (patch)
tree2bd2969921f1e821324957fa74e8661444216fb0 /net-print/gtklp
parentFix for #9760 (diff)
downloadgentoo-2-1bd2e9bec99039d4a41710cce5b3de2a7f9c8a20.tar.gz
gentoo-2-1bd2e9bec99039d4a41710cce5b3de2a7f9c8a20.tar.bz2
gentoo-2-1bd2e9bec99039d4a41710cce5b3de2a7f9c8a20.zip
Marked as stable. See bug #9404 for details.
Diffstat (limited to 'net-print/gtklp')
-rw-r--r--net-print/gtklp/ChangeLog9
-rw-r--r--net-print/gtklp/gtklp-0.9m.ebuild24
2 files changed, 18 insertions, 15 deletions
diff --git a/net-print/gtklp/ChangeLog b/net-print/gtklp/ChangeLog
index eaec9e5af869..a88566e16b94 100644
--- a/net-print/gtklp/ChangeLog
+++ b/net-print/gtklp/ChangeLog
@@ -1,12 +1,15 @@
# ChangeLog for net-print/gtklp
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-print/gtklp/ChangeLog,v 1.5 2002/10/22 17:07:24 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/gtklp/ChangeLog,v 1.6 2002/10/30 17:17:55 raker Exp $
*gtklp-0.9m (22 Oct 2002)
- 22 Oct 2002; Seemant Kulleen <seemant@gentoo.org> gtklp-9.0m.ebuild
- files/digest-gtklp-0.9m :
+ 30 Oct 2002; Nick Hadaway <raker@gentoo.org> gtklp-0.9m.ebuild :
+ Marking 0.9m as stable. Re-enabling the nls use variable support.
+ See bug #9404 for details.
+ 22 Oct 2002; Seemant Kulleen <seemant@gentoo.org> gtklp-0.9m.ebuild,
+ files/digest-gtklp-0.9m :
OK, the issue from bug #9404 is a gettext issue, and upstream has no idea
what to do about it yet. I guess we wait for a fix or get someone to hack
us one.
diff --git a/net-print/gtklp/gtklp-0.9m.ebuild b/net-print/gtklp/gtklp-0.9m.ebuild
index b8bb819408dd..58546b293c77 100644
--- a/net-print/gtklp/gtklp-0.9m.ebuild
+++ b/net-print/gtklp/gtklp-0.9m.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/gtklp/gtklp-0.9m.ebuild,v 1.1 2002/10/22 17:19:20 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/gtklp/gtklp-0.9m.ebuild,v 1.2 2002/10/30 17:17:55 raker Exp $
inherit libtool
@@ -10,34 +10,34 @@ SRC_URI="http://www.stud.uni-hannover.de/~sirtobi/gtklp/files/${P}.src.tar.gz"
HOMEPAGE="http://www.stud.uni-hannover.de/~sirtobi/gtklp"
SLOT="0"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="x86 ppc"
LICENSE="GPL-2"
DEPEND="=x11-libs/gtk+-1.2*
- >=net-print/cups-1.1.7"
-
-RDEPEND="sys-devel/gettext"
+ >=net-print/cups-1.1.7
+ nls? ( sys-devel/gettext )
+ ssl? ( dev-libs/openssl )"
src_compile() {
elibtoolize
local myconf
- # Upstream informs me that there are issues with disabling NLS, because
- # of gettext versions.
-# use nls \
-# && myconf="${myconf} --enable-nls" \
-# || myconf="${myconf} --disable-nls"
+ use nls \
+ && myconf="${myconf} --enable-nls" \
+ || myconf="${myconf} --disable-nls"
use ssl \
&& myconf="${myconf} --enable-ssl" \
|| myconf="${myconf} --disable-ssl"
- econf ${myconf}
- make -f Makefile.fallback || die
+ econf ${myconf} || die "configure failed"
+ emake || die "parallel make failed"
}
src_install () {
make DESTDIR=${D} install || die
dodoc AUTHORS COPYING ChangeLog README NEWS TODO KNOWN_BUGS
+
+ use nls || rm -rf ${D}/usr/share/locale
}