summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2008-01-14 07:49:41 +0000
committerDenis Dupeyron <calchan@gentoo.org>2008-01-14 07:49:41 +0000
commit0df7f7c864f49a322f6aaeb6f70273a594fba27f (patch)
treed2cec212c80913230bbebe2243a9afb990533cb3 /net-print/hplip
parentfix config location (diff)
downloadgentoo-2-0df7f7c864f49a322f6aaeb6f70273a594fba27f.tar.gz
gentoo-2-0df7f7c864f49a322f6aaeb6f70273a594fba27f.tar.bz2
gentoo-2-0df7f7c864f49a322f6aaeb6f70273a594fba27f.zip
Moved the part about avoiding collisions with cups-1.2 symlinks from pkg_setup() to pkg_preinst() so that a compilation failure doesn't result in changes to the filesystem. Thanks to Donnie Berkholz.
(Portage version: 2.1.4)
Diffstat (limited to 'net-print/hplip')
-rw-r--r--net-print/hplip/ChangeLog8
-rw-r--r--net-print/hplip/hplip-2.7.10.ebuild12
-rw-r--r--net-print/hplip/hplip-2.7.12-r1.ebuild12
-rw-r--r--net-print/hplip/hplip-2.7.12.ebuild12
4 files changed, 25 insertions, 19 deletions
diff --git a/net-print/hplip/ChangeLog b/net-print/hplip/ChangeLog
index d17d50c29c95..f51f6b27a2a4 100644
--- a/net-print/hplip/ChangeLog
+++ b/net-print/hplip/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-print/hplip
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/ChangeLog,v 1.94 2008/01/13 15:08:18 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/ChangeLog,v 1.95 2008/01/14 07:49:41 calchan Exp $
+
+ 14 Jan 2008; Denis Dupeyron <calchan@gentoo.org> hplip-2.7.10.ebuild,
+ hplip-2.7.12.ebuild, hplip-2.7.12-r1.ebuild:
+ Moved the part about avoiding collisions with cups-1.2 symlinks from
+ pkg_setup() to pkg_preinst() so that a compilation failure doesn't result in
+ changes to the filesystem. Thanks to Donnie Berkholz.
*hplip-2.7.12-r1 (13 Jan 2008)
diff --git a/net-print/hplip/hplip-2.7.10.ebuild b/net-print/hplip/hplip-2.7.10.ebuild
index 32a490dbb81b..7a8318c8c74e 100644
--- a/net-print/hplip/hplip-2.7.10.ebuild
+++ b/net-print/hplip/hplip-2.7.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-2.7.10.ebuild,v 1.7 2008/01/13 15:08:18 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-2.7.10.ebuild,v 1.8 2008/01/14 07:49:41 calchan Exp $
inherit eutils linux-info
@@ -53,11 +53,6 @@ pkg_setup() {
else
use parport && linux-info_pkg_setup
fi
-
- # avoid collisions with cups-1.2 compat symlinks
- if [ -e "${ROOT}"/usr/lib/cups/backend/hp ] && [ -e "${ROOT}"/usr/libexec/cups/backend/hp ]; then
- rm -f "${ROOT}"/usr/libexec/cups/backend/hp{,fax};
- fi
}
src_unpack() {
@@ -110,6 +105,11 @@ src_install() {
}
pkg_preinst() {
+ # avoid collisions with cups-1.2 compat symlinks
+ if [ -e "${ROOT}"/usr/lib/cups/backend/hp ] && [ -e "${ROOT}"/usr/libexec/cups/backend/hp ]; then
+ rm -f "${ROOT}"/usr/libexec/cups/backend/hp{,fax};
+ fi
+
# try to be very conservative as to when we screw around with config files
use minimal && return 0
use scanner || return 0
diff --git a/net-print/hplip/hplip-2.7.12-r1.ebuild b/net-print/hplip/hplip-2.7.12-r1.ebuild
index 53b264f6e513..e312d287545b 100644
--- a/net-print/hplip/hplip-2.7.12-r1.ebuild
+++ b/net-print/hplip/hplip-2.7.12-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-2.7.12-r1.ebuild,v 1.1 2008/01/13 15:08:18 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-2.7.12-r1.ebuild,v 1.2 2008/01/14 07:49:41 calchan Exp $
inherit eutils linux-info python
@@ -53,11 +53,6 @@ pkg_setup() {
else
use parport && linux-info_pkg_setup
fi
-
- # avoid collisions with cups-1.2 compat symlinks
- if [ -e "${ROOT}"/usr/lib/cups/backend/hp ] && [ -e "${ROOT}"/usr/libexec/cups/backend/hp ]; then
- rm -f "${ROOT}"/usr/libexec/cups/backend/hp{,fax};
- fi
}
src_unpack() {
@@ -110,6 +105,11 @@ src_install() {
}
pkg_preinst() {
+ # avoid collisions with cups-1.2 compat symlinks
+ if [ -e "${ROOT}"/usr/lib/cups/backend/hp ] && [ -e "${ROOT}"/usr/libexec/cups/backend/hp ]; then
+ rm -f "${ROOT}"/usr/libexec/cups/backend/hp{,fax};
+ fi
+
# try to be very conservative as to when we screw around with config files
use minimal && return 0
use scanner || return 0
diff --git a/net-print/hplip/hplip-2.7.12.ebuild b/net-print/hplip/hplip-2.7.12.ebuild
index 09333f11c8dd..a3151fcd96ac 100644
--- a/net-print/hplip/hplip-2.7.12.ebuild
+++ b/net-print/hplip/hplip-2.7.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-2.7.12.ebuild,v 1.3 2008/01/13 15:08:18 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/hplip/hplip-2.7.12.ebuild,v 1.4 2008/01/14 07:49:41 calchan Exp $
inherit eutils linux-info
@@ -53,11 +53,6 @@ pkg_setup() {
else
use parport && linux-info_pkg_setup
fi
-
- # avoid collisions with cups-1.2 compat symlinks
- if [ -e "${ROOT}"/usr/lib/cups/backend/hp ] && [ -e "${ROOT}"/usr/libexec/cups/backend/hp ]; then
- rm -f "${ROOT}"/usr/libexec/cups/backend/hp{,fax};
- fi
}
src_unpack() {
@@ -110,6 +105,11 @@ src_install() {
}
pkg_preinst() {
+ # avoid collisions with cups-1.2 compat symlinks
+ if [ -e "${ROOT}"/usr/lib/cups/backend/hp ] && [ -e "${ROOT}"/usr/libexec/cups/backend/hp ]; then
+ rm -f "${ROOT}"/usr/libexec/cups/backend/hp{,fax};
+ fi
+
# try to be very conservative as to when we screw around with config files
use minimal && return 0
use scanner || return 0