summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2005-06-07 14:59:54 +0000
committerHeinrich Wendel <lanius@gentoo.org>2005-06-07 14:59:54 +0000
commit7abfcfcca3bc22d6b12e49184f90f888eb954676 (patch)
tree1de06d8036e46c1dc3b8845d650e43be59c6815c /net-print/omni/omni-0.9.2.ebuild
parentGot rid of the big ugly conf patch and used the eclass (diff)
downloadgentoo-2-7abfcfcca3bc22d6b12e49184f90f888eb954676.tar.gz
gentoo-2-7abfcfcca3bc22d6b12e49184f90f888eb954676.tar.bz2
gentoo-2-7abfcfcca3bc22d6b12e49184f90f888eb954676.zip
version bump
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-print/omni/omni-0.9.2.ebuild')
-rw-r--r--net-print/omni/omni-0.9.2.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/net-print/omni/omni-0.9.2.ebuild b/net-print/omni/omni-0.9.2.ebuild
new file mode 100644
index 000000000000..9f89484928c9
--- /dev/null
+++ b/net-print/omni/omni-0.9.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/omni/omni-0.9.2.ebuild,v 1.1 2005/06/07 14:59:54 lanius Exp $
+
+inherit eutils
+
+DESCRIPTION="Omni provides support for many printers with a pluggable framework (easy to add devices)"
+HOMEPAGE="http://sourceforge.net/projects/omniprint"
+SRC_URI="mirror://sourceforge/omniprint/${P/o/O}.tar.gz
+ doc? ( mirror://sourceforge/omniprint/OmniArchitecture.0.3.pdf )
+ epson? ( mirror://sourceforge/omniprint/OmniEpsonVendor-${PV}.tar.gz )
+ foomaticdb? ( mirror://gentoo/omni-${PV}-foomatic.tar.bz2 )"
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+DEPEND=""
+RDEPEND="virtual/ghostscript
+ dev-libs/libxml2
+ dev-libs/glib
+ cups? ( >=net-print/cups-1.1.14 )
+ X? ( >=dev-cpp/gtkmm-1.2.5 )
+ >=dev-libs/libsigc++-1.01
+ foomaticdb? ( net-print/foomatic-db-engine )"
+
+S="${WORKDIR}/Omni"
+
+IUSE="cups X ppds foomaticdb static doc epson"
+
+src_unpack() {
+ unpack ${P/o/O}.tar.gz
+ cd ${S}
+ if use epson; then
+ unpack OmniEpsonVendor-${PV}.tar.gz
+ fi
+}
+
+src_compile() {
+ local myconf=" \
+ $(use_enable X jobdialog) \
+ $(use_enable cups) \
+ $(use_enable static)"
+
+ export WANT_AUTOMAKE="1.6"
+ export WANT_AUTOCONF="2.5"
+
+ libtoolize --copy --force
+
+ LANG="" ./setupOmni ${myconf} --disable-device-xml --enable-device-compile || die
+
+ if use ppds && use cups; then
+ sed -i -e "s/model\/foomatic/model\/omni/g" CUPS/Makefile \
+ || die 'sed failed'
+ make -C CUPS generateBuildPPDs || die
+ fi
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ dodoc docs/* # never forget this! ;-)
+ use doc && dodoc ${DISTDIR}/OmniArchitecture.0.3.pdf
+
+ if use foomaticdb; then
+ cd ${D}
+ unpack omni-${PV}-foomatic.tar.bz2
+ fi
+}
+