summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2007-10-14 15:31:24 +0000
committerWolfram Schlich <wschlich@gentoo.org>2007-10-14 15:31:24 +0000
commit80893024dc13ac0741d2602515b8f766419c31f6 (patch)
tree505bda8f82e27039d5281c031f1f9ccc6608c918 /net-print
parentStable on ppc64; bug #194277 (diff)
downloadgentoo-2-80893024dc13ac0741d2602515b8f766419c31f6.tar.gz
gentoo-2-80893024dc13ac0741d2602515b8f766419c31f6.tar.bz2
gentoo-2-80893024dc13ac0741d2602515b8f766419c31f6.zip
version bump, fix bug #165210 and bug #181766
(Portage version: 2.1.3.7)
Diffstat (limited to 'net-print')
-rw-r--r--net-print/splix/ChangeLog11
-rw-r--r--net-print/splix/files/digest-splix-1.0.1_p13
-rw-r--r--net-print/splix/files/splix-1.0.1_p1-fix-makefile.patch52
-rw-r--r--net-print/splix/files/splix-1.0.1_p1-fix-nocolor-segfault.patch12
-rw-r--r--net-print/splix/files/splix-1.0.1_p1-fix-ppd-parallel-build.patch15
-rw-r--r--net-print/splix/splix-1.0.1_p1.ebuild57
6 files changed, 149 insertions, 1 deletions
diff --git a/net-print/splix/ChangeLog b/net-print/splix/ChangeLog
index db76212bf033..e0fc8e8e2967 100644
--- a/net-print/splix/ChangeLog
+++ b/net-print/splix/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-print/splix
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/splix/ChangeLog,v 1.6 2007/02/04 16:54:22 wschlich Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/splix/ChangeLog,v 1.7 2007/10/14 15:31:24 wschlich Exp $
+
+*splix-1.0.1_p1 (14 Oct 2007)
+
+ 14 Oct 2007; Wolfram Schlich <wschlich@gentoo.org>
+ +files/splix-1.0.1_p1-fix-makefile.patch,
+ +files/splix-1.0.1_p1-fix-nocolor-segfault.patch,
+ +files/splix-1.0.1_p1-fix-ppd-parallel-build.patch,
+ +splix-1.0.1_p1.ebuild:
+ version bump, fix bug #165210 and bug #181766
*splix-1.0.1 (04 Feb 2007)
diff --git a/net-print/splix/files/digest-splix-1.0.1_p1 b/net-print/splix/files/digest-splix-1.0.1_p1
new file mode 100644
index 000000000000..5f5eaf264998
--- /dev/null
+++ b/net-print/splix/files/digest-splix-1.0.1_p1
@@ -0,0 +1,3 @@
+MD5 4773d8a451455b5b3d0cec00434cecf7 splix-1.0.1-1.tar.bz2 37871
+RMD160 5cd84f133af82f322db48facf3241e5dc477cb5b splix-1.0.1-1.tar.bz2 37871
+SHA256 c7301b02a2868fd46eb569eaeca89bc691b90b9b51da7043097778585a8c6277 splix-1.0.1-1.tar.bz2 37871
diff --git a/net-print/splix/files/splix-1.0.1_p1-fix-makefile.patch b/net-print/splix/files/splix-1.0.1_p1-fix-makefile.patch
new file mode 100644
index 000000000000..8e659d9c7ccf
--- /dev/null
+++ b/net-print/splix/files/splix-1.0.1_p1-fix-makefile.patch
@@ -0,0 +1,52 @@
+diff -urN splix-1.0.1-1.orig/Makefile splix-1.0.1-1/Makefile
+--- splix-1.0.1-1.orig/Makefile 2007-02-10 15:20:18.000000000 +0100
++++ splix-1.0.1-1/Makefile 2007-10-14 16:18:05.000000000 +0200
+@@ -4,10 +4,10 @@
+ # This project has been placed under the GPL Licence.
+ #
+
+-CXXFLAGS := -O2 `cups-config --cflags`
+-LDFLAGS := `cups-config --ldflags`
+-CUPSFILTER := `cups-config --serverbin`/filter
+-CUPSPPD := `cups-config --datadir`/model
++CXXFLAGS +=
++LDFLAGS +=
++CUPSFILTER := $(DESTDIR)`cups-config --serverbin`/filter
++CUPSPPD := $(DESTDIR)`cups-config --datadir`/model
+
+ # === DON'T CHANGE ANYTHING AFTER THIS MESSAGE ====
+
+diff -urN splix-1.0.1-1.orig/src/Makefile splix-1.0.1-1/src/Makefile
+--- splix-1.0.1-1.orig/src/Makefile 2007-02-10 15:20:18.000000000 +0100
++++ splix-1.0.1-1/src/Makefile 2007-10-14 17:18:31.000000000 +0200
+@@ -4,8 +4,8 @@
+ # This project has been placed under the GPL Licence.
+ #
+
+-CXXFLAGS += -I../include -Wall -g -O0
+-LDFLAGS += -lcups -lcupsimage
++CXXFLAGS += -I../include -Wall
++LDADD += -lcups -lcupsimage
+
+ OBJECTS := spl2.o printer.o band.o compress.o bandanalyser.o
+ HEADERS := include/spl2.h include/document.h include/printer.h \
+@@ -15,16 +15,16 @@
+
+ all: rastertospl2
+ rastertospl2: $(OBJECTS) rastertospl2.o raster.o
+- $(CXX) $(LDFLAGS) -o $@ $^
++ $(CXX) $(LDFLAGS) -o $@ $^ $(LDADD)
+
+ pbmtospl2: $(OBJECTS) pbmtospl2.o pbmimage.o
+- $(CXX) $(LDFLAGS) -o $@ $^
++ $(CXX) $(LDFLAGS) -o $@ $^ $(LDADD)
+
+ %.o: %.cpp $(HEADERS)
+ $(CXX) $(CXXFLAGS) -c $<
+
+ install: rastertospl2
+- install -m 755 -s rastertospl2 ${CUPSFILTER}
++ install -m 755 rastertospl2 ${CUPSFILTER}
+
+ .PHONY: clean distclean
+ clean:
diff --git a/net-print/splix/files/splix-1.0.1_p1-fix-nocolor-segfault.patch b/net-print/splix/files/splix-1.0.1_p1-fix-nocolor-segfault.patch
new file mode 100644
index 000000000000..a7dbd2fdb033
--- /dev/null
+++ b/net-print/splix/files/splix-1.0.1_p1-fix-nocolor-segfault.patch
@@ -0,0 +1,12 @@
+--- splix-1.0.1-1-orig/src/printer.cpp 2007-02-10 15:20:18.000000000 +0100
++++ splix-1.0.1-1/src/printer.cpp 2007-03-05 17:02:42.000000000 +0100
+@@ -102,7 +102,8 @@ Printer::Printer(ppd_file_t *ppd)
+ if (attr)
+ _qpdlVersion = strtol(attr->value, (char **)NULL, 10);
+ attr = ppdFindAttr(_ppd, "QPDL", "ColorPrinter");
+- _color = attr->value[0] == '1' ? true : false;
++ if (attr)
++ _color = attr->value[0] == '1' ? true : false;
+
+ // Get the resolution
+ if ((choice = ppdFindMarkedChoice(_ppd, "Resolution"))) {
diff --git a/net-print/splix/files/splix-1.0.1_p1-fix-ppd-parallel-build.patch b/net-print/splix/files/splix-1.0.1_p1-fix-ppd-parallel-build.patch
new file mode 100644
index 000000000000..3b7ed93db176
--- /dev/null
+++ b/net-print/splix/files/splix-1.0.1_p1-fix-ppd-parallel-build.patch
@@ -0,0 +1,15 @@
+--- ppd/Makefile.orig 2007-10-14 16:40:59.000000000 +0200
++++ ppd/Makefile 2007-10-14 16:52:30.000000000 +0200
+@@ -25,9 +25,10 @@
+ ppdc -d ./ $<
+
+ $(LANGDRIVERSEXT): $(SOURCE) $(patsubst %, $(PODIR)/%.$(POEXT), $(LANGUAGES))
+- ppdc -c ${PODIR}/$(patsubst $(MASTERDRIVER)%.$(DRIVERSEXT),%, $@).${POEXT} -l $(patsubst $(MASTERDRIVER)%.$(DRIVERSEXT),%, $@) -d ${PODIR} $<
++ lang=$(patsubst $(MASTERDRIVER)%.$(DRIVERSEXT),%, $@); \
++ ppdc -c ${PODIR}/$$lang.${POEXT} -l $$lang -d ${PODIR}/$$lang $<; \
+ for filename in ${DRIVERS}; do \
+- mv ${PODIR}/`echo $$filename`.${DRIVERSEXT} `echo $$filename`$(patsubst $(MASTERDRIVER)%.$(DRIVERSEXT),%, $@).${DRIVERSEXT}; \
++ mv ${PODIR}/$$lang/$$filename.${DRIVERSEXT} $$filename$$lang.${DRIVERSEXT}; \
+ done
+
+ .PHONY: update
diff --git a/net-print/splix/splix-1.0.1_p1.ebuild b/net-print/splix/splix-1.0.1_p1.ebuild
new file mode 100644
index 000000000000..9be325516553
--- /dev/null
+++ b/net-print/splix/splix-1.0.1_p1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/splix/splix-1.0.1_p1.ebuild,v 1.1 2007/10/14 15:31:24 wschlich Exp $
+
+inherit eutils toolchain-funcs
+
+MY_P=${PN}-${PV/_p/-}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="A set of CUPS printer drivers for SPL (Samsung Printer Language) printers"
+HOMEPAGE="http://splix.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="net-print/cups" # splix will need >=media-libs/jbigkit-1.6 from 1.1.0 on
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/"${P}"-fix-makefile.patch
+ epatch "${FILESDIR}"/${P}-fix-nocolor-segfault.patch
+ epatch "${FILESDIR}"/${P}-fix-ppd-parallel-build.patch
+}
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" || die "emake failed"
+}
+
+src_install() {
+ CUPSFILTERDIR="$(cups-config --serverbin)/filter"
+ CUPSPPDDIR="$(cups-config --datadir)/model"
+
+ dodir "${CUPSFILTERDIR}"
+ dodir "${CUPSPPDDIR}"
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
+
+pkg_postinst() {
+ ebeep 5
+ ewarn ""
+ ewarn "You *MUST* make sure that the PPD files that CUPS is using"
+ ewarn "for actually installed printers are updated if you upgraded"
+ ewarn "from a previous version of splix!"
+ ewarn "Otherwise you will be unable to print (your printer might"
+ ewarn "spit out blank pages etc.)."
+ ewarn "To do that, simply delete the corresponding PPD file in"
+ ewarn "/etc/cups/ppd/, click on 'Modify Printer' belonging to the"
+ ewarn "corresponding printer in the CUPS webinterface (usually"
+ ewarn "reachable via http://localhost:631/) and choose the correct"
+ ewarn "printer make and model, for example:"
+ ewarn "'Samsung' -> 'Samsung ML-1610, 1.0 (en)'"
+ ewarn ""
+}