summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-06-22 18:09:59 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-06-22 18:09:59 +0000
commit9d315f2691a54a33804dded59829e77b8f72d21e (patch)
treeb76ee66f7fff36771982abe4427a1d1f0626ae34 /net-print
parentStable on sparc (diff)
downloadgentoo-2-9d315f2691a54a33804dded59829e77b8f72d21e.tar.gz
gentoo-2-9d315f2691a54a33804dded59829e77b8f72d21e.tar.bz2
gentoo-2-9d315f2691a54a33804dded59829e77b8f72d21e.zip
add if has_version =net-print/cups-1.1*; for the compat symlinks and einfo thanks to jakub
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'net-print')
-rw-r--r--net-print/cups/ChangeLog6
-rw-r--r--net-print/cups/cups-1.2.1-r2.ebuild40
2 files changed, 26 insertions, 20 deletions
diff --git a/net-print/cups/ChangeLog b/net-print/cups/ChangeLog
index 40aa81ef53dc..1e1962a3bdfd 100644
--- a/net-print/cups/ChangeLog
+++ b/net-print/cups/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-print/cups
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/cups/ChangeLog,v 1.184 2006/06/22 17:54:14 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups/ChangeLog,v 1.185 2006/06/22 18:09:59 genstef Exp $
+
+ 22 Jun 2006; Stefan Schweizer <genstef@gentoo.org> cups-1.2.1-r2.ebuild:
+ add if has_version =net-print/cups-1.1*; for the compat symlinks and einfo
+ thanks to jakub
*cups-1.2.1-r2 (22 Jun 2006)
diff --git a/net-print/cups/cups-1.2.1-r2.ebuild b/net-print/cups/cups-1.2.1-r2.ebuild
index b9ad5469627d..4fa300c26e20 100644
--- a/net-print/cups/cups-1.2.1-r2.ebuild
+++ b/net-print/cups/cups-1.2.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/cups/cups-1.2.1-r2.ebuild,v 1.1 2006/06/22 17:54:14 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups/cups-1.2.1-r2.ebuild,v 1.2 2006/06/22 18:09:59 genstef Exp $
inherit eutils flag-o-matic multilib autotools
@@ -143,22 +143,24 @@ pkg_postinst() {
einfo
einfo "You need to emerge ghostscript with the cups-USEflag turned on"
ewarn
- ewarn "The configuration changed with cups-1.2, you may want to save the old"
- ewarn "one and start from scratch:"
- ewarn "# mv /etc/cups /etc/cups.orig; emerge -va1 cups"
- ewarn
- ewarn "If you are updating from cups-1.1.* you need to remerge every ebuild"
- ewarn "that installed into /usr/lib/cups and /etc/cups, qfile is in portage-utils:"
- ewarn "# FEATURES=-collision-protect emerge -va1 \$(qfile -qC /usr/lib/cups /etc/cups | sed \"s:net-print/cups$::\")"
- ewarn
- einfo "FEATURES=-collision-protect is needed to overwrite the compatibility"
- einfo "symlinks installed by this package, it wont be needed on later merges."
- ewarn "You should also run revdep-rebuild"
- einfo "Rebuilding kdelibs is also a good idea when you want to use it for cups"
-
- # place symlinks to make the update smoothless
- for i in ${ROOT}/usr/lib/cups/{backend,filter}/*; do
- [ "${i/\*}" != "${i}" ] && continue;
- ln -s ${i} ${i/lib/libexec}
- done
+ if has_version =net-print/cups-1.1*; then
+ ewarn "The configuration changed with cups-1.2, you may want to save the old"
+ ewarn "one and start from scratch:"
+ ewarn "# mv /etc/cups /etc/cups.orig; emerge -va1 cups"
+ ewarn
+ ewarn "If you are updating from cups-1.1.* you need to remerge every ebuild"
+ ewarn "that installed into /usr/lib/cups and /etc/cups, qfile is in portage-utils:"
+ ewarn "# FEATURES=-collision-protect emerge -va1 \$(qfile -qC /usr/lib/cups /etc/cups | sed \"s:net-print/cups$::\")"
+ ewarn
+ einfo "FEATURES=-collision-protect is needed to overwrite the compatibility"
+ einfo "symlinks installed by this package, it wont be needed on later merges."
+ ewarn "You should also run revdep-rebuild"
+ einfo "Rebuilding kdelibs is also a good idea when you want to use it for cups"
+
+ # place symlinks to make the update smoothless
+ for i in ${ROOT}/usr/lib/cups/{backend,filter}/*; do
+ [ "${i/\*}" != "${i}" ] && continue;
+ ln -s ${i} ${i/lib/libexec}
+ done
+ fi
}