summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-05-08 21:59:56 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-05-08 21:59:56 +0000
commitdf5069e1f36fd5af886275e47e029677602f6600 (patch)
tree992a19a840aa329d18d58b3c28a9b8a5cc3d857f /net-print
parentFixed URLs, thanks to cygeus in bug #132720. (diff)
downloadgentoo-2-df5069e1f36fd5af886275e47e029677602f6600.tar.gz
gentoo-2-df5069e1f36fd5af886275e47e029677602f6600.tar.bz2
gentoo-2-df5069e1f36fd5af886275e47e029677602f6600.zip
Version bump 1.2.0, still masked due to my printing still being buggy+configuration changes whcih need user interaction
(Portage version: 2.1_pre10-r4)
Diffstat (limited to 'net-print')
-rw-r--r--net-print/cups/ChangeLog9
-rw-r--r--net-print/cups/cups-1.2.0.ebuild134
-rw-r--r--net-print/cups/files/cups-1.2.0-bindnow.patch47
-rw-r--r--net-print/cups/files/digest-cups-1.2.03
4 files changed, 192 insertions, 1 deletions
diff --git a/net-print/cups/ChangeLog b/net-print/cups/ChangeLog
index e13ef31b5b80..4884f3484be4 100644
--- a/net-print/cups/ChangeLog
+++ b/net-print/cups/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-print/cups
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/cups/ChangeLog,v 1.167 2006/05/08 18:52:07 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups/ChangeLog,v 1.168 2006/05/08 21:59:56 genstef Exp $
+
+*cups-1.2.0 (08 May 2006)
+
+ 08 May 2006; Stefan Schweizer <genstef@gentoo.org>
+ +files/cups-1.2.0-bindnow.patch, +cups-1.2.0.ebuild:
+ Version bump 1.2.0, still masked due to my printing still being
+ buggy+configuration changes whcih need user interaction
08 May 2006; Stefan Schweizer <genstef@gentoo.org> cups-1.2.0_pre.ebuild:
Add libpaper depend and remove config file sed
diff --git a/net-print/cups/cups-1.2.0.ebuild b/net-print/cups/cups-1.2.0.ebuild
new file mode 100644
index 000000000000..749e77eea8e6
--- /dev/null
+++ b/net-print/cups/cups-1.2.0.ebuild
@@ -0,0 +1,134 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups/cups-1.2.0.ebuild,v 1.1 2006/05/08 21:59:56 genstef Exp $
+
+inherit eutils pam flag-o-matic multilib autotools
+
+MY_P=${P/_/}
+
+DESCRIPTION="The Common Unix Printing System"
+HOMEPAGE="http://www.cups.org/"
+SRC_URI="http://ftp.easysw.com/pub/cups/${PV}/${MY_P}-source.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="ssl slp pam samba nls gnutls dbus"
+
+DEP="pam? ( virtual/pam )
+ ssl? (
+ !gnutls? ( >=dev-libs/openssl-0.9.6b )
+ gnutls? ( net-libs/gnutls )
+ )
+ slp? ( >=net-libs/openslp-1.0.4 )
+ dbus? ( sys-apps/dbus )
+ >=media-libs/libpng-1.2.1
+ >=media-libs/tiff-3.5.5
+ >=media-libs/jpeg-6b
+ app-text/libpaper"
+DEPEND="${DEP}
+ nls? ( sys-devel/gettext )"
+RDEPEND="${DEP}
+ nls? ( virtual/libintl )
+ !virtual/lpr
+ >=app-text/poppler-0.4.3-r1"
+PDEPEND="samba? ( >=net-fs/samba-3.0.8 )"
+PROVIDE="virtual/lpr"
+
+# upstream includes an interactive test which is a nono for gentoo.
+# therefore, since the printing herd has bigger fish to fry, for now,
+# we just leave it out, even if FEATURES=test
+RESTRICT="test"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ enewgroup lp
+ enewuser lp -1 -1 -1 lp
+
+ enewgroup lpadmin
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-bindnow.patch
+
+ # cups does not use autotools "the usual way" and ship a static config.h.in
+ eaclocal
+ eautoconf
+}
+
+src_compile() {
+ local myconf
+
+ use ssl && \
+ myconf="${myconf} $(use_enable gnutls) $(use_enable !gnutls openssl)"
+
+ export DSOFLAGS="${LDFLAGS}"
+ econf \
+ --with-cups-user=lp \
+ --with-cups-group=lp \
+ --with-system-groups=lpadmin \
+ --localstatedir=/var \
+ --with-bindnow=$(bindnow-flags) \
+ $(use_enable pam) \
+ $(use_enable ssl) \
+ $(use_enable slp) \
+ $(use_enable nls) \
+ $(use_enable dbus) \
+ --enable-libpaper \
+ --enable-threads \
+ --enable-static \
+ --disable-pdftops \
+ ${myconf} \
+ || die "econf failed"
+
+ # Install in /usr/libexec always, instead of using /usr/lib/cups, as that
+ # makes more sense when facing multilib support.
+ sed -i -e 's:SERVERBIN.*:SERVERBIN = $(BUILDROOT)/usr/libexec/cups:' Makedefs
+ sed -i -e 's:#define CUPS_SERVERBIN.*:#define CUPS_SERVERBIN "/usr/libexec/cups":' config.h
+ sed -i -e 's:cups_serverbin=.*:cups_serverbin=/usr/libexec/cups:' cups-config
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make BUILDROOT=${D} install || die "make install failed"
+
+ dodoc {CHANGES,CREDITS,LICENSE,README}.txt
+ dosym /usr/share/cups/docs /usr/share/doc/${PF}/html
+
+ # cleanups
+ rm -rf ${D}/etc/init.d ${D}/etc/pam.d ${D}/etc/rc* ${D}/usr/share/man/cat*
+
+ pamd_mimic_system cups auth account
+
+ sed -i -e "s:server = .*:server = /usr/libexec/cups/daemon/cups-lpd:" ${D}/etc/xinetd.d/cups-lpd
+
+ # install pdftops filter
+ exeinto /usr/libexec/cups/filter/
+ newexe ${FILESDIR}/pdftops.pl pdftops
+
+ fowners lp:lp /var/log/cups /var/run/cups/certs /var/cache/cups \
+ /var/spool/cups/tmp /var/spool/cups /etc/cups/{,interfaces,ppd}
+ keepdir /var/log/cups /var/run/cups/certs /var/cache/cups /var/spool/cups/tmp
+}
+
+pkg_preinst() {
+ # cleanups
+ [ -n "${PN}" ] && rm -fR /usr/share/doc/${PN}-*
+}
+
+pkg_postinst() {
+ einfo "Remote printing: change "
+ echo "Listen localhost:631"
+ einfo "to"
+ echo "Listen *:631"
+ einfo "in /etc/cups/cupsd.conf"
+ einfo
+ einfo "For more information about installing a printer take a look at:"
+ einfo "http://www.gentoo.org/doc/en/printing-howto.xml."
+ einfo
+ einfo "You need to emerge ghostscript with the cups-USEflag turned on"
+}
diff --git a/net-print/cups/files/cups-1.2.0-bindnow.patch b/net-print/cups/files/cups-1.2.0-bindnow.patch
new file mode 100644
index 000000000000..eb1b14e96ba8
--- /dev/null
+++ b/net-print/cups/files/cups-1.2.0-bindnow.patch
@@ -0,0 +1,47 @@
+diff -Naupr --exclude '*.rej' --exclude '*.orig' cups-1.2.0.orig/config-scripts/cups-setXid.m4 cups-1.2.0/config-scripts/cups-setXid.m4
+--- cups-1.2.0.orig/config-scripts/cups-setXid.m4 1970-01-01 01:00:00.000000000 +0100
++++ cups-1.2.0/config-scripts/cups-setXid.m4 2006-05-08 23:50:22.000000000 +0200
+@@ -0,0 +1,9 @@
++dnl
++dnl Copyright 1999-2005 Gentoo Foundation
++dnl Distributed under the terms of the GNU General Public License v2
++dnl
++
++AC_ARG_WITH(bindnow, [ --with-bindnow Set linker flags for force-binding setuid binaries],
++ BINDNOW_FLAGS="$withval",
++ BINDNOW_FLAGS="")
++AC_SUBST(BINDNOW_FLAGS)
+diff -Naupr --exclude '*.rej' --exclude '*.orig' cups-1.2.0.orig/configure.in cups-1.2.0/configure.in
+--- cups-1.2.0.orig/configure.in 2006-05-08 23:50:10.000000000 +0200
++++ cups-1.2.0/configure.in 2006-05-08 23:50:22.000000000 +0200
+@@ -46,6 +46,7 @@ sinclude(config-scripts/cups-defaults.m4
+ sinclude(config-scripts/cups-pap.m4)
+ sinclude(config-scripts/cups-pdf.m4)
+ sinclude(config-scripts/cups-scripting.m4)
++sinclude(config-scripts/cups-setXid.m4)
+
+ LANGFILES=""
+ if test "x$LANGUAGES" != x; then
+diff -Naupr --exclude '*.rej' --exclude '*.orig' cups-1.2.0.orig/Makedefs.in cups-1.2.0/Makedefs.in
+--- cups-1.2.0.orig/Makedefs.in 2006-05-08 23:50:10.000000000 +0200
++++ cups-1.2.0/Makedefs.in 2006-05-08 23:50:44.000000000 +0200
+@@ -131,6 +131,7 @@ IMGLIBS = @IMGLIBS@ -lm
+ IMGFILTERS = @IMGFILTERS@
+ LDFLAGS = -L../cups -L../filter $(RC_CFLAGS) $(ARCHFLAGS) \
+ @LDFLAGS@ @PIEFLAGS@ $(OPTIM)
++BINDNOW_FLAGS = @BINDNOW_FLAGS@
+ LINKCUPS = @LINKCUPS@ $(SSLLIBS)
+ LINKCUPSIMAGE = @LINKCUPSIMAGE@
+ LIBS = $(LINKCUPS) $(COMMONLIBS)
+diff -Naupr --exclude '*.rej' --exclude '*.orig' cups-1.2.0.orig/systemv/Makefile cups-1.2.0/systemv/Makefile
+--- cups-1.2.0.orig/systemv/Makefile 2006-05-08 23:50:10.000000000 +0200
++++ cups-1.2.0/systemv/Makefile 2006-05-08 23:50:22.000000000 +0200
+@@ -205,7 +205,7 @@ lpoptions: lpoptions.o ../cups/$(LIBCUPS
+
+ lppasswd: lppasswd.o ../cups/$(LIBCUPS)
+ echo Linking $@...
+- $(CC) $(LDFLAGS) -o lppasswd lppasswd.o $(LIBZ) $(LIBS)
++ $(CC) $(LDFLAGS) $(BINDNOW_FLAGS) -o lppasswd lppasswd.o $(LIBZ) $(LIBS)
+
+
+ #
diff --git a/net-print/cups/files/digest-cups-1.2.0 b/net-print/cups/files/digest-cups-1.2.0
new file mode 100644
index 000000000000..241dc7930b9a
--- /dev/null
+++ b/net-print/cups/files/digest-cups-1.2.0
@@ -0,0 +1,3 @@
+MD5 a168b0b1c8bb946060e659e1df2927c5 cups-1.2.0-source.tar.bz2 3456476
+RMD160 117d3a713d185bc507cf3a810f6415aa16a2e639 cups-1.2.0-source.tar.bz2 3456476
+SHA256 893a91d96e68de51f767d97d36d2d321320b3611b7178ea9a9d17ad2777f5f9f cups-1.2.0-source.tar.bz2 3456476