summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-05-03 10:16:08 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-05-03 10:16:08 +0000
commitf0a75fdd0f490a12c5378454434ebb5068ac7a3d (patch)
tree40af11e57923d802695caed5ce87c4ae4446b8a5 /net-print
parentStable on amd64 wrt bug #365751 (diff)
downloadgentoo-2-f0a75fdd0f490a12c5378454434ebb5068ac7a3d.tar.gz
gentoo-2-f0a75fdd0f490a12c5378454434ebb5068ac7a3d.tar.bz2
gentoo-2-f0a75fdd0f490a12c5378454434ebb5068ac7a3d.zip
Try to reorder the warnings for the usb useflag to be more self-explanatory.
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'net-print')
-rw-r--r--net-print/cups/ChangeLog5
-rw-r--r--net-print/cups/cups-1.4.6-r1.ebuild28
2 files changed, 17 insertions, 16 deletions
diff --git a/net-print/cups/ChangeLog b/net-print/cups/ChangeLog
index d5d654e340c3..a3d0ae43fe50 100644
--- a/net-print/cups/ChangeLog
+++ b/net-print/cups/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-print/cups
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/cups/ChangeLog,v 1.411 2011/05/01 15:15:04 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups/ChangeLog,v 1.412 2011/05/03 10:16:08 scarabeus Exp $
+
+ 03 May 2011; Tomáš Chvátal <scarabeus@gentoo.org> cups-1.4.6-r1.ebuild:
+ Try to reorder the warnings for the usb useflag to be more self-explanatory.
01 May 2011; Tomáš Chvátal <scarabeus@gentoo.org> cups-1.4.6-r1.ebuild:
use linux-info rather than linux-mod eclass. Per bug #365491.
diff --git a/net-print/cups/cups-1.4.6-r1.ebuild b/net-print/cups/cups-1.4.6-r1.ebuild
index ec4ed461d27f..912d1c18d760 100644
--- a/net-print/cups/cups-1.4.6-r1.ebuild
+++ b/net-print/cups/cups-1.4.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/cups/cups-1.4.6-r1.ebuild,v 1.4 2011/05/01 15:15:04 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/cups/cups-1.4.6-r1.ebuild,v 1.5 2011/05/03 10:16:08 scarabeus Exp $
EAPI=3
@@ -81,6 +81,17 @@ pkg_setup() {
python_pkg_setup
fi
+ if use usb; then
+ elog "You are going to use new libusb backed to access your usb printer."
+ elog "This interface has quite few known issues and does not report all"
+ elog "issues and just refuses to print."
+ elog "Please consider disabling usb useflag if you are having issues."
+ elog
+ elog "Please note that if you disable the usb useflag your device will be"
+ elog "still working using kernel usblp interface instead of libusb."
+ echo
+ fi
+
linux-info_pkg_setup
if ! linux_config_exists; then
ewarn "Can't check the linux kernel configuration."
@@ -89,9 +100,7 @@ pkg_setup() {
# recheck that we don't have usblp to collide with libusb
if use usb; then
if linux_chkconfig_present USB_PRINTER; then
- eerror "Your usb printers will be managed via libusb."
- eerror "Note that this interface still has issues so alternatively"
- eerror "you should just disable usb useflag on ${P}."
+ eerror "Your usb printers will be managed via libusb which collides with kernel module."
eerror "${P} requires the USB_PRINTER support disabled."
eerror "Please disable it:"
eerror " CONFIG_USB_PRINTER=n"
@@ -273,15 +282,4 @@ pkg_postinst() {
elog "For information about installing a printer and general cups setup"
elog "take a look at: http://www.gentoo.org/doc/en/printing-howto.xml"
echo
-
- if use usb; then
- elog
- elog "You are going to use new libusb backed to access your usb printer."
- elog "This interface has quite few known issues and does not report all"
- elog "issues and just refuses to print."
- elog "Please consider disabling usb useflag if you are having issues."
- elog
- elog "Please note that if you disable the usb useflag your device will be"
- elog "still working using kernel usblp interface instead of libusb."
- fi
}