summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2008-07-08 21:24:13 +0000
committerAlin Năstac <mrness@gentoo.org>2008-07-08 21:24:13 +0000
commit64e1d3978e464748f1b9686fe7ec30ef8b599e81 (patch)
tree7c8c0f1015a38c9f267e30d6fc32bea0a6d11767 /net-proxy/haproxy
parentFix regex support, thanks to Yar Odin <yarodin@gmail.com> (#230922). (diff)
downloadgentoo-2-64e1d3978e464748f1b9686fe7ec30ef8b599e81.tar.gz
gentoo-2-64e1d3978e464748f1b9686fe7ec30ef8b599e81.tar.bz2
gentoo-2-64e1d3978e464748f1b9686fe7ec30ef8b599e81.zip
Version bumps (#229575).
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-proxy/haproxy')
-rw-r--r--net-proxy/haproxy/ChangeLog9
-rw-r--r--net-proxy/haproxy/haproxy-1.3.14.6.ebuild47
-rw-r--r--net-proxy/haproxy/haproxy-1.3.15.2.ebuild47
3 files changed, 102 insertions, 1 deletions
diff --git a/net-proxy/haproxy/ChangeLog b/net-proxy/haproxy/ChangeLog
index ab0888590769..979cc826fb4a 100644
--- a/net-proxy/haproxy/ChangeLog
+++ b/net-proxy/haproxy/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-proxy/haproxy
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/ChangeLog,v 1.15 2008/06/23 23:23:42 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/ChangeLog,v 1.16 2008/07/08 21:24:13 mrness Exp $
+
+*haproxy-1.3.15.2 (08 Jul 2008)
+*haproxy-1.3.14.6 (08 Jul 2008)
+
+ 08 Jul 2008; Alin Năstac <mrness@gentoo.org> +haproxy-1.3.14.6.ebuild,
+ +haproxy-1.3.15.2.ebuild:
+ Version bumps (#229575).
*haproxy-1.3.15.1 (23 Jun 2008)
*haproxy-1.3.14.5 (23 Jun 2008)
diff --git a/net-proxy/haproxy/haproxy-1.3.14.6.ebuild b/net-proxy/haproxy/haproxy-1.3.14.6.ebuild
new file mode 100644
index 000000000000..b74cdd47d66b
--- /dev/null
+++ b/net-proxy/haproxy/haproxy-1.3.14.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/haproxy-1.3.14.6.ebuild,v 1.1 2008/07/08 21:24:13 mrness Exp $
+
+inherit linux-info versionator
+
+DESCRIPTION="A TCP/HTTP reverse proxy for high availability environments"
+HOMEPAGE="http://haproxy.1wt.eu"
+SRC_URI="http://haproxy.1wt.eu/download/$(get_version_component_range 1-2)/src/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="pcre"
+
+DEPEND="pcre? ( dev-libs/libpcre )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ local ARGS="TARGET=linux${KV_MAJOR}${KV_MINOR}"
+ use pcre && ARGS="${ARGS} REGEX=pcre"
+ emake ADDINC="${CFLAGS}" LDFLAGS="${LDFLAGS}" ${ARGS}
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe haproxy
+ newinitd "${FILESDIR}/haproxy.initd" haproxy
+
+ # Don't install useless files
+ rm examples/build.cfg doc/*gpl.txt
+
+ dodoc CHANGELOG ROADMAP TODO doc/*.txt
+ docinto examples
+ dodoc examples/*.cfg
+}
+
+pkg_postinst() {
+ if [[ ! -f "${ROOT}/etc/haproxy.cfg" ]] ; then
+ einfo "You need to create /etc/haproxy.cfg before you start haproxy service."
+ if [[ -d "${ROOT}/usr/share/doc/${P}" ]]; then
+ einfo "Please consult the installed documentation for learning the configuration file's syntax."
+ einfo "The documentation and sample configuration files are installed here:"
+ einfo " ${ROOT}usr/share/doc/${P}"
+ fi
+ fi
+}
diff --git a/net-proxy/haproxy/haproxy-1.3.15.2.ebuild b/net-proxy/haproxy/haproxy-1.3.15.2.ebuild
new file mode 100644
index 000000000000..8a34e569257a
--- /dev/null
+++ b/net-proxy/haproxy/haproxy-1.3.15.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/haproxy/haproxy-1.3.15.2.ebuild,v 1.1 2008/07/08 21:24:13 mrness Exp $
+
+inherit versionator
+
+DESCRIPTION="A TCP/HTTP reverse proxy for high availability environments"
+HOMEPAGE="http://haproxy.1wt.eu"
+SRC_URI="http://haproxy.1wt.eu/download/$(get_version_component_range 1-2)/src/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="pcre"
+
+DEPEND="pcre? ( dev-libs/libpcre )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ local ARGS="TARGET=linux26"
+ use pcre && ARGS="${ARGS} REGEX=pcre"
+ emake ADDINC="${CFLAGS}" LDFLAGS="${LDFLAGS}" ${ARGS}
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe haproxy
+ newinitd "${FILESDIR}/haproxy.initd" haproxy
+
+ # Don't install useless files
+ rm examples/build.cfg doc/*gpl.txt
+
+ dodoc CHANGELOG ROADMAP TODO doc/*.txt
+ docinto examples
+ dodoc examples/*.cfg
+}
+
+pkg_postinst() {
+ if [[ ! -f "${ROOT}/etc/haproxy.cfg" ]] ; then
+ einfo "You need to create /etc/haproxy.cfg before you start haproxy service."
+ if [[ -d "${ROOT}/usr/share/doc/${P}" ]]; then
+ einfo "Please consult the installed documentation for learning the configuration file's syntax."
+ einfo "The documentation and sample configuration files are installed here:"
+ einfo " ${ROOT}usr/share/doc/${P}"
+ fi
+ fi
+}