summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-08-02 03:01:10 +0000
committerJeroen Roovers <jer@gentoo.org>2011-08-02 03:01:10 +0000
commit38016c8ef5f2795e1d30718553d123d2107b3468 (patch)
tree5b2a8f1af15cf57afa19a7b74b86f668bf4c591d /net-proxy
parentHopefully fixes bug 341729 (diff)
downloadgentoo-2-38016c8ef5f2795e1d30718553d123d2107b3468.tar.gz
gentoo-2-38016c8ef5f2795e1d30718553d123d2107b3468.tar.bz2
gentoo-2-38016c8ef5f2795e1d30718553d123d2107b3468.zip
Respect CFLAGS thanks to Agostino Sarubbo (bug #377353).
(Portage version: 2.2.0_alpha49/cvs/Linux x86_64)
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/dante/ChangeLog8
-rw-r--r--net-proxy/dante/dante-1.3.1-r1.ebuild78
-rw-r--r--net-proxy/dante/files/dante-1.3.1-flags.patch43
3 files changed, 128 insertions, 1 deletions
diff --git a/net-proxy/dante/ChangeLog b/net-proxy/dante/ChangeLog
index 6d04f68a2b21..08cf0be67c5d 100644
--- a/net-proxy/dante/ChangeLog
+++ b/net-proxy/dante/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-proxy/dante
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/dante/ChangeLog,v 1.57 2011/06/26 02:22:47 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/dante/ChangeLog,v 1.58 2011/08/02 03:01:10 jer Exp $
+
+*dante-1.3.1-r1 (02 Aug 2011)
+
+ 02 Aug 2011; Jeroen Roovers <jer@gentoo.org> +dante-1.3.1-r1.ebuild,
+ +files/dante-1.3.1-flags.patch:
+ Respect CFLAGS thanks to Agostino Sarubbo (bug #377353).
*dante-1.3.1 (26 Jun 2011)
diff --git a/net-proxy/dante/dante-1.3.1-r1.ebuild b/net-proxy/dante/dante-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..7fb2a7922a98
--- /dev/null
+++ b/net-proxy/dante/dante-1.3.1-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/dante/dante-1.3.1-r1.ebuild,v 1.1 2011/08/02 03:01:10 jer Exp $
+
+EAPI="4"
+
+inherit autotools eutils
+
+DESCRIPTION="A free socks4,5 and msproxy implementation"
+HOMEPAGE="http://www.inet.no/dante/"
+SRC_URI="ftp://ftp.inet.no/pub/socks/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug kerberos pam selinux static-libs tcpd"
+
+RDEPEND="pam? ( virtual/pam )
+ kerberos? ( virtual/krb5 )
+ selinux? ( sec-policy/selinux-dante )
+ tcpd? ( sys-apps/tcp-wrappers )
+ userland_GNU? ( sys-apps/shadow )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ sys-devel/bison"
+
+DOCS="BUGS CREDITS NEWS README SUPPORT doc/README* doc/*.txt doc/SOCKS4.protocol"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.3.0-socksify.patch \
+ "${FILESDIR}"/${PN}-1.3.1-flags.patch
+
+ sed -i \
+ -e 's:/etc/socks\.conf:/etc/socks/socks.conf:' \
+ -e 's:/etc/sockd\.conf:/etc/socks/sockd.conf:' \
+ doc/{socksify.1,socks.conf.5,sockd.conf.5,sockd.8} \
+ || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-socks-conf=/etc/socks/socks.conf \
+ --with-sockd-conf=/etc/socks/sockd.conf \
+ --without-upnp \
+ $(use_enable debug) \
+ $(use_with kerberos gssapi) \
+ $(use_with pam) \
+ $(use_enable static-libs static) \
+ $(use_enable tcpd libwrap)
+}
+
+src_install() {
+ default
+
+ # default configuration files
+ insinto /etc/socks
+ doins "${FILESDIR}"/sock?.conf
+ pushd "${D}/etc/socks" > /dev/null
+ use pam && epatch "${FILESDIR}/sockd.conf-with-pam.patch"
+ use tcpd && epatch "${FILESDIR}/sockd.conf-with-libwrap.patch"
+ popd > /dev/null
+
+ # init script
+ newinitd "${FILESDIR}/dante-sockd-init" dante-sockd
+ newconfd "${FILESDIR}/dante-sockd-conf" dante-sockd
+
+ # example configuration files
+ docinto examples
+ dodoc example/*.conf
+
+ use static-libs || find "${ED}" -name '*.la' -exec rm '{}' +
+}
+
+pkg_postinst() {
+ enewuser sockd -1 -1 /etc/socks daemon
+}
diff --git a/net-proxy/dante/files/dante-1.3.1-flags.patch b/net-proxy/dante/files/dante-1.3.1-flags.patch
new file mode 100644
index 000000000000..fb8c211b3a0a
--- /dev/null
+++ b/net-proxy/dante/files/dante-1.3.1-flags.patch
@@ -0,0 +1,43 @@
+Respect CFLAGS (bug #377353) -JeR
+
+
+--- a/configure.ac
++++ b/configure.ac
+@@ -199,18 +199,6 @@
+ #XXX make sure compiling with compiler options works
+ esac
+
+-AC_MSG_CHECKING([for support for -pipe compiler flag])
+-oCFLAGS=$CFLAGS
+-CFLAGS="$CFLAGS -pipe"
+-AC_TRY_RUN([
+-int main()
+-{
+- return 0;
+-}], [AC_MSG_RESULT([yes])
+- comp_flags="${comp_flags} -pipe"],
+- AC_MSG_RESULT([no]))
+-CFLAGS="$oCFLAGS"
+-
+ AC_MSG_CHECKING([for support for -Wbounded compiler flag])
+ oCFLAGS=$CFLAGS
+ CFLAGS="$CFLAGS -Wbounded"
+@@ -233,18 +221,11 @@
+ fi])
+
+ if test x$debug_enabled = xt; then
+- #no optimization wanted
+- if test $ac_cv_prog_cc_g = yes; then
+- CFLAGS="$CFLAGS -g"
+- fi
+ CPPFLAGS="$CPPFLAGS${CPPFLAGS:+ }-DDEBUG=1"
+ AC_MSG_RESULT([yes])
+ else
+ AC_MSG_RESULT([no])
+- #autoconf_compflags is set to "-g -O2" with GCC
+- #override CFLAGS when running configure to avoid this
+ CPPFLAGS="$CPPFLAGS${CPPFLAGS:+ }-DDEBUG=0"
+- CFLAGS="$CFLAGS $autoconf_compflags"
+ fi
+
+ #-Wall ?