summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-01-30 14:07:55 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-01-30 14:07:55 +0000
commitb6f3bacfd264d065f72f1b2c930e2416baae82b8 (patch)
tree379f46654f454fa21f04b90da174bf4d5d068118 /net-voip/sflphone
parentVersion bump, remove old. (diff)
downloadgentoo-2-b6f3bacfd264d065f72f1b2c930e2416baae82b8.tar.gz
gentoo-2-b6f3bacfd264d065f72f1b2c930e2416baae82b8.tar.bz2
gentoo-2-b6f3bacfd264d065f72f1b2c930e2416baae82b8.zip
Fix building with x11-libs/libnotify >= 0.7.
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'net-voip/sflphone')
-rw-r--r--net-voip/sflphone/ChangeLog8
-rw-r--r--net-voip/sflphone/files/sflphone-0.9.8.4-libnotify-0.7.patch34
-rw-r--r--net-voip/sflphone/sflphone-0.9.8.4.ebuild8
3 files changed, 45 insertions, 5 deletions
diff --git a/net-voip/sflphone/ChangeLog b/net-voip/sflphone/ChangeLog
index d5672f02f711..3f86e0d5f4cb 100644
--- a/net-voip/sflphone/ChangeLog
+++ b/net-voip/sflphone/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-voip/sflphone
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-voip/sflphone/ChangeLog,v 1.5 2010/11/04 17:36:21 fauli Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-voip/sflphone/ChangeLog,v 1.6 2011/01/30 14:07:55 ssuominen Exp $
+
+ 30 Jan 2011; Samuli Suominen <ssuominen@gentoo.org> sflphone-0.9.8.4.ebuild,
+ +files/sflphone-0.9.8.4-libnotify-0.7.patch:
+ Fix building with x11-libs/libnotify >= 0.7.
04 Nov 2010; Christian Faulhammer <fauli@gentoo.org>
sflphone-0.9.8.4.ebuild:
diff --git a/net-voip/sflphone/files/sflphone-0.9.8.4-libnotify-0.7.patch b/net-voip/sflphone/files/sflphone-0.9.8.4-libnotify-0.7.patch
new file mode 100644
index 000000000000..90648e3498fd
--- /dev/null
+++ b/net-voip/sflphone/files/sflphone-0.9.8.4-libnotify-0.7.patch
@@ -0,0 +1,34 @@
+--- sflphone-client-gnome/src/sflnotify.c
++++ sflphone-client-gnome/src/sflnotify.c
+@@ -30,6 +30,10 @@
+
+ #include <sflnotify.h>
+
++#ifndef NOTIFY_CHECK_VERSION
++#define NOTIFY_CHECK_VERSION(x,y,z) 0
++#endif
++
+ GnomeNotification *_gnome_notification;
+
+ void create_new_gnome_notification (gchar *title, gchar *body, NotifyUrgency urgency, gint timeout, GnomeNotification **notif)
+@@ -43,12 +47,20 @@
+ notify_init ("SFLphone");
+
+ // Set struct fields
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ _notif->notification = notify_notification_new (title, body, NULL);
++#else
+ _notif->notification = notify_notification_new (title, body, NULL, NULL);
++#endif
+ //_notif->icon = gdk_pixbuf_new_from_file_at_size (LOGO, 120, 120, NULL);
+ _notif->icon = gdk_pixbuf_new_from_file (LOGO_SMALL, NULL);
+ #if GTK_CHECK_VERSION(2,10,0)
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ // notify_notification_attach_to_status_icon function was removed
++#else
+ notify_notification_attach_to_status_icon (_notif->notification , get_status_icon() );
+ #endif
++#endif
+
+ notify_notification_set_urgency (_notif->notification, urgency);
+
diff --git a/net-voip/sflphone/sflphone-0.9.8.4.ebuild b/net-voip/sflphone/sflphone-0.9.8.4.ebuild
index 4cef0cd0cb08..d0a30cea0cb3 100644
--- a/net-voip/sflphone/sflphone-0.9.8.4.ebuild
+++ b/net-voip/sflphone/sflphone-0.9.8.4.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-voip/sflphone/sflphone-0.9.8.4.ebuild,v 1.5 2010/11/04 17:36:21 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-voip/sflphone/sflphone-0.9.8.4.ebuild,v 1.6 2011/01/30 14:07:55 ssuominen Exp $
EAPI="2"
-inherit autotools
+inherit autotools eutils
DESCRIPTION="SFLphone is a robust standards-compliant enterprise softphone, for desktop and embedded systems."
HOMEPAGE="http://www.sflphone.org/"
@@ -52,6 +52,8 @@ DEPEND="${CDEPEND}
RDEPEND="${CDEPEND}"
src_prepare() {
+ epatch "${FILESDIR}"/${P}-libnotify-0.7.patch
+
if ! use gnome; then
ewarn
ewarn "No clients selected. Use USE=gnome to get the gnome client."