summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-02-10 15:41:10 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2013-02-10 15:41:10 +0000
commit058f60129dbce8aa64801eaf34fbaa749ab69bfc (patch)
tree7c5b35c5898b569fbfd859b3f6250317a0f38b99 /net-voip/telepathy-salut
parentUnmask both zd1201 and zd1211 firmware pkgs as they are not in linux-firmware... (diff)
downloadgentoo-2-058f60129dbce8aa64801eaf34fbaa749ab69bfc.tar.gz
gentoo-2-058f60129dbce8aa64801eaf34fbaa749ab69bfc.tar.bz2
gentoo-2-058f60129dbce8aa64801eaf34fbaa749ab69bfc.zip
Switch to EAPI=5 and python-any-r1. Allow switch tls backend, refs bug #456250.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'net-voip/telepathy-salut')
-rw-r--r--net-voip/telepathy-salut/ChangeLog7
-rw-r--r--net-voip/telepathy-salut/telepathy-salut-0.8.1.ebuild37
2 files changed, 28 insertions, 16 deletions
diff --git a/net-voip/telepathy-salut/ChangeLog b/net-voip/telepathy-salut/ChangeLog
index b02e18a9ade1..68ed386f2311 100644
--- a/net-voip/telepathy-salut/ChangeLog
+++ b/net-voip/telepathy-salut/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-voip/telepathy-salut
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-salut/ChangeLog,v 1.47 2013/02/02 23:08:49 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-salut/ChangeLog,v 1.48 2013/02/10 15:41:10 eva Exp $
+
+ 10 Feb 2013; Gilles Dartiguelongue <eva@gentoo.org>
+ telepathy-salut-0.8.1.ebuild:
+ Switch to EAPI=5 and python-any-r1. Allow switch tls backend, refs bug
+ #456250.
02 Feb 2013; Agostino Sarubbo <ago@gentoo.org> telepathy-salut-0.8.1.ebuild:
Add ~arm, wrt bug #449220
diff --git a/net-voip/telepathy-salut/telepathy-salut-0.8.1.ebuild b/net-voip/telepathy-salut/telepathy-salut-0.8.1.ebuild
index 39c2402ee9b9..576575a1fde0 100644
--- a/net-voip/telepathy-salut/telepathy-salut-0.8.1.ebuild
+++ b/net-voip/telepathy-salut/telepathy-salut-0.8.1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-salut/telepathy-salut-0.8.1.ebuild,v 1.3 2013/02/02 23:08:49 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-voip/telepathy-salut/telepathy-salut-0.8.1.ebuild,v 1.4 2013/02/10 15:41:09 eva Exp $
-EAPI="4"
-PYTHON_DEPEND="2:2.5"
+EAPI="5"
+PYTHON_COMPAT=( python2_{5,6,7} )
-inherit base python eutils
+inherit eutils python-any-r1
DESCRIPTION="A link-local XMPP connection manager for Telepathy"
HOMEPAGE="http://telepathy.freedesktop.org/wiki/CategorySalut"
@@ -14,45 +14,52 @@ SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-linux"
-IUSE="test"
+IUSE="gnutls test"
-RDEPEND="dev-libs/libxml2
- >=dev-libs/glib-2.24:2
+RDEPEND="
+ >=dev-libs/dbus-glib-0.61
+ dev-libs/libxml2
+ >=dev-libs/glib-2.28:2
>=sys-apps/dbus-1.1.0
>=net-libs/telepathy-glib-0.17.1
>=net-dns/avahi-0.6.22[dbus]
net-libs/libsoup:2.4
- sys-apps/util-linux"
+ sys-apps/util-linux
+ gnutls? ( >=net-libs/gnutls-2.10.2 )
+ !gnutls? ( >=dev-libs/openssl-0.9.8g )
+"
DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ dev-libs/libxslt
+ virtual/pkgconfig
test? (
>=dev-libs/check-0.9.4
net-libs/libgsasl
dev-python/twisted-words )
- dev-libs/libxslt
- virtual/pkgconfig"
+"
# FIXME: needs xmppstream python module
# >=net-dns/avahi-0.6.22[python]
pkg_setup() {
- DOCS="AUTHORS ChangeLog NEWS README"
- python_set_active_version 2
- python_pkg_setup
+ python-any-r1_pkg_setup
}
src_prepare() {
# Fix uninitialized variable, upstream bug #37701
epatch "${FILESDIR}/${PN}-0.5.0-uninitialized.patch"
- python_convert_shebangs -r 2 .
+ _python_rewrite_shebangs .
}
src_configure() {
econf \
+ --disable-coding-style-checks \
--disable-plugins \
--disable-Werror \
--disable-static \
--disable-avahi-tests \
- --docdir=/usr/share/doc/${PF}
+ --docdir=/usr/share/doc/${PF} \
+ --with-tls=$(usex gnutls gnutls openssl)
#$(use_enable test avahi-tests)
}