summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenrik Brix Andersen <brix@gentoo.org>2006-04-29 14:25:14 +0000
committerHenrik Brix Andersen <brix@gentoo.org>2006-04-29 14:25:14 +0000
commit47b5836936fba89e08a904606374dd21d20c1661 (patch)
treefdf3a771a534b354774c9f01e25d94a46e099855 /net-wireless/hostapd/files
parentInitial import of ebuild written by me. (diff)
downloadgentoo-2-47b5836936fba89e08a904606374dd21d20c1661.tar.gz
gentoo-2-47b5836936fba89e08a904606374dd21d20c1661.tar.bz2
gentoo-2-47b5836936fba89e08a904606374dd21d20c1661.zip
New development snapshot.
(Portage version: 2203-svn)
Diffstat (limited to 'net-wireless/hostapd/files')
-rw-r--r--net-wireless/hostapd/files/digest-hostapd-0.5.31
-rw-r--r--net-wireless/hostapd/files/hostapd-0.5.3-conf.d9
-rw-r--r--net-wireless/hostapd/files/hostapd-0.5.3-init.d50
-rw-r--r--net-wireless/hostapd/files/hostapd-0.5.3-os_get_random.patch36
4 files changed, 96 insertions, 0 deletions
diff --git a/net-wireless/hostapd/files/digest-hostapd-0.5.3 b/net-wireless/hostapd/files/digest-hostapd-0.5.3
new file mode 100644
index 000000000000..b26698dd068c
--- /dev/null
+++ b/net-wireless/hostapd/files/digest-hostapd-0.5.3
@@ -0,0 +1 @@
+MD5 4e3134e8b0d86e831230f8c620fd81bb hostapd-0.5.3.tar.gz 385649
diff --git a/net-wireless/hostapd/files/hostapd-0.5.3-conf.d b/net-wireless/hostapd/files/hostapd-0.5.3-conf.d
new file mode 100644
index 000000000000..7d05735eb3b4
--- /dev/null
+++ b/net-wireless/hostapd/files/hostapd-0.5.3-conf.d
@@ -0,0 +1,9 @@
+# Space separated List of interfaces which needs to be started before
+# hostapd
+INTERFACES="wlan0"
+
+# Space separated list of configuration files
+CONFIGS="/etc/hostapd/hostapd.conf"
+
+# Extra options to pass to hostapd, see hostapd(8)
+OPTIONS=""
diff --git a/net-wireless/hostapd/files/hostapd-0.5.3-init.d b/net-wireless/hostapd/files/hostapd-0.5.3-init.d
new file mode 100644
index 000000000000..a2a00030de7f
--- /dev/null
+++ b/net-wireless/hostapd/files/hostapd-0.5.3-init.d
@@ -0,0 +1,50 @@
+#!/sbin/runscript
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostapd/files/hostapd-0.5.3-init.d,v 1.1 2006/04/29 14:25:14 brix Exp $
+
+opts="start stop reload"
+
+depend() {
+ local iface
+
+ for iface in ${INTERFACES}; do
+ need net.${iface}
+ done
+
+ use logger
+}
+
+checkconfig() {
+ local file
+
+ for file in ${CONFIGS}; do
+ if [[ ! -r ${file} ]]; then
+ eerror "hostapd configuration file (${CONFIG}) not found"
+ return 1
+ fi
+ done
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Starting hostapd"
+ start-stop-daemon --start --exec /usr/sbin/hostapd \
+ -- -B ${OPTIONS} ${CONFIGS}
+ eend ${?}
+}
+
+stop() {
+ ebegin "Stopping hostapd"
+ start-stop-daemon --stop --exec /usr/sbin/hostapd
+ eend ${?}
+}
+
+reload() {
+ checkconfig || return 1
+
+ ebegin "Reloading hostapd configuration"
+ kill -HUP $(pidof /usr/sbin/hostapd) > /dev/null 2>&1
+ eend ${?}
+}
diff --git a/net-wireless/hostapd/files/hostapd-0.5.3-os_get_random.patch b/net-wireless/hostapd/files/hostapd-0.5.3-os_get_random.patch
new file mode 100644
index 000000000000..d494d1e84d94
--- /dev/null
+++ b/net-wireless/hostapd/files/hostapd-0.5.3-os_get_random.patch
@@ -0,0 +1,36 @@
+diff -ur hostapd-0.5.3/hlr_auc_gw.c hostapd-0.5.3-os_get_random/hlr_auc_gw.c
+--- hostapd-0.5.3/hlr_auc_gw.c 2006-03-11 19:15:15.000000000 +0100
++++ hostapd-0.5.3-os_get_random/hlr_auc_gw.c 2006-04-29 15:33:13.000000000 +0200
+@@ -204,7 +204,7 @@
+ size_t res_len;
+
+ #ifdef AKA_USE_MILENAGE
+- os_get_random(rand, EAP_AKA_RAND_LEN);
++ hostapd_get_rand(rand, EAP_AKA_RAND_LEN);
+ res_len = EAP_AKA_RES_MAX_LEN;
+ inc_byte_array(test_sqn, 6);
+ printf("AKA: Milenage with SQN=%02x%02x%02x%02x%02x%02x\n",
+diff -ur hostapd-0.5.3/Makefile hostapd-0.5.3-os_get_random/Makefile
+--- hostapd-0.5.3/Makefile 2006-04-28 06:10:57.000000000 +0200
++++ hostapd-0.5.3-os_get_random/Makefile 2006-04-29 15:37:04.000000000 +0200
+@@ -343,7 +343,7 @@
+ $(CC) -o hostapd_cli hostapd_cli.o $(DIR_WPA_SUPPLICANT)/wpa_ctrl.o
+
+ NOBJS = nt_password_hash.o $(DIR_WPA_SUPPLICANT)/ms_funcs.o sha1.o rc4.o md5.o
+-NOBJS += $(DIR_WPA_SUPPLICANT)/crypto.o
++NOBJS += $(DIR_WPA_SUPPLICANT)/crypto.o os_$(CONFIG_OS).o
+ ifdef TLS_FUNCS
+ LIBS_n += -lcrypto
+ endif
+diff -ur hostapd-0.5.3/ms_funcs.c hostapd-0.5.3-os_get_random/ms_funcs.c
+--- hostapd-0.5.3/ms_funcs.c 2006-04-28 06:10:57.000000000 +0200
++++ hostapd-0.5.3-os_get_random/ms_funcs.c 2006-04-29 15:32:37.000000000 +0200
+@@ -368,7 +368,7 @@
+
+ memset(pw_block, 0, PWBLOCK_LEN);
+ offset = (256 - password_len) * 2;
+- os_get_random(pw_block, offset);
++ hostapd_get_rand(pw_block, offset);
+ for (i = 0; i < password_len; i++)
+ pw_block[offset + i * 2] = password[i];
+ /*