summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2007-02-10 00:48:41 +0000
committerMike Auty <ikelos@gentoo.org>2007-02-10 00:48:41 +0000
commit3a8a46d31e08bf448a69688871908da39f501082 (patch)
tree629a992aef024604365ff7bf1cf1073f5daeef43 /net-wireless/madwifi-ng
parentVersion bump. (diff)
downloadgentoo-2-3a8a46d31e08bf448a69688871908da39f501082.tar.gz
gentoo-2-3a8a46d31e08bf448a69688871908da39f501082.tar.bz2
gentoo-2-3a8a46d31e08bf448a69688871908da39f501082.zip
Fix up 'unable to attach hardware' problem, bug 165477.
(Portage version: 2.1.2-r8)
Diffstat (limited to 'net-wireless/madwifi-ng')
-rw-r--r--net-wireless/madwifi-ng/ChangeLog6
-rw-r--r--net-wireless/madwifi-ng/files/madwifi-ng-0.9.2.1-linux-2.6.20.patch24
2 files changed, 29 insertions, 1 deletions
diff --git a/net-wireless/madwifi-ng/ChangeLog b/net-wireless/madwifi-ng/ChangeLog
index 8501c7abc2ae..c627007983f6 100644
--- a/net-wireless/madwifi-ng/ChangeLog
+++ b/net-wireless/madwifi-ng/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-wireless/madwifi-ng
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/madwifi-ng/ChangeLog,v 1.23 2007/02/05 20:16:44 dsd Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/madwifi-ng/ChangeLog,v 1.24 2007/02/10 00:48:41 ikelos Exp $
+
+ 10 Feb 2007; Mike Auty <ikelos@gentoo.org>
+ files/madwifi-ng-0.9.2.1-linux-2.6.20.patch:
+ Fix up 'unable to attach hardware' problem, bug 165477.
05 Feb 2007; Daniel Drake <dsd@gentoo.org>
+files/madwifi-ng-0.9.2.1-linux-2.6.20.patch, madwifi-ng-0.9.2.1.ebuild:
diff --git a/net-wireless/madwifi-ng/files/madwifi-ng-0.9.2.1-linux-2.6.20.patch b/net-wireless/madwifi-ng/files/madwifi-ng-0.9.2.1-linux-2.6.20.patch
index cabdbb6c547c..aa7d28627cc1 100644
--- a/net-wireless/madwifi-ng/files/madwifi-ng-0.9.2.1-linux-2.6.20.patch
+++ b/net-wireless/madwifi-ng/files/madwifi-ng-0.9.2.1-linux-2.6.20.patch
@@ -1,3 +1,27 @@
+Index: madwifi-0.9.2.1/ath_hal/ah_osdep.h
+===================================================================
+--- madwifi-0.9.2.1.orig/hal/linux/ah_osdep.h
++++ madwifi-0.9.2.1/hal/linux/ah_osdep.h
+@@ -40,12 +40,12 @@
+
+ /*
+- * Starting with 2.6.4 the kernel supports a configuration option
+- * to pass parameters in registers. If this is enabled we must
+- * mark all function interfaces in+out of the HAL to pass parameters
+- * on the stack as this is the convention used internally (for
+- * maximum portability).
++ * Linux on i386 may pass parameters in registers. This is an option
++ * starting with Linux 2.6.4. Starting with Linux 2.6.20, it's done
++ * unconditionally. However, the HAL uses standard ABI whereas the
++ * parameters are passed on the stack (for maximum portability).
++ * "asmlinkage" forces the standard ABI for the HAL calls.
+ */
+-#ifdef CONFIG_REGPARM
+-#define __ahdecl __attribute__((regparm(0)))
++#ifdef __i386__
++#define __ahdecl asmlinkage
+ #else
+ #define __ahdecl
Index: madwifi-0.9.2.1/ath/if_ath.c
===================================================================
--- madwifi-0.9.2.1.orig/ath/if_ath.c