summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2015-03-18 18:37:24 +0000
committerRick Farina <zerochaos@gentoo.org>2015-03-18 18:37:24 +0000
commitf8b0a46f4fa4c77703345023e395b410bc37ef85 (patch)
tree1c3ea5b5567ccb1694fbe130b4fd76d8675f6406 /net-wireless/ubertooth
parentRevision bump for Poppler 0.32 (diff)
downloadgentoo-2-f8b0a46f4fa4c77703345023e395b410bc37ef85.tar.gz
gentoo-2-f8b0a46f4fa4c77703345023e395b410bc37ef85.tar.bz2
gentoo-2-f8b0a46f4fa4c77703345023e395b410bc37ef85.zip
update live ebuild for new udev installation method
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'net-wireless/ubertooth')
-rw-r--r--net-wireless/ubertooth/ChangeLog7
-rw-r--r--net-wireless/ubertooth/ubertooth-9999.ebuild27
2 files changed, 19 insertions, 15 deletions
diff --git a/net-wireless/ubertooth/ChangeLog b/net-wireless/ubertooth/ChangeLog
index 4aed79f774f1..4b28fcf2304b 100644
--- a/net-wireless/ubertooth/ChangeLog
+++ b/net-wireless/ubertooth/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-wireless/ubertooth
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/ubertooth/ChangeLog,v 1.26 2014/08/26 01:33:17 zerochaos Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/ubertooth/ChangeLog,v 1.27 2015/03/18 18:37:24 zerochaos Exp $
+
+ 18 Mar 2015; Rick Farina <zerochaos@gentoo.org> ubertooth-9999.ebuild:
+ update live ebuild for new udev installation method
26 Aug 2014; Rick Farina <zerochaos@gentoo.org> ubertooth-2014.04.1-r1.ebuild,
ubertooth-9999.ebuild:
diff --git a/net-wireless/ubertooth/ubertooth-9999.ebuild b/net-wireless/ubertooth/ubertooth-9999.ebuild
index 90f24857988e..957b8a83bcee 100644
--- a/net-wireless/ubertooth/ubertooth-9999.ebuild
+++ b/net-wireless/ubertooth/ubertooth-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/ubertooth/ubertooth-9999.ebuild,v 1.25 2014/08/26 01:33:17 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/ubertooth/ubertooth-9999.ebuild,v 1.26 2015/03/18 18:37:24 zerochaos Exp $
EAPI="5"
@@ -8,7 +8,7 @@ PYTHON_DEPEND="python? 2"
SUPPORT_PYTHON_ABIS="1"
RESTRICT_PYTHON_ABIS="3.*"
-inherit multilib distutils cmake-utils
+inherit multilib distutils cmake-utils udev
HOMEPAGE="http://ubertooth.sourceforge.net/"
@@ -21,15 +21,14 @@ REQUIRED_USE="dfu? ( python )
python? ( || ( dfu specan ) )"
DEPEND="bluez? ( net-wireless/bluez:= )
>=net-libs/libbtbb-${PV}:=
- pcap? ( net-libs/libpcap:= )"
+ pcap? ( net-libs/libpcap:= )
+ virtual/libusb:1="
RDEPEND="${DEPEND}
- specan? ( virtual/libusb:1
- >=dev-qt/qtgui-4.7.2:4
+ specan? ( >=dev-qt/qtgui-4.7.2:4
>=dev-python/pyside-1.0.2
>=dev-python/numpy-1.3
>=dev-python/pyusb-1.0.0_alpha1 )
- dfu? ( virtual/libusb:1
- >=dev-python/pyusb-1.0.0_alpha1 )
+ dfu? ( >=dev-python/pyusb-1.0.0_alpha1 )
udev? ( virtual/udev )"
MY_PV=${PV/\./-}
@@ -74,8 +73,15 @@ src_configure() {
mycmakeargs=(
$(cmake-utils_use_enable bluez USE_BLUEZ)
$(cmake-utils_use_enable pcap USE_PCAP)
+ $(cmake-utils_use_enable udev INSTALL_UDEV_RULES)
-DDISABLE_PYTHON=true
)
+ if use udev; then
+ mycmakeargs+=(
+ -DUDEV_RULES_GROUP=usb
+ -DUDEV_RULES_PATH="$(get_udevdir)/rules.d"
+ )
+ fi
cmake-utils_src_configure
}
@@ -97,11 +103,6 @@ src_install() {
use ubertooth1-firmware && newins ubertooth-one-firmware-bin/bluetooth_rxtx.dfu ${PN}-one-${PV}-bluetooth_rxtx.dfu
fi
- if use udev; then
- insinto /lib/udev/rules.d/
- doins "${S}"/lib${PN}/40-${PN}.rules
- fi
-
use python && distutils_src_install
elog "Everyone can read from the ubertooth, but to talk to it"