summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-03-06 10:31:06 +0000
committerJustin Lecher <jlec@gentoo.org>2011-03-06 10:31:06 +0000
commit31010d1cc1405e08511291b58614612095873c58 (patch)
tree16f65756eb758b85a771cdf43007c9b9718a2eef /net-wireless
parentUse slot dependencies for gtk+. (diff)
downloadgentoo-2-31010d1cc1405e08511291b58614612095873c58.tar.gz
gentoo-2-31010d1cc1405e08511291b58614612095873c58.tar.bz2
gentoo-2-31010d1cc1405e08511291b58614612095873c58.zip
New addition, written by me, #282953
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/python-wifi/ChangeLog11
-rw-r--r--net-wireless/python-wifi/metadata.xml9
-rw-r--r--net-wireless/python-wifi/python-wifi-0.3.1.ebuild35
-rw-r--r--net-wireless/python-wifi/python-wifi-0.5.0.ebuild33
4 files changed, 88 insertions, 0 deletions
diff --git a/net-wireless/python-wifi/ChangeLog b/net-wireless/python-wifi/ChangeLog
new file mode 100644
index 000000000000..ac4a03148bef
--- /dev/null
+++ b/net-wireless/python-wifi/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-wireless/python-wifi
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/python-wifi/ChangeLog,v 1.1 2011/03/06 10:31:06 jlec Exp $
+
+*python-wifi-0.5.0 (06 Mar 2011)
+*python-wifi-0.3.1 (06 Mar 2011)
+
+ 06 Mar 2011; Justin Lecher <jlec@gentoo.org> +python-wifi-0.3.1.ebuild,
+ +python-wifi-0.5.0.ebuild, +metadata.xml:
+ New addition, written by me, #282953
+
diff --git a/net-wireless/python-wifi/metadata.xml b/net-wireless/python-wifi/metadata.xml
new file mode 100644
index 000000000000..a4ac62a71c93
--- /dev/null
+++ b/net-wireless/python-wifi/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
+
diff --git a/net-wireless/python-wifi/python-wifi-0.3.1.ebuild b/net-wireless/python-wifi/python-wifi-0.3.1.ebuild
new file mode 100644
index 000000000000..f0b57f45852b
--- /dev/null
+++ b/net-wireless/python-wifi/python-wifi-0.3.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/python-wifi/python-wifi-0.3.1.ebuild,v 1.1 2011/03/06 10:31:06 jlec Exp $
+
+EAPI="2"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3*"
+
+inherit distutils
+
+DESCRIPTION="Provides r/w access to a wireless network card's capabilities using the Linux Wireless Extensions"
+HOMEPAGE="http://pypi.python.org/pypi/python-wifi/"
+SRC_URI="
+ mirror://pypi/packages/source/p/${PN}/${P}.tar.gz
+ mirror://berlios/${PN/-}/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="LGPL-2.1 examples? ( GPL-2 )"
+IUSE="examples"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools"
+
+DOCS="docs/AUTHORS docs/BUGS docs/DEVEL.txt docs/TODO"
+
+src_install() {
+ distutils_src_install
+ if use examples; then
+ insinto /usr/share/${P}/
+ doins -r examples || die "no examples"
+ fi
+}
diff --git a/net-wireless/python-wifi/python-wifi-0.5.0.ebuild b/net-wireless/python-wifi/python-wifi-0.5.0.ebuild
new file mode 100644
index 000000000000..de7359f8c7fb
--- /dev/null
+++ b/net-wireless/python-wifi/python-wifi-0.5.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/python-wifi/python-wifi-0.5.0.ebuild,v 1.1 2011/03/06 10:31:06 jlec Exp $
+
+EAPI="2"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3*"
+
+inherit distutils
+
+DESCRIPTION="Provides r/w access to a wireless network card's capabilities using the Linux Wireless Extensions"
+HOMEPAGE="http://pypi.python.org/pypi/python-wifi https://developer.berlios.de/projects/pythonwifi"
+SRC_URI="mirror://berlios/${PN/-}/${P}.tar.bz2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="LGPL-2.1 examples? ( GPL-2 )"
+IUSE="examples"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools"
+
+DOCS="docs/AUTHORS docs/BUGS docs/DEVEL.txt docs/TODO"
+
+src_install() {
+ distutils_src_install
+ if use examples; then
+ insinto /usr/share/${P}/
+ doins -r examples || die "no examples"
+ fi
+}