summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Stewart <vericgar@gentoo.org>2005-09-18 06:24:37 +0000
committerMichael Stewart <vericgar@gentoo.org>2005-09-18 06:24:37 +0000
commitfb0015ac5a261d0a855f0acbbea1530af3657223 (patch)
tree4a00aa6b23caa4dc30324baa474a1626673c0479 /net-www/apache/apache-2.0.54-r31.ebuild
parentVersion bump to close bug #106306. Straight to stable as it's all html docs. (diff)
downloadgentoo-2-fb0015ac5a261d0a855f0acbbea1530af3657223.tar.gz
gentoo-2-fb0015ac5a261d0a855f0acbbea1530af3657223.tar.bz2
gentoo-2-fb0015ac5a261d0a855f0acbbea1530af3657223.zip
Fix logic for mpm detection. Fixes bug 104242
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'net-www/apache/apache-2.0.54-r31.ebuild')
-rw-r--r--net-www/apache/apache-2.0.54-r31.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/net-www/apache/apache-2.0.54-r31.ebuild b/net-www/apache/apache-2.0.54-r31.ebuild
index 6b106c739a27..bfc65add0933 100644
--- a/net-www/apache/apache-2.0.54-r31.ebuild
+++ b/net-www/apache/apache-2.0.54-r31.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.54-r31.ebuild,v 1.1 2005/09/18 05:01:04 vericgar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.54-r31.ebuild,v 1.2 2005/09/18 06:24:37 vericgar Exp $
inherit eutils gnuconfig multilib
@@ -380,7 +380,7 @@ try_mpm() {
die "mpm to try not specified!"
fi
- if [ -n "${mpm}" ]; then
+ if [ "x${mpm}" != "x" -a "x${mpm}" != "x${nmpm}" ]; then
mpm_die ${nmpm} ${mpm}
fi