summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Stewart <vericgar@gentoo.org>2006-11-28 03:35:16 +0000
committerMichael Stewart <vericgar@gentoo.org>2006-11-28 03:35:16 +0000
commit9fbe8472998ca17adb1394b26db204923a8150db (patch)
tree95a7e23c47466df5d5093c8e8d810e52253761ac /net-www/apache
parentStabilized on amd64 (see bug #155622). (diff)
downloadgentoo-2-9fbe8472998ca17adb1394b26db204923a8150db.tar.gz
gentoo-2-9fbe8472998ca17adb1394b26db204923a8150db.tar.bz2
gentoo-2-9fbe8472998ca17adb1394b26db204923a8150db.zip
Fix logic for srvdir USE-flag, closes bug #156394
(Portage version: 2.1.2_pre2-r5)
Diffstat (limited to 'net-www/apache')
-rw-r--r--net-www/apache/apache-2.2.3-r1.ebuild24
1 files changed, 13 insertions, 11 deletions
diff --git a/net-www/apache/apache-2.2.3-r1.ebuild b/net-www/apache/apache-2.2.3-r1.ebuild
index 637bcdfb2851..f3c61cdc4bf1 100644
--- a/net-www/apache/apache-2.2.3-r1.ebuild
+++ b/net-www/apache/apache-2.2.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.2.3-r1.ebuild,v 1.1 2006/11/27 02:45:56 vericgar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.2.3-r1.ebuild,v 1.2 2006/11/28 03:35:16 vericgar Exp $
inherit eutils flag-o-matic gnuconfig multilib autotools
@@ -89,16 +89,18 @@ src_unpack() {
${GENTOO_PATCHDIR}/{conf/httpd.conf,init/*,patches/config.layout,scripts/Makefile.suexec,scripts/suexec2-config} \
|| die "libdir sed failed"
- # Use /srv/<FQDN>/www instead of /var/www/<FQDN> if USE=srvdir
- useq srvdir && sed -i -e "s:/var/www/localhost:/srv/localhost/www:g" \
- ${GENTOO_PATCHDIR}/{conf/httpd.conf,conf/modules.d/*,conf/vhosts.d/*,patches/config.layout,init/apache2.confd} \
- || die "srvdir sed failed (1)"
- useq srvdir && sed -i -e "s:/var/www/example.com:/srv/example.com/www:g" \
- ${GENTOO_PATCHDIR}/conf/vhosts.d/*.example \
- || die "srvdir sed failed (2)"
- useq srvdir && sed -i -e "s:/var/www:/srv:g" \
- ${GENTOO_PATCHDIR}/{conf/httpd.conf,conf/suexec-conf,conf/vhosts.d/*.example,scripts/suexec2-config} \
- || die "srvdir sed failed (3)"
+ if useq srvdir; then
+ # Use /srv/<FQDN>/www instead of /var/www/<FQDN> if USE=srvdir
+ sed -i -e "s:/var/www/localhost:/srv/localhost/www:g" \
+ ${GENTOO_PATCHDIR}/{conf/httpd.conf,conf/modules.d/*,conf/vhosts.d/*,patches/config.layout,init/apache2.confd} \
+ || die "srvdir sed failed (1)"
+ sed -i -e "s:/var/www/example.com:/srv/example.com/www:g" \
+ ${GENTOO_PATCHDIR}/conf/vhosts.d/*.example \
+ || die "srvdir sed failed (2)"
+ sed -i -e "s:/var/www:/srv:g" \
+ ${GENTOO_PATCHDIR}/{conf/httpd.conf,conf/suexec-conf,conf/vhosts.d/*.example,scripts/suexec2-config} \
+ || die "srvdir sed failed (3)"
+ fi
#### Patch Organization
# 00-19 Gentoo specific (00_all_some-title.patch)