summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2003-10-05 08:19:39 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2003-10-05 08:19:39 +0000
commitf042b0f142094da98414113bf43d2fe82140773b (patch)
tree6aff87929c6962139b065e1fc11060132d251de6 /net-www/epiphany
parentshould really be ~arch, sorry. (diff)
downloadgentoo-2-f042b0f142094da98414113bf43d2fe82140773b.tar.gz
gentoo-2-f042b0f142094da98414113bf43d2fe82140773b.tar.bz2
gentoo-2-f042b0f142094da98414113bf43d2fe82140773b.zip
Changing the idea behind the patch
Diffstat (limited to 'net-www/epiphany')
-rw-r--r--net-www/epiphany/ChangeLog6
-rw-r--r--net-www/epiphany/epiphany-1.0.ebuild4
-rw-r--r--net-www/epiphany/files/epiphany-1.0-disable_Werror.patch16
-rw-r--r--net-www/epiphany/files/epiphany-1.0-gcc2_Werror_fix.patch13
4 files changed, 23 insertions, 16 deletions
diff --git a/net-www/epiphany/ChangeLog b/net-www/epiphany/ChangeLog
index 0ddad0521363..8667855c5f8c 100644
--- a/net-www/epiphany/ChangeLog
+++ b/net-www/epiphany/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for net-www/epiphany
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/epiphany/ChangeLog,v 1.22 2003/10/04 17:10:36 leonardop Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/epiphany/ChangeLog,v 1.23 2003/10/05 08:19:39 leonardop Exp $
+ 05 Oct 2003; L. Boshell <leonardop@gentoo.org> epiphany-1.0.ebuild:
+ Taking a different approach with the patch. Just disable -Werror by
+ default, since it brings up troubles that are gcc-2's fault anyway.
+
04 Oct 2003; L. Boshell <leonardop@gentoo.org> epiphany-1.0.ebuild:
Added patch to make it compile under gcc-2. Thanks to Tristan Henderson
for the patch and contribution on bug #28686.
diff --git a/net-www/epiphany/epiphany-1.0.ebuild b/net-www/epiphany/epiphany-1.0.ebuild
index 7a312a6ddfe7..7726b3c6eab2 100644
--- a/net-www/epiphany/epiphany-1.0.ebuild
+++ b/net-www/epiphany/epiphany-1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/epiphany/epiphany-1.0.ebuild,v 1.3 2003/10/04 17:10:36 leonardop Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/epiphany/epiphany-1.0.ebuild,v 1.4 2003/10/05 08:19:39 leonardop Exp $
inherit gnome2
@@ -47,6 +47,6 @@ src_unpack() {
unpack ${A}
cd ${S}
- epatch ${FILESDIR}/${P}-gcc2_Werror_fix.patch
+ epatch ${FILESDIR}/${P}-disable_Werror.patch
}
diff --git a/net-www/epiphany/files/epiphany-1.0-disable_Werror.patch b/net-www/epiphany/files/epiphany-1.0-disable_Werror.patch
new file mode 100644
index 000000000000..d195ef437668
--- /dev/null
+++ b/net-www/epiphany/files/epiphany-1.0-disable_Werror.patch
@@ -0,0 +1,16 @@
+diff -NurB epiphany-1.0-orig/configure epiphany-1.0/configure
+--- epiphany-1.0-orig/configure 2003-10-04 11:16:56.000000000 -0500
++++ epiphany-1.0/configure 2003-10-05 00:22:23.000000000 -0500
+@@ -20222,9 +20222,9 @@
+ unset SAVE_CFLAGS
+ done
+ unset option
+- if test "$enable_compile_warnings" = "error" ; then
+- warning_flags="$warning_flags -Werror"
+- fi
++# if test "$enable_compile_warnings" = "error" ; then
++# warning_flags="$warning_flags -Werror"
++# fi
+ ;;
+ *)
+ { { echo "$as_me:$LINENO: error: Unknown argument '$enable_compile_warnings' to --enable-compile-warnings" >&5
diff --git a/net-www/epiphany/files/epiphany-1.0-gcc2_Werror_fix.patch b/net-www/epiphany/files/epiphany-1.0-gcc2_Werror_fix.patch
deleted file mode 100644
index c8b4984d6f03..000000000000
--- a/net-www/epiphany/files/epiphany-1.0-gcc2_Werror_fix.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff -NurB epiphany-1.0-orig/lib/ephy-node.c epiphany-1.0/lib/ephy-node.c
---- epiphany-1.0-orig/lib/ephy-node.c 2003-10-04 11:16:56.000000000 -0500
-+++ epiphany-1.0/lib/ephy-node.c 2003-10-04 11:35:41.000000000 -0500
-@@ -1109,8 +1109,7 @@
-
- g_ptr_array_sort (newkids, compare_func);
-
-- new_order = g_new (int, newkids->len);
-- memset (new_order, -1, sizeof (int) * newkids->len);
-+ new_order = g_new0 (int, newkids->len);
-
- for (i = 0; i < newkids->len; i++)
- {