summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDean Bailey <alron@gentoo.org>2003-04-08 21:53:55 +0000
committerDean Bailey <alron@gentoo.org>2003-04-08 21:53:55 +0000
commit8a8e418a9e784a2c5e114a29efe216c22d466d71 (patch)
tree9c7023afd700a9d62aa1558c44ee07964271bcfd /net-www/horde-turba
parentadded horde-pear, this is php pear files that are more up to date and verifie... (diff)
downloadgentoo-2-8a8e418a9e784a2c5e114a29efe216c22d466d71.tar.gz
gentoo-2-8a8e418a9e784a2c5e114a29efe216c22d466d71.tar.bz2
gentoo-2-8a8e418a9e784a2c5e114a29efe216c22d466d71.zip
version bump and fix with uninstall issues.
Diffstat (limited to 'net-www/horde-turba')
-rw-r--r--net-www/horde-turba/ChangeLog6
-rw-r--r--net-www/horde-turba/files/digest-horde-turba-1.21
-rw-r--r--net-www/horde-turba/horde-turba-1.2.ebuild67
3 files changed, 73 insertions, 1 deletions
diff --git a/net-www/horde-turba/ChangeLog b/net-www/horde-turba/ChangeLog
index a62eedb308db..4a03bc17e72d 100644
--- a/net-www/horde-turba/ChangeLog
+++ b/net-www/horde-turba/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-www/horde-turba
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/horde-turba/ChangeLog,v 1.4 2003/02/12 08:48:16 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/horde-turba/ChangeLog,v 1.5 2003/04/08 21:53:55 alron Exp $
+
+*horde-turba-1.2 (08 Apr 2003)
+ 08 Apr 2003; Dean Bailey <alron@gentoo.org> horde-turba-1.2 :
+ Version bump and fix for when updatin turba.
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/net-www/horde-turba/files/digest-horde-turba-1.2 b/net-www/horde-turba/files/digest-horde-turba-1.2
new file mode 100644
index 000000000000..9fbde0a54611
--- /dev/null
+++ b/net-www/horde-turba/files/digest-horde-turba-1.2
@@ -0,0 +1 @@
+MD5 7c082cdbeb499eef99ff4dbf6b3608f5 turba-1.2.tar.gz 384397
diff --git a/net-www/horde-turba/horde-turba-1.2.ebuild b/net-www/horde-turba/horde-turba-1.2.ebuild
new file mode 100644
index 000000000000..fd7604ad1107
--- /dev/null
+++ b/net-www/horde-turba/horde-turba-1.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/horde-turba/horde-turba-1.2.ebuild,v 1.1 2003/04/08 21:53:55 alron Exp $
+
+DESCRIPTION="Turba ${PV} is the Horde address book / contact management program"
+HOMEPAGE="http://www.horde.org"
+P=turba-1.2
+SRC_URI="ftp://ftp.horde.org/pub/turba/tarballs/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+DEPEND=""
+RDEPEND=">=net-www/horde-2.2.1"
+IUSE=""
+
+find_http_root() {
+ export HTTPD_ROOT=`grep apache /etc/passwd | cut -d: -f6`/htdocs
+ if [ -z "${HTTPD_ROOT}" ]; then
+ eerror "HTTPD_ROOT is null! Using defaults."
+ eerror "You probably want to check /etc/passwd"
+ HTTPD_ROOT="/home/httpd/htdocs"
+ fi
+
+ export REGISTRY=${HTTPD_ROOT}/horde/config/registry.php
+ [ -f ${REGISTRY} ] || REGISTRY=${HTTPD_ROOT}/horde/config/registry.php.dist
+}
+
+pkg_setup() {
+ GREPSQL=`grep sql /var/db/pkg/dev-php/mod_php*/USE`
+ GREPLDAP=`grep ldap /var/db/pkg/dev-php/mod_php*/USE`
+ if [ "${GREPSQL}" != "" ] || [ "${GREPLDAP}" != "" ] ; then
+ return 0
+ else
+ eerror "Missing SQL or LDAP support in mod_php !"
+ die "aborting..."
+ fi
+ find_http_root
+ [ -f ${REGISTRY} ] || die "${REGISTRY} not found"
+}
+
+src_compile() {
+ echo "Nothing to compile"
+}
+
+src_install () {
+
+ # detecting apache usergroup
+ GID=`grep apache /etc/group |cut -d: -f3`
+ if [ -z "${GID}" ]; then
+ einfo "Using default GID of 81 for Apache"
+ GID=81
+ fi
+
+ find_http_root
+ dodir ${HTTPD_ROOT}/horde/turba
+ cp -r . ${D}/${HTTPD_ROOT}/horde/turba
+
+ # protecting files
+ chown -R apache.${GID} ${D}/${HTTPD_ROOT}/horde/turba
+ find ${D}/${HTTPD_ROOT}/horde/turba/ -type f -exec chmod 0640 {} \;
+ find ${D}/${HTTPD_ROOT}/horde/turba/ -type d -exec chmod 0750 {} \;
+}
+
+pkg_postinst() {
+ find_http_root
+ einfo "Please read ${HTTPD_ROOT}/horde/turba/docs/INSTALL !"
+}