summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2007-05-12 10:57:59 +0000
committerLuca Longinotti <chtekk@gentoo.org>2007-05-12 10:57:59 +0000
commit290214386092b8c29ef8ac4febf71a13f4350fc8 (patch)
tree0820118944c8819533b628fc67eb05b4e74d7f1d /net-www/mod_auth_pam/mod_auth_pam-1.1.1-r1.ebuild
parentVersion bump. (diff)
downloadgentoo-2-290214386092b8c29ef8ac4febf71a13f4350fc8.tar.gz
gentoo-2-290214386092b8c29ef8ac4febf71a13f4350fc8.tar.bz2
gentoo-2-290214386092b8c29ef8ac4febf71a13f4350fc8.zip
Remove Apache1 support, fix Apache2 support.
(Portage version: 2.1.2.7)
Diffstat (limited to 'net-www/mod_auth_pam/mod_auth_pam-1.1.1-r1.ebuild')
-rw-r--r--net-www/mod_auth_pam/mod_auth_pam-1.1.1-r1.ebuild21
1 files changed, 6 insertions, 15 deletions
diff --git a/net-www/mod_auth_pam/mod_auth_pam-1.1.1-r1.ebuild b/net-www/mod_auth_pam/mod_auth_pam-1.1.1-r1.ebuild
index 2f386c483301..5fde88f79f1c 100644
--- a/net-www/mod_auth_pam/mod_auth_pam-1.1.1-r1.ebuild
+++ b/net-www/mod_auth_pam/mod_auth_pam-1.1.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_pam/mod_auth_pam-1.1.1-r1.ebuild,v 1.15 2007/01/20 11:16:56 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_pam/mod_auth_pam-1.1.1-r1.ebuild,v 1.16 2007/05/12 10:57:59 chtekk Exp $
inherit eutils apache-module
@@ -15,14 +15,9 @@ IUSE=""
DEPEND="sys-libs/pam"
RDEPEND="${DEPEND}"
-APXS1_ARGS="-c ${PN}.c -lpam"
APXS2_ARGS="-c ${PN}.c -lpam"
-
APACHE2_EXECFILES=".libs/mod_auth_sys_group.so"
-APACHE1_MOD_CONF="10_${PN}_ap1"
-APACHE1_MOD_DEFINE="AUTH_PAM"
-
APACHE2_MOD_CONF="10_${PN}"
APACHE2_MOD_DEFINE="AUTH_PAM"
@@ -30,30 +25,26 @@ DOCFILES="INSTALL README doc/*"
need_apache
-SRC_URI="apache2? ( http://pam.sourceforge.net/mod_auth_pam/dist/${PN}-2.0-${PV}.tar.gz )
- !apache2? ( http://pam.sourceforge.net/mod_auth_pam/dist/${P}.tar.gz )"
+SRC_URI="http://pam.sourceforge.net/mod_auth_pam/dist/${PN}-2.0-${PV}.tar.gz"
-use apache2 && S="${WORKDIR}/${PN}"
+S="${WORKDIR}/${PN}"
src_unpack() {
unpack ${A}
cd "${S}"
- use apache2 || epatch "${FILESDIR}/${P}-compile-fix.patch"
- use apache2 && sed -i -e 's/servicename = "httpd"/servicename = "apache2"/' "${PN}.c"
- use apache2 || sed -i -e 's/servicename = "httpd"/servicename = "apache"/' "${PN}.c"
+ sed -i -e 's/servicename = "httpd"/servicename = "apache2"/' "${PN}.c"
}
src_compile() {
apache-module_src_compile
- use apache2 && ${APXS2} -c mod_auth_sys_group.c
+ ${APXS2} -c mod_auth_sys_group.c
}
src_install() {
apache-module_src_install
insinto /etc/pam.d
- use apache2 && newins "${FILESDIR}/apache2.pam" apache2
- use apache2 || newins "${FILESDIR}/apache2.pam" apache
+ newins "${FILESDIR}/apache2.pam" apache2
}
pkg_postinst() {