summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Parpart <trapni@gentoo.org>2005-01-10 22:05:39 +0000
committerChristian Parpart <trapni@gentoo.org>2005-01-10 22:05:39 +0000
commitc254cdd12e82ce2330a4357bfcbb9a67e3fc41db (patch)
tree6c501b6a28b0df882145ac0267507abd0465e7ad /net-www/mod_auth_pam/mod_auth_pam-1.1.1-r1.ebuild
parentadded raidutils to portage (diff)
downloadgentoo-2-c254cdd12e82ce2330a4357bfcbb9a67e3fc41db.tar.gz
gentoo-2-c254cdd12e82ce2330a4357bfcbb9a67e3fc41db.tar.bz2
gentoo-2-c254cdd12e82ce2330a4357bfcbb9a67e3fc41db.zip
merged from apache-herd svn tree
Diffstat (limited to 'net-www/mod_auth_pam/mod_auth_pam-1.1.1-r1.ebuild')
-rw-r--r--net-www/mod_auth_pam/mod_auth_pam-1.1.1-r1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/net-www/mod_auth_pam/mod_auth_pam-1.1.1-r1.ebuild b/net-www/mod_auth_pam/mod_auth_pam-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..8383cd8afbee
--- /dev/null
+++ b/net-www/mod_auth_pam/mod_auth_pam-1.1.1-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_pam/mod_auth_pam-1.1.1-r1.ebuild,v 1.1 2005/01/10 22:05:39 trapni Exp $
+
+inherit eutils apache-module
+
+DESCRIPTION="PAM authentication module for Apache2"
+HOMEPAGE="http://pam.sourceforge.net/mod_auth_pam/"
+
+SRC_URI="http://pam.sourceforge.net/mod_auth_pam/dist/${PN}-2.0-1.1.1.tar.gz"
+LICENSE="Apache-1.1"
+
+KEYWORDS="~x86 ~ppc ~sparc"
+
+DEPEND="sys-libs/pam"
+SLOT="0"
+IUSE=""
+
+S="${WORKDIR}/${PN}"
+
+APXS2_S="${S}/.libs"
+APACHE2_MOD_CONF="${PVR}/10_mod_auth_pam"
+DOCFILES="INSTALL README"
+
+
+src_unpack() {
+ unpack "${PN}-2.0-1.1.1.tar.gz"
+ cd "${S}"
+ epatch ${FILESDIR}/${PF}-gentoo.diff || die
+}
+
+src_compile() {
+ emake APXS=${APXS2} || die
+}
+
+src_install () {
+ APACHE2_MOD_FILE='mod_auth_sys_group.so' apache2_src_install
+ unset DOCFILES APACHE2_MOD_CONF
+ APACHE2_MOD_FILE='mod_auth_pam.so' apache2_src_install
+
+ insinto /etc/pam.d
+ newins ${FILESDIR}/apache2.pam apache2
+
+ dohtml doc/*
+}
+
+pkg_postinst() {
+ local gid=`grep ^shadow: /etc/group | cut -d: -f3`
+ einfo
+ einfo "If the system is configured with the shadow authentication method"
+ einfo "the following commands must be executed by root to make /etc/shadow"
+ einfo "accessible by the apache server:"
+ einfo
+ if [ -z "${gid}" ]; then
+ einfo " # groupadd shadow"
+ einfo " # gpasswd -a apache shadow"
+ gid='shadow'
+ fi
+ einfo " # chgrp ${gid} /etc/shadow"
+ einfo " # chmod 640 /etc/shadow"
+ einfo
+}