summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Laue <brad@gentoo.org>2004-10-29 05:59:57 +0000
committerBrad Laue <brad@gentoo.org>2004-10-29 05:59:57 +0000
commitadf6f31d824e7f350a2a54e417e5c00a6ac69958 (patch)
tree61ba9f9d92ae8a004f4973140d396f46c4f6ebfe /net-www/mozilla-firefox-bin
parentupdated the multicast dns patch from suse and added an example host.conf that... (diff)
downloadgentoo-2-adf6f31d824e7f350a2a54e417e5c00a6ac69958.tar.gz
gentoo-2-adf6f31d824e7f350a2a54e417e5c00a6ac69958.tar.bz2
gentoo-2-adf6f31d824e7f350a2a54e417e5c00a6ac69958.zip
Update to 1.0RC1
Diffstat (limited to 'net-www/mozilla-firefox-bin')
-rw-r--r--net-www/mozilla-firefox-bin/files/digest-mozilla-firefox-bin-1.0_rc11
-rw-r--r--net-www/mozilla-firefox-bin/mozilla-firefox-bin-1.0_rc1.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/net-www/mozilla-firefox-bin/files/digest-mozilla-firefox-bin-1.0_rc1 b/net-www/mozilla-firefox-bin/files/digest-mozilla-firefox-bin-1.0_rc1
new file mode 100644
index 000000000000..f3a9395e48a1
--- /dev/null
+++ b/net-www/mozilla-firefox-bin/files/digest-mozilla-firefox-bin-1.0_rc1
@@ -0,0 +1 @@
+MD5 9a4f75963f65292fdfc919daa06c0add firefox-1.0rc1.en-US.linux-i686.tar.gz 8250499
diff --git a/net-www/mozilla-firefox-bin/mozilla-firefox-bin-1.0_rc1.ebuild b/net-www/mozilla-firefox-bin/mozilla-firefox-bin-1.0_rc1.ebuild
new file mode 100644
index 000000000000..ebbee271ddca
--- /dev/null
+++ b/net-www/mozilla-firefox-bin/mozilla-firefox-bin-1.0_rc1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firefox-bin/mozilla-firefox-bin-1.0_rc1.ebuild,v 1.1 2004/10/29 05:59:57 brad Exp $
+
+inherit nsplugins eutils mozilla-launcher
+
+IUSE="gnome"
+
+MY_PV=${PV/_/}
+S=${WORKDIR}/firefox
+DESCRIPTION="The Mozilla Firefox Web Browser"
+# Mirrors have it in one of the following places, depending on what
+# mirror you check and when you check it... :-(
+SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${MY_PV}/firefox-${MY_PV}.en-US.linux-i686.tar.gz"
+HOMEPAGE="http://www.mozilla.org/projects/firefox"
+RESTRICT="nostrip"
+
+KEYWORDS="-* x86 amd64"
+SLOT="0"
+LICENSE="MPL-1.1 NPL-1.1"
+
+DEPEND="virtual/libc"
+RDEPEND="virtual/x11
+ x86? (
+ >=sys-libs/lib-compat-1.0-r2
+ >=x11-libs/gtk+-2.2
+ )
+ amd64? (
+ >=app-emulation/emul-linux-x86-baselibs-1.0
+ >=app-emulation/emul-linux-x86-gtklibs-1.0
+ )
+ virtual/x11
+ >=net-www/mozilla-launcher-1.13"
+
+src_install() {
+ # Install firefox in /opt
+ dodir /opt
+ mv ${S} ${D}/opt/firefox
+
+ # Plugin path setup (rescuing the existing plugins)
+ src_mv_plugins /opt/firefox/plugins
+
+ # Fixing permissions
+ chown -R root:root ${D}/opt/firefox
+
+ # mozilla-launcher-1.8 supports -bin versions
+ dodir /usr/bin
+ dosym /usr/libexec/mozilla-launcher /usr/bin/firefox-bin
+
+ # Install icon and .desktop for menu entry
+ if use gnome; then
+ insinto /usr/share/pixmaps
+ doins ${FILESDIR}/icon/mozillafirefox-bin-icon.png
+ # Fix bug 54179: Install .desktop file into /usr/share/applications
+ # instead of /usr/share/gnome/apps/Internet (18 Jun 2004 agriffis)
+ insinto /usr/share/applications
+ doins ${FILESDIR}/icon/mozillafirefox-bin.desktop
+ fi
+
+ # Normally firefox-bin-0.9 must be run as root once before it can
+ # be run as a normal user. Drop in some initialized files to
+ # avoid this.
+ einfo "Extracting firefox-bin-${PV} initialization files"
+ tar xjpf ${FILESDIR}/firefox-bin-0.9-init.tar.bz2 -C ${D}/opt/firefox
+}
+
+pkg_preinst() {
+ export MOZILLA_FIVE_HOME=${ROOT}/opt/firefox
+
+ # Remove the old plugins dir
+ pkg_mv_plugins /opt/firefox/plugins
+
+ # Remove entire installed instance to prevent all kinds of
+ # problems... see bug 44772 for example
+ rm -rf "${MOZILLA_FIVE_HOME}"
+}
+
+pkg_postinst() {
+ export MOZILLA_FIVE_HOME=${ROOT}/opt/firefox
+
+ update_mozilla_launcher_symlinks
+}
+
+pkg_postrm() {
+ update_mozilla_launcher_symlinks
+}