summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2003-03-16 07:44:55 +0000
committerMartin Schlemmer <azarah@gentoo.org>2003-03-16 07:44:55 +0000
commit05d6c0f4f09fece63abb8e28f10f0df7178ec5f2 (patch)
tree46c350a69073dfa02e38b572dbbc81958e950bf3 /net-www/mplayerplug-in
parentadded ChangeLog, and corrected ebuild. (diff)
downloadgentoo-2-05d6c0f4f09fece63abb8e28f10f0df7178ec5f2.tar.gz
gentoo-2-05d6c0f4f09fece63abb8e28f10f0df7178ec5f2.tar.bz2
gentoo-2-05d6c0f4f09fece63abb8e28f10f0df7178ec5f2.zip
new version
Diffstat (limited to 'net-www/mplayerplug-in')
-rw-r--r--net-www/mplayerplug-in/ChangeLog7
-rw-r--r--net-www/mplayerplug-in/files/digest-mplayerplug-in-0.602
-rw-r--r--net-www/mplayerplug-in/mplayerplug-in-0.60.ebuild54
3 files changed, 62 insertions, 1 deletions
diff --git a/net-www/mplayerplug-in/ChangeLog b/net-www/mplayerplug-in/ChangeLog
index 224d35e80f35..fd1fb262371f 100644
--- a/net-www/mplayerplug-in/ChangeLog
+++ b/net-www/mplayerplug-in/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/mplayerplug-in
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/ChangeLog,v 1.2 2003/02/19 23:39:47 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/ChangeLog,v 1.3 2003/03/16 07:44:55 azarah Exp $
+
+*mplayerplug-in-0.60 (16 Mar 2003)
+
+ 16 Mar 2003; Martin Schlemmer <azarah@gentoo.org> mplayerplug-in-0.60.ebuild :
+ Update version, closing bug #16854.
*mplayerplug-in-0.40 (16 Feb 2003)
diff --git a/net-www/mplayerplug-in/files/digest-mplayerplug-in-0.60 b/net-www/mplayerplug-in/files/digest-mplayerplug-in-0.60
new file mode 100644
index 000000000000..65209e2bcf50
--- /dev/null
+++ b/net-www/mplayerplug-in/files/digest-mplayerplug-in-0.60
@@ -0,0 +1,2 @@
+MD5 a7579d9ee11f107c584de569f831ce67 mplayerplug-in_v0.60.tar.gz 35492
+MD5 88ffb4b41928f5b063800bab46be1545 mini.tar.bz2 5775
diff --git a/net-www/mplayerplug-in/mplayerplug-in-0.60.ebuild b/net-www/mplayerplug-in/mplayerplug-in-0.60.ebuild
new file mode 100644
index 000000000000..ff75bd16177c
--- /dev/null
+++ b/net-www/mplayerplug-in/mplayerplug-in-0.60.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/mplayerplug-in-0.60.ebuild,v 1.1 2003/03/16 07:44:55 azarah Exp $
+
+IUSE=""
+
+inherit nsplugins
+
+S="${WORKDIR}/mplayerplug-in"
+HOMEPAGE="http://mplayerplug-in.sourceforge.net/"
+DESCRIPTION="mplayer plug-in for Mozilla"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_v${PV}.tar.gz
+ mirror://sourceforge/${PN}/mini.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND=">=media-video/mplayer-0.90_rc4"
+
+src_compile() {
+ [ -z "${CC}" ] && CC="gcc"
+ emake CC="${CC}" OPTIMIZER="${CFLAGS}" || die
+}
+
+src_install() {
+ exeinto /opt/netscape/plugins
+ doexe mplayerplug-in.so
+
+ inst_plugin /opt/netscape/plugins/mplayerplug-in.so
+
+ insinto /usr/share/mplayer/Skin/mini
+ doins ${WORKDIR}/mini/*
+
+ dodir /etc
+ # For some reason this does not work yet for mplayer options, and
+ # setting 'vo' cause it for 'mozilla file:///space/movies/foo.avi'
+ # at least to not work...
+ cat > ${D}/etc/mplayerplug-in.conf <<END
+# Should it handle embedded movies ?
+noembed=0
+
+# Set to 'mini' if you want the seek bar
+use-gui=no
+
+# Normal mplayer style config options
+#vo=x11
+fs=no
+zoom=yes
+END
+
+ dodoc TODO ChangeLog INSTALL README
+}
+