summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2004-05-03 00:38:36 +0000
committerStuart Herbert <stuart@gentoo.org>2004-05-03 00:38:36 +0000
commitfb523006c1ec7c44ea826bcad6a887d252865c25 (patch)
tree4ebd128c8cbeb6fd97aac3a6a4197ef46e8f3fb6 /net-www/mypictures
parentMarked stable on ppc/sparc/alpha/amd64/hppa/ia64/mips. (Manifest recommit) (diff)
downloadgentoo-2-fb523006c1ec7c44ea826bcad6a887d252865c25.tar.gz
gentoo-2-fb523006c1ec7c44ea826bcad6a887d252865c25.tar.bz2
gentoo-2-fb523006c1ec7c44ea826bcad6a887d252865c25.zip
Initial import
Diffstat (limited to 'net-www/mypictures')
-rw-r--r--net-www/mypictures/ChangeLog10
-rw-r--r--net-www/mypictures/Manifest5
-rw-r--r--net-www/mypictures/files/digest-mypictures-200402021
-rw-r--r--net-www/mypictures/files/mypictures.diff14
-rw-r--r--net-www/mypictures/metadata.xml8
-rw-r--r--net-www/mypictures/mypictures-20040202.ebuild45
6 files changed, 83 insertions, 0 deletions
diff --git a/net-www/mypictures/ChangeLog b/net-www/mypictures/ChangeLog
new file mode 100644
index 000000000000..280d3e6eb3f8
--- /dev/null
+++ b/net-www/mypictures/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-www/mypictures
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mypictures/ChangeLog,v 1.1 2004/05/03 00:38:36 stuart Exp $
+
+*mypictures-20040202 (03 May 2004)
+
+ 03 May 2004; Stuart Herbert <stuart@gentoo.org> metadata.xml,
+ mypictures-20040202.ebuild, files/mypictures.diff:
+ Initial import
+
diff --git a/net-www/mypictures/Manifest b/net-www/mypictures/Manifest
new file mode 100644
index 000000000000..d10495e5949e
--- /dev/null
+++ b/net-www/mypictures/Manifest
@@ -0,0 +1,5 @@
+MD5 3d182d43f7f0341a9a42f96694f04e72 metadata.xml 224
+MD5 c28a64bcc747811ca674579af895f39e ChangeLog 126
+MD5 a37d51200521806caf0eb44db6f4e1e1 mypictures-20040202.ebuild 984
+MD5 d0c4d3efa97c9bf0927e82f3cdb295b8 files/digest-mypictures-20040202 58
+MD5 31a77b7664997f1fa8e77af1adf58833 files/mypictures.diff 482
diff --git a/net-www/mypictures/files/digest-mypictures-20040202 b/net-www/mypictures/files/digest-mypictures-20040202
new file mode 100644
index 000000000000..b2271d4f8287
--- /dev/null
+++ b/net-www/mypictures/files/digest-mypictures-20040202
@@ -0,0 +1 @@
+MD5 0f38d5d868bb36add29e8032083a4a8d mypictures.tgz 43783
diff --git a/net-www/mypictures/files/mypictures.diff b/net-www/mypictures/files/mypictures.diff
new file mode 100644
index 000000000000..88c4048ab669
--- /dev/null
+++ b/net-www/mypictures/files/mypictures.diff
@@ -0,0 +1,14 @@
+diff -u --recursive mypictures.orig/index.php mypictures/index.php
+--- mypictures.orig/index.php 2004-05-03 01:45:58.523174520 +0100
++++ mypictures/index.php 2004-05-03 01:47:16.713287816 +0100
+@@ -471,8 +471,8 @@
+ }
+
+ $cmd = $config['convert'];
+- $cmd .= ' -geometry 120x120 ';
+- $cmd .= '"'.$img.'" "'.$thumb.'"';
++ $cmd .= ' -size 120x120 ';
++ $cmd .= '"'.$img.'" -resize 120x120 +profile "*" "'.$thumb.'"';
+ system($cmd);
+
+ header("Content-type: image/png");
diff --git a/net-www/mypictures/metadata.xml b/net-www/mypictures/metadata.xml
new file mode 100644
index 000000000000..0d59c319c3eb
--- /dev/null
+++ b/net-www/mypictures/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>webapps</herd>
+<maintainer>
+ <email>web-apps@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/net-www/mypictures/mypictures-20040202.ebuild b/net-www/mypictures/mypictures-20040202.ebuild
new file mode 100644
index 000000000000..73c10d0ca751
--- /dev/null
+++ b/net-www/mypictures/mypictures-20040202.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mypictures/mypictures-20040202.ebuild,v 1.1 2004/05/03 00:38:36 stuart Exp $
+
+inherit webapp
+
+DESCRIPTION="Simple photo-gallery for websites"
+HOMEPAGE="http://www.splitbrain.org/Programming/PHP/mypictures/index.php"
+SRC_URI="http://www.splitbrain.org/Programming/PHP/mypictures/mypictures.tgz"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="$DEPEND
+ sys-apps/sed"
+RDEPEND="$RDEPEND
+ media-gfx/imagemagick"
+S=${WORKDIR}/${PN}
+
+src_unpack () {
+ unpack "${A}"
+ cd "${S}"
+
+ # we have to patch the path to imagemagick's convert tool
+
+ epatch ${FILESDIR}/mypictures.diff
+ sed -i "s|/usr/bin/X11/convert|/usr/bin/convert|g;" index.php
+}
+
+src_compile() {
+ # do nothing
+ echo > /dev/null
+}
+
+src_install() {
+ webapp_src_preinst
+
+ cp index.php exifReader.inc exifWriter.inc ${D}${MY_HTDOCSDIR}
+ mkdir ${D}${MY_HTDOCSDIR}/.img
+ cp .img/* ${D}${MY_HTDOCSDIR}/.img
+
+ dodoc CHANGES README
+
+ webapp_configfile ${MY_HTDOCSDIR}
+ webapp_src_install
+}