summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-03-28 00:39:41 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-03-28 00:39:41 +0000
commiteba06fe50e5c04feaad9fe7cfc5101b66d751514 (patch)
tree81dc63894283d27a3b1f03da9f431cd5d8a64285 /net-www/skipstone
parentmissing file (diff)
downloadgentoo-2-eba06fe50e5c04feaad9fe7cfc5101b66d751514.tar.gz
gentoo-2-eba06fe50e5c04feaad9fe7cfc5101b66d751514.tar.bz2
gentoo-2-eba06fe50e5c04feaad9fe7cfc5101b66d751514.zip
Patch to remove duplicate translations in the Russian set.
Diffstat (limited to 'net-www/skipstone')
-rw-r--r--net-www/skipstone/ChangeLog11
-rw-r--r--net-www/skipstone/files/digest-skipstone-0.8.0-r11
-rw-r--r--net-www/skipstone/files/skipstone-gentoo.patch40
-rw-r--r--net-www/skipstone/skipstone-0.8.0-r1.ebuild39
4 files changed, 90 insertions, 1 deletions
diff --git a/net-www/skipstone/ChangeLog b/net-www/skipstone/ChangeLog
index 6f9178f04dae..e87a744bcee1 100644
--- a/net-www/skipstone/ChangeLog
+++ b/net-www/skipstone/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-www/skipstone
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/skipstone/ChangeLog,v 1.4 2002/03/27 21:21:03 blocke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/skipstone/ChangeLog,v 1.5 2002/03/28 00:39:41 seemant Exp $
+
+*skipstone-0.8.0-r1 (27 Mar 2002)
+
+ 27 Mar 2002; Seemant Kulleen <seemant@gentoo.org> skipstone-0.8.0-r1.ebuild :
+
+ There seems to be an issue with the Russian translation set from upstream,
+ involving duplicate entries which caused a compilation failure for nls in USE.
+ I am in communication (hopefully) with upstream about this, but in the
+ meantime I have added a patch which removes the duplicate entries.
*skipstone-0.8.0 (27 Mar 2002)
diff --git a/net-www/skipstone/files/digest-skipstone-0.8.0-r1 b/net-www/skipstone/files/digest-skipstone-0.8.0-r1
new file mode 100644
index 000000000000..4635700b671f
--- /dev/null
+++ b/net-www/skipstone/files/digest-skipstone-0.8.0-r1
@@ -0,0 +1 @@
+MD5 3a6903289c7531b75f8e705f72a72b7c skipstone-0.8.0.tar.gz 377299
diff --git a/net-www/skipstone/files/skipstone-gentoo.patch b/net-www/skipstone/files/skipstone-gentoo.patch
new file mode 100644
index 000000000000..d38a347814c8
--- /dev/null
+++ b/net-www/skipstone/files/skipstone-gentoo.patch
@@ -0,0 +1,40 @@
+--- ru.po Wed Mar 27 06:12:03 2002
++++ ru.po.2 Wed Mar 27 16:18:07 2002
+@@ -624,14 +624,6 @@
+ msgid "Clear popup items"
+ msgstr ""
+
+-#: ../src/skipstone-config.c:258
+-msgid "Maximum popup entries: "
+-msgstr "íÁËÓÉÍÕÍ ÓÏÏÂÝÅÎÉÊ: "
+-
+-#: ../src/skipstone-config.c:259
+-msgid "Clear popup items"
+-msgstr "õÄÁÌÉÔØ ÓÏÏÂÝÅÎÉÑ"
+-
+ #: ../src/skipstone-config.c:261
+ msgid "Maximum Go menu items: "
+ msgstr "íÁËÓÉÍÁÌØÎÏÅ ËÏÌÉÞÅÓÔ×Ï ÐÕÎËÔÏ× ÍÅÎÀ ÷ÐÅÒ£Ä:"
+@@ -1441,22 +1433,6 @@
+ msgid "0.5"
+ msgstr ""
+
+-#: ../src/skipstone-print.c:29
+-msgid "0.5"
+-msgstr ""
+-
+-#: ../src/skipstone-print.c:30
+-msgid "0.5"
+-msgstr ""
+-
+-#: ../src/skipstone-print.c:31
+-msgid "0.5"
+-msgstr ""
+-
+-#: ../src/skipstone-print.c:32
+-msgid "Ok"
+-msgstr "ïË"
+-
+ #: ../src/skipstone-print.c:34
+ msgid "Print Error!"
+ msgstr "ïÛÉÂËÁ ÐÅÞÁÔÉ!"
diff --git a/net-www/skipstone/skipstone-0.8.0-r1.ebuild b/net-www/skipstone/skipstone-0.8.0-r1.ebuild
new file mode 100644
index 000000000000..55766c1c0cb1
--- /dev/null
+++ b/net-www/skipstone/skipstone-0.8.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Damon Conway <damon@3jane.net>
+# $Header: /var/cvsroot/gentoo-x86/net-www/skipstone/skipstone-0.8.0-r1.ebuild,v 1.1 2002/03/28 00:39:41 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GTK+ based web browser based on the Mozilla engine"
+SRC_URI="http://www.muhri.net/skipstone/${P}.tar.gz"
+HOMEPAGE="http://www.muhri.net/skipstone/"
+
+DEPEND="nls? ( sys-devel/gettext )
+ ~net-www/mozilla-0.9.9
+ >=x11-libs/gtk+-1.2.10"
+
+use nls && myconf="enable_nls=1"
+
+src_compile() {
+
+ if [ "`use nls`" ]
+ then
+ cd ${S}/src
+ xgettext -k_ -kN_ ../src/*.[ch] -o ../locale/skipstone.pot
+ cd ${S}/locale
+ patch < ${FILESDIR}/skipstone-gentoo.patch
+ fi
+
+ cd ${S}/src
+ emake \
+ ${myconf} \
+ PREFIX="/usr/lib/mozilla" || die
+}
+
+src_install () {
+ make \
+ PREFIX=${D}/usr \
+ LOCALEDIR=${D}/usr/share/locale \
+ ${myconf} install || die
+ dodoc AUTHORS COPYING README README.copying
+}