summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2006-07-11 16:18:31 +0000
committerJoseph Jezak <josejx@gentoo.org>2006-07-11 16:18:31 +0000
commit0dd8acf318032462d1f919c1eb5ff5031bfb1a1e (patch)
treee5467c2316300259d25b0d0618b72e2eb6427e83 /net-www
parentMark 1.0.0 stable on ia64 (diff)
downloadgentoo-2-0dd8acf318032462d1f919c1eb5ff5031bfb1a1e.tar.gz
gentoo-2-0dd8acf318032462d1f919c1eb5ff5031bfb1a1e.tar.bz2
gentoo-2-0dd8acf318032462d1f919c1eb5ff5031bfb1a1e.zip
Removed moz/gecko-sdk references and fixed bug #139898.
(Portage version: 2.1.1_pre2-r6)
Diffstat (limited to 'net-www')
-rw-r--r--net-www/mplayerplug-in/ChangeLog8
-rw-r--r--net-www/mplayerplug-in/files/digest-mplayerplug-in-3.25-r13
-rw-r--r--net-www/mplayerplug-in/files/fix-cflags.patch11
-rw-r--r--net-www/mplayerplug-in/mplayerplug-in-3.25-r1.ebuild82
4 files changed, 103 insertions, 1 deletions
diff --git a/net-www/mplayerplug-in/ChangeLog b/net-www/mplayerplug-in/ChangeLog
index ba8ff1959df1..d8fe830c53d7 100644
--- a/net-www/mplayerplug-in/ChangeLog
+++ b/net-www/mplayerplug-in/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/mplayerplug-in
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/ChangeLog,v 1.65 2006/07/03 03:46:36 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/ChangeLog,v 1.66 2006/07/11 16:18:31 josejx Exp $
+
+*mplayerplug-in-3.25-r1 (11 Jul 2006)
+
+ 11 Jul 2006; Joseph Jezak <josejx@gentoo.org> +files/fix-cflags.patch,
+ +mplayerplug-in-3.25-r1.ebuild:
+ Removed moz/gecko-sdk references and fixed bug #139838.
03 Jul 2006; Thomas Cort <tcort@gentoo.org> mplayerplug-in-3.21.ebuild:
Stable on alpha wrt Bug #138735.
diff --git a/net-www/mplayerplug-in/files/digest-mplayerplug-in-3.25-r1 b/net-www/mplayerplug-in/files/digest-mplayerplug-in-3.25-r1
new file mode 100644
index 000000000000..7a883ebb4c35
--- /dev/null
+++ b/net-www/mplayerplug-in/files/digest-mplayerplug-in-3.25-r1
@@ -0,0 +1,3 @@
+MD5 fb99a2efeacd5aed8b92ae0bb33c708a mplayerplug-in-3.25.tar.gz 209554
+RMD160 885f6b7eb69f5c0ddb7e3356801a235906723efa mplayerplug-in-3.25.tar.gz 209554
+SHA256 ce8304c3cab3ffc10888f3648d9470ab7db7609c5178ef3a6cb3163fc7b901c8 mplayerplug-in-3.25.tar.gz 209554
diff --git a/net-www/mplayerplug-in/files/fix-cflags.patch b/net-www/mplayerplug-in/files/fix-cflags.patch
new file mode 100644
index 000000000000..31f713545fc6
--- /dev/null
+++ b/net-www/mplayerplug-in/files/fix-cflags.patch
@@ -0,0 +1,11 @@
+--- Makefile.in.bak 2006-07-11 15:48:20.000000000 +0000
++++ Makefile.in 2006-07-11 15:47:55.000000000 +0000
+@@ -12,7 +12,7 @@
+
+ CC= @CC@
+ CXX= @CXX@
+-CFLAGS= -Wall @CFLAGS@ @CPPFLAGS@ @CXXFLAGS@ @CXXFLAGS64@ -DXP_UNIX -DMOZ_X11 @MOZPLUG_CFLAGS@ -Iinclude -fPIC @GECKO_DEFINES@ @GTK_CFLAGS@ @GTHREAD_CFLAGS@ @GTK_DEFINES@
++CFLAGS= -Wall @CPPFLAGS@ @CXXFLAGS@ @CXXFLAGS64@ -DXP_UNIX -DMOZ_X11 @MOZPLUG_CFLAGS@ -Iinclude -fPIC @GECKO_DEFINES@ @GTK_CFLAGS@ @GTHREAD_CFLAGS@ @GTK_DEFINES@
+ LDFLAGS= @LDFLAGS@ @LDFLAGS64@ @LIBS@ @X_PRE_LIBS@ @XEXT_LIBS@ @XPM_LIBS@ @MOZPLUG_LIBS@ @GTK_LIBS@ @GTHREAD_LIBS@
+ LIBOBJS= @LIBOBJS@
+ OBJ= plugin.o nsScriptablePeer.o npp_gate.o np_entry.o npn_gate.o \
diff --git a/net-www/mplayerplug-in/mplayerplug-in-3.25-r1.ebuild b/net-www/mplayerplug-in/mplayerplug-in-3.25-r1.ebuild
new file mode 100644
index 000000000000..93627622d818
--- /dev/null
+++ b/net-www/mplayerplug-in/mplayerplug-in-3.25-r1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/mplayerplug-in-3.25-r1.ebuild,v 1.1 2006/07/11 16:18:31 josejx Exp $
+
+inherit eutils multilib nsplugins
+
+DESCRIPTION="mplayer plug-in for Gecko based browsers"
+HOMEPAGE="http://mplayerplug-in.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 -hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE="gtk"
+
+DEPEND=">=media-video/mplayer-1.0_pre5
+ || ( www-client/mozilla-firefox
+ www-client/seamonkey
+ )
+ || ( ( x11-libs/libXpm
+ x11-proto/xextproto
+ )
+ virtual/x11
+ )
+ gtk? (
+ >=x11-libs/gtk+-2.2.0
+ dev-libs/atk
+ >=dev-libs/glib-2.2.0
+ >=x11-libs/pango-1.2.1
+ )"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-gcc4.patch
+ epatch ${FILESDIR}/fix-cflags.patch
+}
+
+src_compile() {
+ local myconf
+
+ # We force gtk2 now because moz only compiles against gtk2
+ if use gtk; then
+ myconf="${myconf} --enable-gtk2"
+ else
+ ewarn "For playback controls, you must enable gtk support."
+ myconf="${myconf} --enable-x"
+ fi
+
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ exeinto /opt/netscape/plugins
+ doexe mplayerplug-in.so || die "plugin failed"
+ inst_plugin /opt/netscape/plugins/mplayerplug-in.so
+
+ insinto /opt/netscape/plugins
+ doins mplayerplug-in.xpt || die "xpt failed"
+ inst_plugin /opt/netscape/plugins/mplayerplug-in.xpt
+
+ PLUGINS="gmp rm qt wmp"
+
+ for plugin in ${PLUGINS}; do
+ ### Install the plugin
+ exeinto /opt/netscape/plugins
+ doexe "mplayerplug-in-${plugin}.so" || die "plugin ${plugin} failed"
+ inst_plugin "/opt/netscape/plugins/mplayerplug-in-${plugin}.so"
+ ### Install the xpt
+ insinto /opt/netscape/plugins
+ doins "mplayerplug-in-${plugin}.xpt" || die "plugin ${plugin} xpt failed"
+ inst_plugin "/opt/netscape/plugins/mplayerplug-in-${plugin}.xpt"
+ done
+
+ insinto /etc
+ doins mplayerplug-in.conf
+
+ dodoc ChangeLog INSTALL README DOCS/tech/*.txt
+}