summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2008-12-29 15:48:35 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2008-12-29 15:48:35 +0000
commit3d893d8e9d598f5d09d0882ce32f79ea17ed7445 (patch)
treecc642e792c763c9a4614f8bca680c2c3c55e06fb /net-www
parentVersion bump (diff)
downloadgentoo-2-3d893d8e9d598f5d09d0882ce32f79ea17ed7445.tar.gz
gentoo-2-3d893d8e9d598f5d09d0882ce32f79ea17ed7445.tar.bz2
gentoo-2-3d893d8e9d598f5d09d0882ce32f79ea17ed7445.zip
Fix libdir placement. Per bug #231894.
(Portage version: 2.2_rc19/cvs/Linux 2.6.28-gentoo i686)
Diffstat (limited to 'net-www')
-rw-r--r--net-www/kaffeine-mozilla-plugin/ChangeLog8
-rw-r--r--net-www/kaffeine-mozilla-plugin/kaffeine-mozilla-plugin-0.2.ebuild11
2 files changed, 13 insertions, 6 deletions
diff --git a/net-www/kaffeine-mozilla-plugin/ChangeLog b/net-www/kaffeine-mozilla-plugin/ChangeLog
index d410b7f7a1c1..232818bc58a6 100644
--- a/net-www/kaffeine-mozilla-plugin/ChangeLog
+++ b/net-www/kaffeine-mozilla-plugin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-www/kaffeine-mozilla-plugin
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/kaffeine-mozilla-plugin/ChangeLog,v 1.12 2007/07/22 07:43:10 dberkholz Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/kaffeine-mozilla-plugin/ChangeLog,v 1.13 2008/12/29 15:48:35 scarabeus Exp $
+
+ 29 Dec 2008; Tomas Chvatal <scarabeus@gentoo.org>
+ kaffeine-mozilla-plugin-0.2.ebuild:
+ Fix libdir placement. Per bug #231894.
22 Jul 2007; Donnie Berkholz <dberkholz@gentoo.org>;
kaffeine-mozilla-plugin-0.2.ebuild:
diff --git a/net-www/kaffeine-mozilla-plugin/kaffeine-mozilla-plugin-0.2.ebuild b/net-www/kaffeine-mozilla-plugin/kaffeine-mozilla-plugin-0.2.ebuild
index 18b3f24f648b..7cd6b3dfb268 100644
--- a/net-www/kaffeine-mozilla-plugin/kaffeine-mozilla-plugin-0.2.ebuild
+++ b/net-www/kaffeine-mozilla-plugin/kaffeine-mozilla-plugin-0.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/kaffeine-mozilla-plugin/kaffeine-mozilla-plugin-0.2.ebuild,v 1.11 2007/07/22 07:43:10 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/kaffeine-mozilla-plugin/kaffeine-mozilla-plugin-0.2.ebuild,v 1.12 2008/12/29 15:48:35 scarabeus Exp $
inherit nsplugins multilib
@@ -21,11 +21,14 @@ RDEPEND=">=media-video/kaffeine-0.4.3
DEPEND="${RDEPEND}"
src_compile() {
- econf --prefix=/usr/$(get_libdir)/${PLUGINS_DIR} || die
+ econf \
+ --prefix=/usr/$(get_libdir)/${PLUGINS_DIR}
+ --libdir=/usr/$(get_libdir)/${PLUGINS_DIR%plugins}
+
emake || die
}
src_install() {
- einstall prefix=${D}/usr/$(get_libdir)/${PLUGINS_DIR%plugins} || die
+ einstall prefix="${D}"/usr/$(get_libdir)/${PLUGINS_DIR%plugins} || die
dodoc AUTHORS ChangeLog README
}