summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2007-06-05 16:41:01 +0000
committerChristian Heim <phreak@gentoo.org>2007-06-05 16:41:01 +0000
commitc0d891d464eba7b1d69f365562fafc27d658b9c2 (patch)
treec63700b51b4d3a823405d88a36a2ecb1c9020fb0 /net-www
parentVersion bump, remove old (diff)
downloadgentoo-2-c0d891d464eba7b1d69f365562fafc27d658b9c2.tar.gz
gentoo-2-c0d891d464eba7b1d69f365562fafc27d658b9c2.tar.bz2
gentoo-2-c0d891d464eba7b1d69f365562fafc27d658b9c2.zip
Yet another revision bump, removing the previously installed original apache configs (install-conf), some config changes (Yet again, yes), adding a patch to fix the case where indexing would be *veery* slow (bug 139451 - thanks to Joshua Pettett <bugs.gentoo.devel at homelinkcs.com>); adding support for /etc/init.d/apache2 modules showing a list of present (as in loaded and compiled-in) modules.
(Portage version: 2.1.2.9)
Diffstat (limited to 'net-www')
-rw-r--r--net-www/apache/ChangeLog13
-rw-r--r--net-www/apache/apache-2.2.4-r5.ebuild (renamed from net-www/apache/apache-2.2.4-r4.ebuild)58
-rw-r--r--net-www/apache/files/digest-apache-2.2.4-r46
-rw-r--r--net-www/apache/files/digest-apache-2.2.4-r56
4 files changed, 58 insertions, 25 deletions
diff --git a/net-www/apache/ChangeLog b/net-www/apache/ChangeLog
index 68fec90b7c52..c8fd79c76b04 100644
--- a/net-www/apache/ChangeLog
+++ b/net-www/apache/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for net-www/apache
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/ChangeLog,v 1.532 2007/06/02 19:34:35 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/ChangeLog,v 1.533 2007/06/05 16:41:01 phreak Exp $
+
+*apache-2.2.4-r5 (05 Jun 2007)
+
+ 05 Jun 2007; Christian Heim <phreak@gentoo.org> -apache-2.2.4-r4.ebuild,
+ +apache-2.2.4-r5.ebuild:
+ Yet another revision bump, removing the previously installed original apache
+ configs (install-conf), some config changes (Yet again, yes), adding a patch
+ to fix the case where indexing would be *veery* slow (bug 139451 - thanks to
+ Joshua Pettett <bugs.gentoo.devel at homelinkcs.com>); adding support for
+ /etc/init.d/apache2 modules showing a list of present (as in loaded and
+ compiled-in) modules.
02 Jun 2007; Luca Longinotti <chtekk@gentoo.org> apache-2.2.4-r4.ebuild:
Expand elog message for upgrades.
diff --git a/net-www/apache/apache-2.2.4-r4.ebuild b/net-www/apache/apache-2.2.4-r5.ebuild
index 3d6896da552a..0ed62a46e7a5 100644
--- a/net-www/apache/apache-2.2.4-r4.ebuild
+++ b/net-www/apache/apache-2.2.4-r5.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.2.4-r4.ebuild,v 1.4 2007/06/02 19:34:35 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.2.4-r5.ebuild,v 1.1 2007/06/05 16:41:01 phreak Exp $
inherit eutils flag-o-matic gnuconfig multilib autotools
# latest gentoo apache files
GENTOO_PATCHNAME="gentoo-${PF}"
-GENTOO_PATCHSTAMP="20070527"
+GENTOO_PATCHSTAMP="20070605"
GENTOO_DEVSPACE="phreak"
GENTOO_PATCHDIR="${WORKDIR}/${GENTOO_PATCHNAME}"
@@ -49,13 +49,15 @@ pkg_setup() {
die "ldap USE-flag enabled while not supported in apr-util"
fi
- # select our MPM
+ # Select the default MPM module
MPM_LIST="event itk peruser prefork worker"
for x in ${MPM_LIST} ; do
if use mpm-${x} ; then
if [[ "x${mpm}" == "x" ]] ; then
mpm=${x}
- einfo "Selected MPM: ${mpm}"
+ elog
+ elog "Selected MPM: ${mpm}"
+ elog
else
eerror "You have selected more then one mpm USE-flag."
eerror "Only one MPM is supported."
@@ -67,10 +69,14 @@ pkg_setup() {
if [[ "x${mpm}" == "x" ]] ; then
if use threads ; then
mpm=worker
- einfo "Selected default threaded MPM: ${mpm}";
+ elog
+ elog "Selected default threaded MPM: ${mpm}";
+ elog
else
mpm=prefork
- einfo "Selected default MPM: ${mpm}";
+ elog
+ elog "Selected default MPM: ${mpm}";
+ elog
fi
fi
@@ -125,7 +131,8 @@ src_unpack() {
fi
# setup the filesystem layout config
- cat "${GENTOO_PATCHDIR}"/patches/config.layout >> "${S}"/config.layout
+ cat "${GENTOO_PATCHDIR}"/patches/config.layout >> "${S}"/config.layout || \
+ die "Failed preparing config.layout!"
sed -i -e "s:version:${PF}:g" "${S}"/config.layout
# patched-in MPMs need the build environment rebuilt
@@ -134,7 +141,7 @@ src_unpack() {
}
src_compile() {
- local modtype="shared" myconf=""
+ local modtype="shared" myconf="" mods=""
cd "${S}"
# Instead of filtering --as-needed (bug #128505), append --no-as-needed
@@ -154,14 +161,6 @@ src_compile() {
myconf="${myconf} --with-ssl=/usr --enable-ssl=${modtype}"
fi
- # Fix for bug #24215 - robbat2@gentoo.org, 30 Oct 2003
- # We pre-load the cache with the correct answer! This avoids
- # it violating the sandbox. This may have to be changed for
- # non-Linux systems or if sem_open changes on Linux. This
- # hack is built around documentation in /usr/include/semaphore.h
- # and the glibc (pthread) source.
- echo 'ac_cv_func_sem_open=${ac_cv_func_sem_open=no}' >> config.cache
-
# Only build suexec with USE=-no-suexec
if use no-suexec ; then
myconf="${myconf} --disable-suexec"
@@ -188,7 +187,6 @@ src_compile() {
--datadir=/var/www/localhost \
--sysconfdir=/etc/apache2 \
--localstatedir=/var \
- --cache-file="${S}/config.cache" \
--with-mpm=${mpm} \
--with-perl=/usr/bin/perl \
--with-expat=/usr \
@@ -344,8 +342,32 @@ pkg_postinst() {
chown -R apache:0 "${ROOT}"/var/www/localhost
fi
- # Check for dual/upgrade install
+ # Previous installations of apache-2.2 installed the upstream configuration
+ # files, which shouldn't even have been installed!
+ if has_version '>=net-www/apache-2.2.4' ; then
+ [ -f "${ROOT}"/etc/apache2/apache2.conf ] && \
+ rm -f "${ROOT}"/etc/apache2/apache2.conf >/dev/null 2>&1
+
+ for i in extra original ; do
+ [ -d "${ROOT}"/etc/apache2/$i ] && \
+ rm -rf "${ROOT}"/etc/apache2/$i >/dev/null 2>&1
+ done
+ fi
+ # Note the user of the config changes
+ if has_version '<net-www/apache-2.2.4-r5' ; then
+ elog
+ elog "Please make sure that you update your /etc directory."
+ elog "Between the versions, we had to changes some config files"
+ elog "and move some stuff out of the main httpd.conf file to a seperate"
+ elog "modules.d entry."
+ elog
+ elog "Thus please update your /etc directory either via etc-update,"
+ elog "dispatch-conf or conf-update !"
+ elog
+ fi
+
+ # Check for dual/upgrade install
if has_version '<net-www/apache-2.2.0' ; then
elog
elog "When upgrading from versions below 2.2.0 to this version, you"
diff --git a/net-www/apache/files/digest-apache-2.2.4-r4 b/net-www/apache/files/digest-apache-2.2.4-r4
deleted file mode 100644
index fc9f722cc47c..000000000000
--- a/net-www/apache/files/digest-apache-2.2.4-r4
+++ /dev/null
@@ -1,6 +0,0 @@
-MD5 bb30deabe843052f7a354c5ce38f8aa9 gentoo-apache-2.2.4-r4-20070527.tar.bz2 57489
-RMD160 e20aaee9c0fe243bcb801ae96bd9166b1742a774 gentoo-apache-2.2.4-r4-20070527.tar.bz2 57489
-SHA256 06d72c37d6fe73db0f82c4734bcce3a23c1acfdc4c600225588acfe70bbbda4b gentoo-apache-2.2.4-r4-20070527.tar.bz2 57489
-MD5 536c86c7041515a25dd8bad3611da9a3 httpd-2.2.4.tar.bz2 4930375
-RMD160 bb6e8a7447fa8e8f629010f30b548068de518523 httpd-2.2.4.tar.bz2 4930375
-SHA256 08ab82eae6418e265d361730e7eadc7d6966dffdb66ee07bd4d9af3f2b28dfc8 httpd-2.2.4.tar.bz2 4930375
diff --git a/net-www/apache/files/digest-apache-2.2.4-r5 b/net-www/apache/files/digest-apache-2.2.4-r5
new file mode 100644
index 000000000000..9f9a3b4d896b
--- /dev/null
+++ b/net-www/apache/files/digest-apache-2.2.4-r5
@@ -0,0 +1,6 @@
+MD5 b1df5f894ba9b0c8ce2235160037d68e gentoo-apache-2.2.4-r5-20070605.tar.bz2 57317
+RMD160 d5ef8bddc1a470d0a5ef41b1d7d3423054c90626 gentoo-apache-2.2.4-r5-20070605.tar.bz2 57317
+SHA256 507327d1a0029b7583c842b5f9d15a2be54226befe4fe1c32969d267de138363 gentoo-apache-2.2.4-r5-20070605.tar.bz2 57317
+MD5 536c86c7041515a25dd8bad3611da9a3 httpd-2.2.4.tar.bz2 4930375
+RMD160 bb6e8a7447fa8e8f629010f30b548068de518523 httpd-2.2.4.tar.bz2 4930375
+SHA256 08ab82eae6418e265d361730e7eadc7d6966dffdb66ee07bd4d9af3f2b28dfc8 httpd-2.2.4.tar.bz2 4930375