summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChuck Short <zul@gentoo.org>2004-04-17 16:12:37 +0000
committerChuck Short <zul@gentoo.org>2004-04-17 16:12:37 +0000
commitd0f12c88270b361d55143912c5822d03992b7172 (patch)
tree70fcee821b0d4bfa79d226b40f0396e95b5e7eef /net-www
parenteutils, S=, and IUSE. (Manifest recommit) (diff)
downloadgentoo-2-d0f12c88270b361d55143912c5822d03992b7172.tar.gz
gentoo-2-d0f12c88270b361d55143912c5822d03992b7172.tar.bz2
gentoo-2-d0f12c88270b361d55143912c5822d03992b7172.zip
Reverted back to intall syntax.
Diffstat (limited to 'net-www')
-rw-r--r--net-www/apache/ChangeLog5
-rw-r--r--net-www/apache/apache-2.0.49-r1.ebuild12
2 files changed, 10 insertions, 7 deletions
diff --git a/net-www/apache/ChangeLog b/net-www/apache/ChangeLog
index d1c14c6002cd..4d4783816d7d 100644
--- a/net-www/apache/ChangeLog
+++ b/net-www/apache/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-www/apache
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/ChangeLog,v 1.126 2004/04/16 11:24:39 zul Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/ChangeLog,v 1.127 2004/04/17 16:12:37 zul Exp $
+
+ 17 Apr 2004; Chuck Short <zul@gentoo.org> apache-2.0.49-r1.ebuild:
+ Reverted back to install syntax for /var/log/apache2. Closes #48063.
16 Apr 2004; Chuck Short <zul@gentoo.org> files/2.0.49/commonapache2.conf:
Fixed typo, closes #46028.
diff --git a/net-www/apache/apache-2.0.49-r1.ebuild b/net-www/apache/apache-2.0.49-r1.ebuild
index e3bd83ff9e84..67254c8a9c0c 100644
--- a/net-www/apache/apache-2.0.49-r1.ebuild
+++ b/net-www/apache/apache-2.0.49-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.49-r1.ebuild,v 1.2 2004/04/15 18:54:48 zul Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.49-r1.ebuild,v 1.3 2004/04/17 16:12:37 zul Exp $
inherit flag-o-matic eutils fixheadtails
@@ -332,13 +332,13 @@ pkg_postinst() {
set_filter_flags
#empty dirs...
- keepdir ${ROOT}/var/lib/dav ; fowners root:apache /var/lib/dav ; fperms 0755 /var/lib/dav
- keepdir ${ROOT}/var/lib/apache2 ; fowners root:root /var/log/apache2 ; fperms 0755 /var/log/apache2
- keepdir ${ROOT}/var/cache/apache2 ; fowners root:root /var/cache/apache2 ; fperms 0755 /var/cache/apache2
-
+ install -d -m0755 -o apache -g apache ${ROOT}/var/lib/dav
+ install -d -m0755 -o root -g root ${ROOT}/var/log/apache2
+ install -d -m0755 -o root -g root ${ROOT}/var/cache/apache2
+
if use ssl; then
# install -d -m0755 -o root -g root ${ROOT}/etc/apache2/conf/ssl
- keepdir ${ROOT}/etc/apache2/conf/ssl ; fowners root:root ${ROOT}/etc/apache2/conf/ssl ; fperms 0755 ${ROOT}/etc/apache2/conf/ssll
+ install -d -m0755 -o root -g root ${ROOT}/etc/apache2/conf/ssl
cd ${ROOT}/etc/apache2/conf/ssl
einfo
einfo "Generating self-signed test certificate in /etc/apache2/conf/ssl..."