summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2008-07-21 20:39:06 +0000
committerAlfredo Tupone <tupone@gentoo.org>2008-07-21 20:39:06 +0000
commit592342c1ccf745fd152fc801036b6914d43e8d47 (patch)
treef6330b1fbe289db66f4e900c57b5c7239fcad78e /net-zope
parentVersion bump (diff)
downloadgentoo-2-592342c1ccf745fd152fc801036b6914d43e8d47.tar.gz
gentoo-2-592342c1ccf745fd152fc801036b6914d43e8d47.tar.bz2
gentoo-2-592342c1ccf745fd152fc801036b6914d43e8d47.zip
Make it work with zope >= 2.9.8 . Bug #224529
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-zope')
-rw-r--r--net-zope/tinytableplus/ChangeLog8
-rw-r--r--net-zope/tinytableplus/files/tinytableplus-0.9-zope-2.9.8.patch11
-rw-r--r--net-zope/tinytableplus/tinytableplus-0.9-r1.ebuild12
3 files changed, 26 insertions, 5 deletions
diff --git a/net-zope/tinytableplus/ChangeLog b/net-zope/tinytableplus/ChangeLog
index 56aeed682b98..eaac47a521cd 100644
--- a/net-zope/tinytableplus/ChangeLog
+++ b/net-zope/tinytableplus/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-zope/tinytableplus
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/tinytableplus/ChangeLog,v 1.5 2007/02/05 20:42:13 flameeyes Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/tinytableplus/ChangeLog,v 1.6 2008/07/21 20:39:05 tupone Exp $
+
+ 21 Jul 2008; Tupone Alfredo <tupone@gentoo.org>
+ +files/tinytableplus-0.9-zope-2.9.8.patch, tinytableplus-0.9-r1.ebuild:
+ Make it work with zope >= 2.9.8 . Bug #224529 by <nerdboy@gentoo.org>
05 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/net-zope/tinytableplus/files/tinytableplus-0.9-zope-2.9.8.patch b/net-zope/tinytableplus/files/tinytableplus-0.9-zope-2.9.8.patch
new file mode 100644
index 000000000000..9ef777b5e21e
--- /dev/null
+++ b/net-zope/tinytableplus/files/tinytableplus-0.9-zope-2.9.8.patch
@@ -0,0 +1,11 @@
+--- TinyTablePlus/TinyTablePlus.py.old 2008-07-21 22:18:47.000000000 +0200
++++ TinyTablePlus/TinyTablePlus.py 2008-07-21 22:19:39.000000000 +0200
+@@ -39,7 +39,7 @@
+
+ from Globals import HTMLFile, MessageDialog, Persistent
+ from Shared.DC.ZRDB.Results import Results
+-from PersistentMapping import PersistentMapping
++from persistent.mapping import PersistentMapping
+ from DateTime import DateTime
+ from App.Extensions import getBrain
+ import OFS.ObjectManager, OFS.SimpleItem, Acquisition, AccessControl.Role
diff --git a/net-zope/tinytableplus/tinytableplus-0.9-r1.ebuild b/net-zope/tinytableplus/tinytableplus-0.9-r1.ebuild
index 877f2ae30437..2c7bb1cc0177 100644
--- a/net-zope/tinytableplus/tinytableplus-0.9-r1.ebuild
+++ b/net-zope/tinytableplus/tinytableplus-0.9-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/tinytableplus/tinytableplus-0.9-r1.ebuild,v 1.2 2006/01/27 02:47:46 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/tinytableplus/tinytableplus-0.9-r1.ebuild,v 1.3 2008/07/21 20:39:05 tupone Exp $
-inherit zproduct
+inherit eutils zproduct
NEW_PV="${PV//./-}"
DESCRIPTION="TinyTable (a product designed to manage a small amount of tabular dat) with update capability"
@@ -15,3 +15,9 @@ KEYWORDS="~sparc x86"
S=${WORKDIR}/lib/python/Products
ZPROD_LIST="TinyTablePlus"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-zope-2.9.8.patch
+}