summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Kuleshov <svyatogor@gentoo.org>2005-10-08 18:22:01 +0000
committerSergey Kuleshov <svyatogor@gentoo.org>2005-10-08 18:22:01 +0000
commit96c8f576a038c4c71188f17dbf4702a5e4e0a1b8 (patch)
tree2d6a0275f67478a6a8c8162f3b685344e7d2f770 /rox-extra
parentnagios-core-1.2-r2 and -r3 were already obsolete (diff)
downloadgentoo-2-96c8f576a038c4c71188f17dbf4702a5e4e0a1b8.tar.gz
gentoo-2-96c8f576a038c4c71188f17dbf4702a5e4e0a1b8.tar.bz2
gentoo-2-96c8f576a038c4c71188f17dbf4702a5e4e0a1b8.zip
new application for rox.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'rox-extra')
-rw-r--r--rox-extra/diff/ChangeLog11
-rw-r--r--rox-extra/diff/Manifest3
-rw-r--r--rox-extra/diff/diff-2.1.2.ebuild29
-rw-r--r--rox-extra/diff/files/diff-2.1.2_unified-fix.patch11
-rw-r--r--rox-extra/diff/files/digest-diff-2.1.21
-rw-r--r--rox-extra/diff/metadata.xml9
6 files changed, 64 insertions, 0 deletions
diff --git a/rox-extra/diff/ChangeLog b/rox-extra/diff/ChangeLog
new file mode 100644
index 000000000000..fe2257a5670b
--- /dev/null
+++ b/rox-extra/diff/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for rox-extra/diff
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/rox-extra/diff/ChangeLog,v 1.1 2005/10/08 18:22:01 svyatogor Exp $
+
+*diff-2.1.2 (08 Oct 2005)
+
+ 08 Oct 2005; Sergey Kuleshov <svyatogor@gentoo.org>
+ +files/diff-2.1.2_unified-fix.patch, +diff-2.1.2.ebuild:
+ New application - create diffs in ROX easily. Suggested by Peter Hyman.
+ Bug #107276
+
diff --git a/rox-extra/diff/Manifest b/rox-extra/diff/Manifest
new file mode 100644
index 000000000000..8b69c966451c
--- /dev/null
+++ b/rox-extra/diff/Manifest
@@ -0,0 +1,3 @@
+MD5 a5eae5ddad88513133b38ae63b7cab6f diff-2.1.2.ebuild 752
+MD5 571cef12b851be55f47b77c699dbe08f files/digest-diff-2.1.2 61
+MD5 53b0aa09c45f6f9ab96a386317a0df08 files/diff-2.1.2_unified-fix.patch 387
diff --git a/rox-extra/diff/diff-2.1.2.ebuild b/rox-extra/diff/diff-2.1.2.ebuild
new file mode 100644
index 000000000000..979053bbe03b
--- /dev/null
+++ b/rox-extra/diff/diff-2.1.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/rox-extra/diff/diff-2.1.2.ebuild,v 1.1 2005/10/08 18:22:01 svyatogor Exp $
+
+inherit eutils rox
+
+MY_PN="Diff"
+PATCH_FN="diff-2.1.2_unified-fix.patch"
+DESCRIPTION="This is a helper program for ROX-Filer. It provides images for video files. By Stephen Watson"
+HOMEPAGE="http://www.kerofin.demon.co.uk/rox/diff.html"
+SRC_URI="http://www.kerofin.demon.co.uk/rox/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~x86"
+
+ROX_CLIB=2.1.0
+SET_PERM=true
+
+APPNAME=${MY_PN}
+S=${WORKDIR}
+
+# patch to make unified diffs work. Thanks to Stephen Watson, author
+src_unpack() {
+ unpack ${A}
+ cd ${S}/${APPNAME}/src
+ epatch ${FILESDIR}/${PATCH_FN}
+}
diff --git a/rox-extra/diff/files/diff-2.1.2_unified-fix.patch b/rox-extra/diff/files/diff-2.1.2_unified-fix.patch
new file mode 100644
index 000000000000..c03def17c1c5
--- /dev/null
+++ b/rox-extra/diff/files/diff-2.1.2_unified-fix.patch
@@ -0,0 +1,11 @@
+--- /var/tmp/portage/rox-diff-2.1.2/work/Diff/src/main.c 2004-11-21 08:11:28.000000000 -0500
++++ main.c 2005-10-05 14:04:59.000000000 -0400
+@@ -775,7 +775,7 @@
+ GtkTextIter start, end;
+ GtkTextBuffer *buf;
+
+- win->unified=options.use_unified;
++ win->unified=o_use_unified.int_value;
+
+ win->fname[0]=g_strdup(tmpnam(NULL));
+ write_window_to(win->file[0], win->fname[0], win);
diff --git a/rox-extra/diff/files/digest-diff-2.1.2 b/rox-extra/diff/files/digest-diff-2.1.2
new file mode 100644
index 000000000000..a662dc115e61
--- /dev/null
+++ b/rox-extra/diff/files/digest-diff-2.1.2
@@ -0,0 +1 @@
+MD5 7e6ef13d2bbed331c935120ada6f2d36 Diff-2.1.2.tar.gz 53662
diff --git a/rox-extra/diff/metadata.xml b/rox-extra/diff/metadata.xml
new file mode 100644
index 000000000000..9ba1c41f8b2e
--- /dev/null
+++ b/rox-extra/diff/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>svyatogor@gentoo.org</email>
+ <name>Sergey Kuleshov</name>
+</maintainer>
+</pkgmetadata>