summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-05-22 07:30:37 +0000
committerJustin Lecher <jlec@gentoo.org>2010-05-22 07:30:37 +0000
commit09a422f66d41385853f5d2f8d836568a816b6704 (patch)
tree6d1d81afaa8186817057284d3e49a368d0619741 /sci-astronomy/wcslib/wcslib-4.4.4-r1.ebuild
parentrevert old version (diff)
downloadgentoo-2-09a422f66d41385853f5d2f8d836568a816b6704.tar.gz
gentoo-2-09a422f66d41385853f5d2f8d836568a816b6704.tar.bz2
gentoo-2-09a422f66d41385853f5d2f8d836568a816b6704.zip
sci-astronomy/wcslib - LDFLAGS respected
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy/wcslib/wcslib-4.4.4-r1.ebuild')
-rw-r--r--sci-astronomy/wcslib/wcslib-4.4.4-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sci-astronomy/wcslib/wcslib-4.4.4-r1.ebuild b/sci-astronomy/wcslib/wcslib-4.4.4-r1.ebuild
new file mode 100644
index 000000000000..f2a4110b3cd3
--- /dev/null
+++ b/sci-astronomy/wcslib/wcslib-4.4.4-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcslib/wcslib-4.4.4-r1.ebuild,v 1.1 2010/05/22 07:30:37 jlec Exp $
+
+EAPI=2
+inherit eutils virtualx flag-o-matic
+
+DESCRIPTION="Astronomical World Coordinate System transformations library"
+HOMEPAGE="http://www.atnf.csiro.au/people/mcalabre/WCS/"
+SRC_URI="ftp://ftp.atnf.csiro.au/pub/software/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ sci-libs/cfitsio
+ sci-libs/pgplot"
+DEPEND="${RDEPEND}
+ test? (
+ media-fonts/font-misc-misc
+ media-fonts/font-cursor-misc
+ )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-4.4.2-flibs.patch
+ epatch "${FILESDIR}"/${PN}-4.4.4-destdir.patch
+ epatch "${FILESDIR}"/${PN}-4.4.4-ldflags.patch
+ append-flags -U_FORTIFY_SOURCE
+}
+
+src_compile() {
+ # -j1 forced. build system too crappy to be worth debugging
+ # does not really fix anything
+ emake -j1 || die "emake failed"
+}
+
+src_test() {
+ Xemake check || die "emake test failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README || die
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins -r *.pdf html || die
+ fi
+}