summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-06-07 23:32:10 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-06-07 23:32:10 +0000
commit4390c6136a0c7f56223a229934eb668eb352af05 (patch)
tree1e87409a546e3bc0422e1e221eb09bbdccd34c9c /sci-astronomy
parentRemoval of sci-visualization/udav (diff)
downloadgentoo-2-4390c6136a0c7f56223a229934eb668eb352af05.tar.gz
gentoo-2-4390c6136a0c7f56223a229934eb668eb352af05.tar.bz2
gentoo-2-4390c6136a0c7f56223a229934eb668eb352af05.zip
Version bump
(Portage version: 2.2.01.21938-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/cpl/ChangeLog9
-rw-r--r--sci-astronomy/cpl/cpl-6.3.1.ebuild74
2 files changed, 81 insertions, 2 deletions
diff --git a/sci-astronomy/cpl/ChangeLog b/sci-astronomy/cpl/ChangeLog
index 4c0c5d177b9d..31d37ed2fb40 100644
--- a/sci-astronomy/cpl/ChangeLog
+++ b/sci-astronomy/cpl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-astronomy/cpl
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/cpl/ChangeLog,v 1.12 2012/12/05 17:22:29 bicatali Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/cpl/ChangeLog,v 1.13 2013/06/07 23:32:10 bicatali Exp $
+
+*cpl-6.3.1 (07 Jun 2013)
+
+ 07 Jun 2013; Sébastien Fabbro <bicatali@gentoo.org> +cpl-6.3.1.ebuild:
+ Version bump
*cpl-6.2 (05 Dec 2012)
diff --git a/sci-astronomy/cpl/cpl-6.3.1.ebuild b/sci-astronomy/cpl/cpl-6.3.1.ebuild
new file mode 100644
index 000000000000..350617ac5936
--- /dev/null
+++ b/sci-astronomy/cpl/cpl-6.3.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/cpl/cpl-6.3.1.ebuild,v 1.1 2013/06/07 23:32:10 bicatali Exp $
+
+EAPI=5
+
+JAVA_PKG_OPT_USE=gasgano
+AUTOTOOLS_AUTORECONF=1
+
+inherit eutils java-pkg-opt-2 autotools-utils
+
+DESCRIPTION="ESO common pipeline library for astronomical data reduction"
+HOMEPAGE="http://www.eso.org/sci/software/cpl/"
+SRC_URI="ftp://ftp.eso.org/pub/dfs/pipelines/libraries/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="doc gasgano static-libs threads"
+
+RDEPEND="
+ >=sci-astronomy/wcslib-4.8.4
+ >=sci-libs/cfitsio-3.310
+ >=sci-libs/fftw-3.1.2
+ gasgano? ( sci-astronomy/gasgano )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.1.1-check-shared-libs.patch
+ "${FILESDIR}"/${PN}-6.1.1-use-system-ltdl.patch
+)
+
+src_prepare() {
+ # bug 422455 and remove cpu chcking
+ sed -i \
+ -e '/AM_C_PROTOTYPES/d' \
+ -e '/CPL_CHECK_CPU/d' \
+ configure.ac libcext/configure.ac || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+ --disable-ltdl-install
+ --without-included-ltdl
+ --with-cfitsio="${EPREFIX}/usr"
+ --with-wcs="${EPREFIX}/usr"
+ --with-fftw="${EPREFIX}/usr"
+ $(use_enable doc maintainer-mode)
+ $(use_enable threads)
+ )
+ if use gasgano; then
+ myeconfargs+=(
+ --enable-gasgano
+ --with-gasgano="${EPREFIX}/usr"
+ --with-gasgano-classpath="${EPREFIX}/usr/share/gasgano/lib"
+ --with-java="$(java-config -O)"
+ )
+ else
+ myeconfargs+=( --disable-gasgano )
+ fi
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile all $(use doc && echo html)
+}
+
+src_install() {
+ autotools-utils_src_install all $(use doc && echo install-html)
+}