summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-01-18 03:42:06 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-01-18 03:42:06 +0000
commit57fcc19ff37c0c9d9951d45db4a9a051ecb04097 (patch)
tree0cd8a98574a1c1892563dd2d1c7ccfa2263fe67f /sci-astronomy
parentKeyworded ~amd64. (diff)
downloadgentoo-2-57fcc19ff37c0c9d9951d45db4a9a051ecb04097.tar.gz
gentoo-2-57fcc19ff37c0c9d9951d45db4a9a051ecb04097.tar.bz2
gentoo-2-57fcc19ff37c0c9d9951d45db4a9a051ecb04097.zip
Initial import (fixes bug #67489). Many thanks to Tim Cera <timcera@earthlink.net> for his ebuild.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/pyephem/ChangeLog11
-rw-r--r--sci-astronomy/pyephem/Manifest4
-rw-r--r--sci-astronomy/pyephem/files/digest-pyephem-3.7b1
-rw-r--r--sci-astronomy/pyephem/metadata.xml5
-rw-r--r--sci-astronomy/pyephem/pyephem-3.7b.ebuild26
5 files changed, 47 insertions, 0 deletions
diff --git a/sci-astronomy/pyephem/ChangeLog b/sci-astronomy/pyephem/ChangeLog
new file mode 100644
index 000000000000..904b123bbdd1
--- /dev/null
+++ b/sci-astronomy/pyephem/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-astronomy/pyephem
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/pyephem/ChangeLog,v 1.1 2006/01/18 03:42:06 markusle Exp $
+
+*pyephem-3.7b (18 Jan 2006)
+
+ 18 Jan 2006; Markus Dittrich <markusle@gentoo.org> +metadata.xml,
+ +pyephem-3.7b.ebuild:
+ Initial import (fixes bug #67489). Many thanks to Tim Cera
+ <timcera@earthlink.net> for his ebuild.
+
diff --git a/sci-astronomy/pyephem/Manifest b/sci-astronomy/pyephem/Manifest
new file mode 100644
index 000000000000..985c7a8fd2f4
--- /dev/null
+++ b/sci-astronomy/pyephem/Manifest
@@ -0,0 +1,4 @@
+MD5 ee0f0acf27628f40cb2a35fe877e852d ChangeLog 348
+MD5 b294ea62bc5486f7aaa97a29867dd1fc files/digest-pyephem-3.7b 64
+MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
+MD5 1fc3de8c175dfe047b54f7470163d4a8 pyephem-3.7b.ebuild 671
diff --git a/sci-astronomy/pyephem/files/digest-pyephem-3.7b b/sci-astronomy/pyephem/files/digest-pyephem-3.7b
new file mode 100644
index 000000000000..939c0be6615c
--- /dev/null
+++ b/sci-astronomy/pyephem/files/digest-pyephem-3.7b
@@ -0,0 +1 @@
+MD5 08ddcadfef79b6020d593b7665b4c3fa pyephem-3.7b.tar.gz 299901
diff --git a/sci-astronomy/pyephem/metadata.xml b/sci-astronomy/pyephem/metadata.xml
new file mode 100644
index 000000000000..b229aec85b8f
--- /dev/null
+++ b/sci-astronomy/pyephem/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+</pkgmetadata>
diff --git a/sci-astronomy/pyephem/pyephem-3.7b.ebuild b/sci-astronomy/pyephem/pyephem-3.7b.ebuild
new file mode 100644
index 000000000000..455cfff0a61f
--- /dev/null
+++ b/sci-astronomy/pyephem/pyephem-3.7b.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/pyephem/pyephem-3.7b.ebuild,v 1.1 2006/01/18 03:42:06 markusle Exp $
+
+inherit distutils
+
+DESCRIPTION="PyEphem provides scientific-grade astronomical computations for the python programming language."
+LICENSE="GPL-2"
+HOMEPAGE="http://www.rhodesmill.org/brandon/projects/pyephem.html"
+SRC_URI="http://www.rhodesmill.org/brandon/projects/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="virtual/python"
+
+src_install() {
+ distutils_src_install
+
+ # install docs and examples
+ dohtml doc/* || die "Failed to install html docs"
+
+ insinto /usr/share/${PN}/examples
+ doins examples/* || die "Failed to install examples"
+}