summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-07-25 22:53:22 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-07-25 22:53:22 +0000
commitf926f4cfaa1ae003281e1c1124e9237474397a90 (patch)
tree2a8538e3f45e9df8311fcbb471c9ad65b38130bd /sci-astronomy
parentInitial commit to tree (diff)
downloadgentoo-2-f926f4cfaa1ae003281e1c1124e9237474397a90.tar.gz
gentoo-2-f926f4cfaa1ae003281e1c1124e9237474397a90.tar.bz2
gentoo-2-f926f4cfaa1ae003281e1c1124e9237474397a90.zip
Version bump
(Portage version: 2.1.10.7/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/skycat/ChangeLog9
-rw-r--r--sci-astronomy/skycat/skycat-3.1.2.ebuild55
2 files changed, 62 insertions, 2 deletions
diff --git a/sci-astronomy/skycat/ChangeLog b/sci-astronomy/skycat/ChangeLog
index b8e34a49430b..32ff7c1cb1eb 100644
--- a/sci-astronomy/skycat/ChangeLog
+++ b/sci-astronomy/skycat/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-astronomy/skycat
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/skycat/ChangeLog,v 1.7 2010/09/24 18:13:38 bicatali Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/skycat/ChangeLog,v 1.8 2011/07/25 22:53:22 bicatali Exp $
+
+*skycat-3.1.2 (25 Jul 2011)
+
+ 25 Jul 2011; Sébastien Fabbro <bicatali@gentoo.org> +skycat-3.1.2.ebuild:
+ Version bump
*skycat-3.1.1 (24 Sep 2010)
diff --git a/sci-astronomy/skycat/skycat-3.1.2.ebuild b/sci-astronomy/skycat/skycat-3.1.2.ebuild
new file mode 100644
index 000000000000..846df77f493b
--- /dev/null
+++ b/sci-astronomy/skycat/skycat-3.1.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/skycat/skycat-3.1.2.ebuild,v 1.1 2011/07/25 22:53:22 bicatali Exp $
+
+EAPI=4
+inherit eutils autotools
+
+DESCRIPTION="ESO astronomical image visualizer with catalog access."
+HOMEPAGE="http://archive.eso.org/skycat"
+SRC_URI="http://archive.eso.org/cms/tools-documentation/skycat-download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="threads"
+
+DEPEND="x11-libs/libXext
+ >=dev-tcltk/tclx-2.4
+ >=dev-tcltk/blt-2.4
+ >=dev-tcltk/itcl-3.3
+ >=dev-tcltk/iwidgets-4.0.1
+ >=dev-tcltk/tkimg-1.3
+ sci-libs/cfitsio
+ sci-astronomy/wcstools"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # fix buggy tcl.m4 for bash3
+ epatch "${FILESDIR}"/${PN}-3.0.1-m4.patch
+ # need fix for tk-8.5
+ if has_version ">=dev-lang/tk-8.5" ; then
+ epatch "${FILESDIR}"/${PN}-3.0.2-tk8.5.patch
+ fi
+ epatch "${FILESDIR}"/${PN}-3.0.2-makefile-qa.patch
+ # use system libs
+ epatch "${FILESDIR}"/${PN}-3.0.2-systemlibs.patch
+ rm -fr astrotcl/{cfitsio,libwcs} \
+ || die "Failed to remove included libs"
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable threads) --enable-merge
+}
+
+src_install() {
+ default
+ local d
+ for d in tclutil astrotcl rtd cat skycat; do
+ for f in README CHANGES VERSION; do
+ newdoc ${f} ${f}.${d}
+ done
+ done
+}