summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-04-28 15:01:05 +0000
committerJustin Lecher <jlec@gentoo.org>2011-04-28 15:01:05 +0000
commit75fbde332ef5216ccac2d3097417692047117690 (patch)
treedf21a28b663ea9fd4dee09fd934eee10ac4f6b8a /sci-biology/abyss/abyss-1.2.7.ebuild
parentversion bump (diff)
downloadgentoo-2-75fbde332ef5216ccac2d3097417692047117690.tar.gz
gentoo-2-75fbde332ef5216ccac2d3097417692047117690.tar.bz2
gentoo-2-75fbde332ef5216ccac2d3097417692047117690.zip
Added openmp USE
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/abyss/abyss-1.2.7.ebuild')
-rw-r--r--sci-biology/abyss/abyss-1.2.7.ebuild22
1 files changed, 13 insertions, 9 deletions
diff --git a/sci-biology/abyss/abyss-1.2.7.ebuild b/sci-biology/abyss/abyss-1.2.7.ebuild
index 95f18eb1550b..2bfafaaab3a9 100644
--- a/sci-biology/abyss/abyss-1.2.7.ebuild
+++ b/sci-biology/abyss/abyss-1.2.7.ebuild
@@ -1,26 +1,25 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/abyss/abyss-1.2.7.ebuild,v 1.1 2011/04/28 14:04:23 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/abyss/abyss-1.2.7.ebuild,v 1.2 2011/04/28 15:01:05 jlec Exp $
-EAPI="2"
+EAPI="4"
-inherit autotools base
+inherit autotools
DESCRIPTION="Assembly By Short Sequences - a de novo, parallel, paired-end sequence assembler"
-HOMEPAGE="http://www.bcgsc.ca/platform/bioinfo/software/abyss"
+HOMEPAGE="http://www.bcgsc.ca/platform/bioinfo/software/abyss/"
SRC_URI="http://www.bcgsc.ca/downloads/abyss/${P}.tar.gz"
LICENSE="abyss"
SLOT="0"
-IUSE="+mpi"
-KEYWORDS="~amd64 ~x86"
+IUSE="+mpi openmp"
+KEYWORDS="amd64 x86"
-DEPEND="dev-cpp/sparsehash
+DEPEND="
+ dev-cpp/sparsehash
mpi? ( virtual/mpi )"
RDEPEND="${DEPEND}"
-DOCS=( ChangeLog README )
-
# todo: --enable-maxk=N configure option
# todo: fix automagic mpi toggling
@@ -29,3 +28,8 @@ src_prepare() {
sed -i -e "/dist_pkgdoc_DATA/d" Makefile.am || die
eautoreconf
}
+
+src_configure() {
+ econf \
+ $(use_enable openmp)
+}