summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2012-05-29 02:44:21 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2012-05-29 02:44:21 +0000
commit72e2c49cf33ed9222518fef8654459ddbbee8ddb (patch)
treef34be53033bff8a051b0a3e2ab7b8b20aa5a2bf2 /sci-biology/abyss
parentAdd dev-perl/Net-DNS and dev-perl/Getopt-GUI-Long as RDEPEND (bug 418009 and ... (diff)
downloadgentoo-2-72e2c49cf33ed9222518fef8654459ddbbee8ddb.tar.gz
gentoo-2-72e2c49cf33ed9222518fef8654459ddbbee8ddb.tar.bz2
gentoo-2-72e2c49cf33ed9222518fef8654459ddbbee8ddb.zip
version bump
(Portage version: 2.2.0_alpha74/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/abyss')
-rw-r--r--sci-biology/abyss/ChangeLog9
-rw-r--r--sci-biology/abyss/abyss-1.3.3.ebuild35
2 files changed, 42 insertions, 2 deletions
diff --git a/sci-biology/abyss/ChangeLog b/sci-biology/abyss/ChangeLog
index 0f7d4e0f7817..7d16878ef343 100644
--- a/sci-biology/abyss/ChangeLog
+++ b/sci-biology/abyss/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/abyss
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/abyss/ChangeLog,v 1.11 2011/09/24 21:48:12 weaver Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/abyss/ChangeLog,v 1.12 2012/05/29 02:44:21 weaver Exp $
+
+*abyss-1.3.3 (29 May 2012)
+
+ 29 May 2012; Andrey Kislyuk <weaver@gentoo.org> +abyss-1.3.3.ebuild:
+ version bump
*abyss-1.3.0 (24 Sep 2011)
diff --git a/sci-biology/abyss/abyss-1.3.3.ebuild b/sci-biology/abyss/abyss-1.3.3.ebuild
new file mode 100644
index 000000000000..edc248a34395
--- /dev/null
+++ b/sci-biology/abyss/abyss-1.3.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/abyss/abyss-1.3.3.ebuild,v 1.1 2012/05/29 02:44:21 weaver Exp $
+
+EAPI="4"
+
+inherit autotools
+
+DESCRIPTION="Assembly By Short Sequences - a de novo, parallel, paired-end sequence assembler"
+HOMEPAGE="http://www.bcgsc.ca/platform/bioinfo/software/abyss/"
+SRC_URI="http://www.bcgsc.ca/downloads/abyss/${P}.tar.gz"
+
+LICENSE="abyss"
+SLOT="0"
+IUSE="+mpi openmp"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-cpp/sparsehash
+ mpi? ( virtual/mpi )"
+RDEPEND="${DEPEND}"
+
+# todo: --enable-maxk=N configure option
+# todo: fix automagic mpi toggling
+
+src_prepare() {
+ sed -i -e "s/-Werror//" configure.ac || die #365195
+ sed -i -e "/dist_pkgdoc_DATA/d" Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable openmp)
+}