summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-04-25 11:00:59 +0000
committerJustin Lecher <jlec@gentoo.org>2011-04-25 11:00:59 +0000
commitb2ae998488f3b3f2bc6f1a12013b619b8575d001 (patch)
tree1f7e3c657a878283113f0ccd77996a5939aa21d1 /sci-biology/last
parentold (diff)
downloadgentoo-2-b2ae998488f3b3f2bc6f1a12013b619b8575d001.tar.gz
gentoo-2-b2ae998488f3b3f2bc6f1a12013b619b8575d001.tar.bz2
gentoo-2-b2ae998488f3b3f2bc6f1a12013b619b8575d001.zip
Fix for gcc-4.6, #3624783
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/last')
-rw-r--r--sci-biology/last/ChangeLog6
-rw-r--r--sci-biology/last/files/162-gcc46.patch15
-rw-r--r--sci-biology/last/last-162-r1.ebuild6
-rw-r--r--sci-biology/last/last-162.ebuild6
4 files changed, 29 insertions, 4 deletions
diff --git a/sci-biology/last/ChangeLog b/sci-biology/last/ChangeLog
index 07e62371a151..409df24ba839 100644
--- a/sci-biology/last/ChangeLog
+++ b/sci-biology/last/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-biology/last
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/last/ChangeLog,v 1.13 2011/04/08 06:29:27 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/last/ChangeLog,v 1.14 2011/04/25 11:00:59 jlec Exp $
+
+ 25 Apr 2011; Justin Lecher <jlec@gentoo.org> +files/162-gcc46.patch,
+ last-162.ebuild, last-162-r1.ebuild:
+ Fix for gcc-4.6, #3624783
*last-162-r1 (08 Apr 2011)
diff --git a/sci-biology/last/files/162-gcc46.patch b/sci-biology/last/files/162-gcc46.patch
new file mode 100644
index 000000000000..9c66c6d39f00
--- /dev/null
+++ b/sci-biology/last/files/162-gcc46.patch
@@ -0,0 +1,15 @@
+ src/XdropAligner.hh | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/src/XdropAligner.hh b/src/XdropAligner.hh
+index 9dea32e..3c0e35f 100644
+--- a/src/XdropAligner.hh
++++ b/src/XdropAligner.hh
+@@ -12,6 +12,7 @@
+ #include <vector>
+ #include <cassert>
+ #include <climits> // INT_MAX
++#include <cstddef>
+
+ namespace cbrc{
+
diff --git a/sci-biology/last/last-162-r1.ebuild b/sci-biology/last/last-162-r1.ebuild
index 1f288b98bc26..16849bcca8f8 100644
--- a/sci-biology/last/last-162-r1.ebuild
+++ b/sci-biology/last/last-162-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/last/last-162-r1.ebuild,v 1.1 2011/04/08 06:29:27 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/last/last-162-r1.ebuild,v 1.2 2011/04/25 11:00:59 jlec Exp $
EAPI="2"
@@ -19,7 +19,9 @@ DEPEND="app-arch/unzip"
RDEPEND=""
src_prepare() {
- epatch "${FILESDIR}"/${PV}-ldflags.patch
+ epatch \
+ "${FILESDIR}"/${PV}-ldflags.patch \
+ "${FILESDIR}"/${PV}-gcc46.patch
}
src_compile() {
diff --git a/sci-biology/last/last-162.ebuild b/sci-biology/last/last-162.ebuild
index 24a418b5af01..092a985fb3ac 100644
--- a/sci-biology/last/last-162.ebuild
+++ b/sci-biology/last/last-162.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/last/last-162.ebuild,v 1.1 2011/04/02 18:26:30 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/last/last-162.ebuild,v 1.2 2011/04/25 11:00:59 jlec Exp $
EAPI="2"
@@ -18,6 +18,10 @@ KEYWORDS="~amd64 ~x86"
DEPEND="app-arch/unzip"
RDEPEND=""
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PV}-gcc46.patch
+}
src_compile() {
emake -e -C src CXX="$(tc-getCXX)" \
STRICT="${LDFLAGS}" || die