summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2009-09-04 19:30:55 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2009-09-04 19:30:55 +0000
commit148d0097954e879a71b1ab0f46aafaa549111598 (patch)
tree7245cfd3444f93e377e61848b39ca4df1292b0e4 /sci-biology/raxml/raxml-7.2.2.ebuild
parentVersion bump (but no mpi support in 7.2.2) (diff)
downloadgentoo-2-148d0097954e879a71b1ab0f46aafaa549111598.tar.gz
gentoo-2-148d0097954e879a71b1ab0f46aafaa549111598.tar.bz2
gentoo-2-148d0097954e879a71b1ab0f46aafaa549111598.zip
Tweak build process
(Portage version: 2.2_rc30/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/raxml/raxml-7.2.2.ebuild')
-rw-r--r--sci-biology/raxml/raxml-7.2.2.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/sci-biology/raxml/raxml-7.2.2.ebuild b/sci-biology/raxml/raxml-7.2.2.ebuild
index b112de055eea..0084739e5718 100644
--- a/sci-biology/raxml/raxml-7.2.2.ebuild
+++ b/sci-biology/raxml/raxml-7.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/raxml/raxml-7.2.2.ebuild,v 1.1 2009/09/04 19:12:50 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/raxml/raxml-7.2.2.ebuild,v 1.2 2009/09/04 19:30:55 weaver Exp $
EAPI="2"
@@ -15,7 +15,7 @@ SLOT="0"
IUSE="+threads"
KEYWORDS="~amd64 ~x86"
-# errors compiling mpi for version 7.2.2. mpi is enabled by adding -DPARALLEL to CFLAGS
+# mpi is not supported in version 7.2.2. mpi is enabled by adding -DPARALLEL to CFLAGS
DEPEND="" # mpi? ( virtual/mpi )"
RDEPEND="${DEPEND}"
@@ -28,11 +28,15 @@ src_prepare() {
}
src_compile() {
- emake -f Makefile.SSE3.gcc || die
- if use threads; then emake -f Makefile.SSE3.PTHREADS.gcc clean && emake -f Makefile.SSE3.PTHREADS.gcc || die; fi
+ emake -f Makefile.gcc || die
+ emake -f Makefile.SSE3.gcc clean && emake -f Makefile.SSE3.gcc || die
+ if use threads; then
+ emake -f Makefile.PTHREADS.gcc clean && emake -f Makefile.PTHREADS.gcc || die
+ emake -f Makefile.SSE3.PTHREADS.gcc clean && emake -f Makefile.SSE3.PTHREADS.gcc || die
+ fi
}
src_install() {
- dobin raxmlHPC-SSE3 || die
- if use threads; then dobin raxmlHPC-PTHREADS-SSE3 || die; fi
+ dobin raxmlHPC raxmlHPC-SSE3 || die
+ if use threads; then dobin raxmlHPC-PTHREADS raxmlHPC-PTHREADS-SSE3 || die; fi
}