summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-07-27 18:42:15 +0000
committerJustin Lecher <jlec@gentoo.org>2015-07-27 18:42:15 +0000
commit029e639c320642e7e8f71222d35461b7e65fba0d (patch)
tree0b98f9317731a91df6453f8c73562c2147a1d6a0 /sci-biology
parentConvert to distutils-r1 (diff)
downloadgentoo-2-029e639c320642e7e8f71222d35461b7e65fba0d.tar.gz
gentoo-2-029e639c320642e7e8f71222d35461b7e65fba0d.tar.bz2
gentoo-2-029e639c320642e7e8f71222d35461b7e65fba0d.zip
Use fortran-2.eclass, bug #543204; drop old
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key E9402A79B03529A2!)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/mothur/ChangeLog13
-rw-r--r--sci-biology/mothur/files/mothur-1.13.0-makefile.patch43
-rw-r--r--sci-biology/mothur/files/mothur-1.13.0-overflows.patch82
-rw-r--r--sci-biology/mothur/files/mothur-1.13.0-overflows2.patch77
-rw-r--r--sci-biology/mothur/mothur-1.13.0-r1.ebuild43
-rw-r--r--sci-biology/mothur/mothur-1.13.0-r2.ebuild45
-rw-r--r--sci-biology/mothur/mothur-1.27.0-r1.ebuild (renamed from sci-biology/mothur/mothur-1.27.0.ebuild)18
7 files changed, 17 insertions, 304 deletions
diff --git a/sci-biology/mothur/ChangeLog b/sci-biology/mothur/ChangeLog
index 2b37c7e6e2ec..38517a441a26 100644
--- a/sci-biology/mothur/ChangeLog
+++ b/sci-biology/mothur/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-biology/mothur
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/mothur/ChangeLog,v 1.12 2015/04/07 14:33:37 jlec Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/mothur/ChangeLog,v 1.13 2015/07/27 18:42:15 jlec Exp $
+
+*mothur-1.27.0-r1 (27 Jul 2015)
+
+ 27 Jul 2015; Justin Lecher <jlec@gentoo.org> +mothur-1.27.0-r1.ebuild,
+ -files/mothur-1.13.0-makefile.patch, -files/mothur-1.13.0-overflows.patch,
+ -files/mothur-1.13.0-overflows2.patch, -mothur-1.13.0-r1.ebuild,
+ -mothur-1.13.0-r2.ebuild, -mothur-1.27.0.ebuild:
+ Use fortran-2.eclass, bug #543204; drop old
11 Mar 2013; Justin Lecher <jlec@gentoo.org> metadata.xml:
Drop Andrey as maintainer so that bugs get assigned to sci-biology directly
@@ -61,4 +69,3 @@
04 Mar 2009; Andrey Kislyuk <weaver@gentoo.org> ChangeLog:
New package, ebuild written by me
-
diff --git a/sci-biology/mothur/files/mothur-1.13.0-makefile.patch b/sci-biology/mothur/files/mothur-1.13.0-makefile.patch
deleted file mode 100644
index 6b2f0f1bd201..000000000000
--- a/sci-biology/mothur/files/mothur-1.13.0-makefile.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-Fix build with --as-needed, respect CXX, CXXFLAGS
-
-http://www.mothur.org/forum/viewtopic.php?f=4&t=590
-http://bugs.gentoo.org/show_bug.cgi?id=339753
-
---- makefile
-+++ makefile
-@@ -11,7 +11,7 @@
-
- # Optimize to level 3:
-
--CXXFLAGS += -O3
-+#CXXFLAGS += -O3
-
- MOTHUR_FILES = "\"Enter_your_default_path_here\""
-
-@@ -49,7 +49,7 @@
-
- ifeq ($(strip $(USEREADLINE)),yes)
- CXXFLAGS += -DUSE_READLINE
-- LDFLAGS += \
-+ LIBS = \
- -lreadline\
- -lncurses
- endif
-@@ -57,7 +57,7 @@
- USEMPI ?= no
-
- ifeq ($(strip $(USEMPI)),yes)
-- CXX = mpic++
-+# CXX = mpic++
- CXXFLAGS += -DUSE_MPI
- endif
-
-@@ -74,7 +74,7 @@
- OBJECTS=$(patsubst %.cpp,%.o,$(wildcard *.cpp))
-
- mothur : $(OBJECTS)
-- $(CXX) $(LDFLAGS) $(TARGET_ARCH) -o $@ $(OBJECTS)
-+ $(CXX) $(LDFLAGS) $(TARGET_ARCH) -o $@ $(OBJECTS) $(LIBS)
-
- install : mothur
- cp mothur ../Release/mothur
diff --git a/sci-biology/mothur/files/mothur-1.13.0-overflows.patch b/sci-biology/mothur/files/mothur-1.13.0-overflows.patch
deleted file mode 100644
index 0cd9d7f3a47e..000000000000
--- a/sci-biology/mothur/files/mothur-1.13.0-overflows.patch
+++ /dev/null
@@ -1,82 +0,0 @@
-Fix buffer overflows
-
-http://www.mothur.org/forum/viewtopic.php?f=4&t=591
-
---- Mothur.source/filterseqscommand.cpp
-+++ Mothur.source/filterseqscommand.cpp
-@@ -305,8 +305,8 @@
-
- //wait on chidren
- for(int i = 1; i < processors; i++) {
-- char buf[4];
-- MPI_Recv(buf, 4, MPI_CHAR, i, tag, MPI_COMM_WORLD, &status);
-+ char buf[5];
-+ MPI_Recv(buf, 5, MPI_CHAR, i, tag, MPI_COMM_WORLD, &status);
- }
-
- }else { //you are a child process
-@@ -326,11 +326,11 @@
-
- if (m->control_pressed) { MPI_File_close(&inMPI); MPI_File_close(&outMPI); return 0; }
-
-- char buf[4];
-+ char buf[5];
- strcpy(buf, "done");
-
- //tell parent you are done.
-- MPI_Send(buf, 4, MPI_CHAR, 0, tag, MPI_COMM_WORLD);
-+ MPI_Send(buf, 5, MPI_CHAR, 0, tag, MPI_COMM_WORLD);
- }
-
- MPI_File_close(&outMPI);
---- Mothur.source/distancecommand.cpp
-+++ Mothur.source/distancecommand.cpp
-@@ -271,8 +271,8 @@
- for(int i = 1; i < processors; i++) {
- if (m->control_pressed) { MPI_File_close(&outMPI); delete distCalculator; return 0; }
-
-- char buf[4];
-- MPI_Recv(buf, 4, MPI_CHAR, i, tag, MPI_COMM_WORLD, &status);
-+ char buf[5];
-+ MPI_Recv(buf, 5, MPI_CHAR, i, tag, MPI_COMM_WORLD, &status);
- }
- }else { //you are a child process
- //do your part
-@@ -280,10 +280,10 @@
-
- if (m->control_pressed) { MPI_File_close(&outMPI); delete distCalculator; return 0; }
-
-- char buf[4];
-+ char buf[5];
- strcpy(buf, "done");
- //tell parent you are done.
-- MPI_Send(buf, 4, MPI_CHAR, 0, tag, MPI_COMM_WORLD);
-+ MPI_Send(buf, 5, MPI_CHAR, 0, tag, MPI_COMM_WORLD);
- }
-
- MPI_File_close(&outMPI);
---- Mothur.source/chimeracheckcommand.cpp
-+++ Mothur.source/chimeracheckcommand.cpp
-@@ -269,8 +269,8 @@
-
- //wait on chidren
- for(int j = 1; j < processors; j++) {
-- char buf[4];
-- MPI_Recv(buf, 4, MPI_CHAR, j, tag, MPI_COMM_WORLD, &status);
-+ char buf[5];
-+ MPI_Recv(buf, 5, MPI_CHAR, j, tag, MPI_COMM_WORLD, &status);
- }
- }else{ //you are a child process
- MPI_Recv(&numSeqs, 1, MPI_INT, 0, tag, MPI_COMM_WORLD, &status);
-@@ -288,9 +288,9 @@
- if (m->control_pressed) { MPI_File_close(&inMPI); MPI_File_close(&outMPI); for (int j = 0; j < outputNames.size(); j++) { remove(outputNames[j].c_str()); } delete chimera; return 0; }
-
- //tell parent you are done.
-- char buf[4];
-+ char buf[5];
- strcpy(buf, "done");
-- MPI_Send(buf, 4, MPI_CHAR, 0, tag, MPI_COMM_WORLD);
-+ MPI_Send(buf, 5, MPI_CHAR, 0, tag, MPI_COMM_WORLD);
- }
-
- //close files
diff --git a/sci-biology/mothur/files/mothur-1.13.0-overflows2.patch b/sci-biology/mothur/files/mothur-1.13.0-overflows2.patch
deleted file mode 100644
index ac1103d19aa4..000000000000
--- a/sci-biology/mothur/files/mothur-1.13.0-overflows2.patch
+++ /dev/null
@@ -1,77 +0,0 @@
- clearcutcommand.cpp | 32 ++++++++++++++++----------------
- 1 files changed, 16 insertions(+), 16 deletions(-)
-
-diff --git a/clearcutcommand.cpp b/clearcutcommand.cpp
-index 1a7ab1f..256aa4d 100644
---- a/clearcutcommand.cpp
-+++ b/clearcutcommand.cpp
-@@ -180,33 +180,33 @@ int ClearcutCommand::execute() {
-
- vector<char*> cPara;
-
-- char* tempClearcut = new char[8]; strcpy(tempClearcut, "clearcut"); cPara.push_back(tempClearcut);
-+ char* tempClearcut = new char[16]; strcpy(tempClearcut, "clearcut"); cPara.push_back(tempClearcut);
-
- //you gave us a distance matrix
-- if (phylipfile != "") { char* temp = new char[10]; strcpy(temp, "--distance"); cPara.push_back(temp); }
-+ if (phylipfile != "") { char* temp = new char[16]; strcpy(temp, "--distance"); cPara.push_back(temp); }
-
- //you gave us a fastafile
-- if (fastafile != "") { char* temp = new char[11]; strcpy(temp, "--alignment"); cPara.push_back(temp); }
-+ if (fastafile != "") { char* temp = new char[16]; strcpy(temp, "--alignment"); cPara.push_back(temp); }
-
-- if (version) { char* temp = new char[9]; strcpy(temp, "--version"); cPara.push_back(temp); }
-- if (verbose) { char* temp = new char[9]; strcpy(temp, "--verbose"); cPara.push_back(temp); }
-- if (quiet) { char* temp = new char[7]; strcpy(temp, "--quiet"); cPara.push_back(temp); }
-+ if (version) { char* temp = new char[16]; strcpy(temp, "--version"); cPara.push_back(temp); }
-+ if (verbose) { char* temp = new char[16]; strcpy(temp, "--verbose"); cPara.push_back(temp); }
-+ if (quiet) { char* temp = new char[16]; strcpy(temp, "--quiet"); cPara.push_back(temp); }
- if (seed != "*") {
- string tempSeed = "--seed=" + seed;
- char* temp = new char[tempSeed.length()];
- strcpy(temp, tempSeed.c_str());
- cPara.push_back(temp);
- }
-- if (norandom) { char* temp = new char[10]; strcpy(temp, "--norandom"); cPara.push_back(temp); }
-- if (shuffle) { char* temp = new char[9]; strcpy(temp, "--shuffle"); cPara.push_back(temp); }
-- if (neighbor) { char* temp = new char[10]; strcpy(temp, "--neighbor"); cPara.push_back(temp); }
-+ if (norandom) { char* temp = new char[16]; strcpy(temp, "--norandom"); cPara.push_back(temp); }
-+ if (shuffle) { char* temp = new char[16]; strcpy(temp, "--shuffle"); cPara.push_back(temp); }
-+ if (neighbor) { char* temp = new char[16]; strcpy(temp, "--neighbor"); cPara.push_back(temp); }
-
- string tempIn = "--in=" + inputFile;
- char* tempI = new char[tempIn.length()];
- strcpy(tempI, tempIn.c_str());
- cPara.push_back(tempI);
-
-- if (stdoutWanted) { char* temp = new char[8]; strcpy(temp, "--stdout"); cPara.push_back(temp); }
-+ if (stdoutWanted) { char* temp = new char[16]; strcpy(temp, "--stdout"); cPara.push_back(temp); }
- else{
- string tempOut = "--out=" + outputName;
-
-@@ -215,10 +215,10 @@ int ClearcutCommand::execute() {
- cPara.push_back(temp);
- }
-
-- if (DNA) { char* temp = new char[5]; strcpy(temp, "--DNA"); cPara.push_back(temp); }
-- if (protein) { char* temp = new char[9]; strcpy(temp, "--protein"); cPara.push_back(temp); }
-- if (jukes) { char* temp = new char[7]; strcpy(temp, "--jukes"); cPara.push_back(temp); }
-- if (kimura) { char* temp = new char[8]; strcpy(temp, "--kimura"); cPara.push_back(temp); }
-+ if (DNA) { char* temp = new char[16]; strcpy(temp, "--DNA"); cPara.push_back(temp); }
-+ if (protein) { char* temp = new char[16]; strcpy(temp, "--protein"); cPara.push_back(temp); }
-+ if (jukes) { char* temp = new char[16]; strcpy(temp, "--jukes"); cPara.push_back(temp); }
-+ if (kimura) { char* temp = new char[16]; strcpy(temp, "--kimura"); cPara.push_back(temp); }
- if (matrixout != "") {
- string tempMatrix = "--matrixout=" + outputDir + matrixout;
- char* temp = new char[tempMatrix.length()];
-@@ -233,8 +233,8 @@ int ClearcutCommand::execute() {
- cPara.push_back(temp);
- }
-
-- if (expblen) { char* temp = new char[9]; strcpy(temp, "--expblen"); cPara.push_back(temp); }
-- if (expdist) { char* temp = new char[9]; strcpy(temp, "--expdist"); cPara.push_back(temp); }
-+ if (expblen) { char* temp = new char[16]; strcpy(temp, "--expblen"); cPara.push_back(temp); }
-+ if (expdist) { char* temp = new char[16]; strcpy(temp, "--expdist"); cPara.push_back(temp); }
-
- char** clearcutParameters;
- clearcutParameters = new char*[cPara.size()];
diff --git a/sci-biology/mothur/mothur-1.13.0-r1.ebuild b/sci-biology/mothur/mothur-1.13.0-r1.ebuild
deleted file mode 100644
index 1efa846e1e42..000000000000
--- a/sci-biology/mothur/mothur-1.13.0-r1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/mothur/mothur-1.13.0-r1.ebuild,v 1.3 2012/08/14 15:37:59 jlec Exp $
-
-EAPI="2"
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="A suite of algorithms for ecological bioinformatics"
-HOMEPAGE="http://www.mothur.org/"
-SRC_URI="mirror://gentoo/${P}.zip"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="mpi +readline"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="${RDEPEND}
- app-arch/unzip"
-RDEPEND="mpi? ( virtual/mpi )"
-
-S=${WORKDIR}/Mothur.source
-
-pkg_setup() {
- use mpi && CXX=mpicxx || CXX=$(tc-getCXX)
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-makefile.patch \
- "${FILESDIR}"/${P}-overflows.patch
-}
-
-use_yn() {
- use $1 && echo "yes" || echo "no"
-}
-
-src_compile() {
- emake USEMPI=$(use_yn mpi) USEREADLINE=$(use_yn readline) || die
-}
-
-src_install() {
- dobin ${PN}
-}
diff --git a/sci-biology/mothur/mothur-1.13.0-r2.ebuild b/sci-biology/mothur/mothur-1.13.0-r2.ebuild
deleted file mode 100644
index 3dad5095a7ca..000000000000
--- a/sci-biology/mothur/mothur-1.13.0-r2.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/mothur/mothur-1.13.0-r2.ebuild,v 1.1 2012/08/14 15:37:59 jlec Exp $
-
-EAPI="2"
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="A suite of algorithms for ecological bioinformatics"
-HOMEPAGE="http://www.mothur.org/"
-SRC_URI="mirror://gentoo/${P}.zip"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="mpi +readline"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="${RDEPEND}
- app-arch/unzip"
-RDEPEND="mpi? ( virtual/mpi )"
-
-S=${WORKDIR}/Mothur.source
-
-pkg_setup() {
- use mpi && CXX=mpicxx || CXX=$(tc-getCXX)
-}
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-makefile.patch \
- "${FILESDIR}"/${P}-overflows.patch \
- "${FILESDIR}"/${P}-overflows2.patch
-}
-
-use_yn() {
- use $1 && echo "yes" || echo "no"
-}
-
-src_compile() {
- emake USEMPI=$(use_yn mpi) USEREADLINE=$(use_yn readline) || die
-}
-
-src_install() {
- dobin ${PN}
-}
diff --git a/sci-biology/mothur/mothur-1.27.0.ebuild b/sci-biology/mothur/mothur-1.27.0-r1.ebuild
index 852d09ca39ea..b6b4e4fe0be6 100644
--- a/sci-biology/mothur/mothur-1.27.0.ebuild
+++ b/sci-biology/mothur/mothur-1.27.0-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/mothur/mothur-1.27.0.ebuild,v 1.1 2012/08/14 15:37:59 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/mothur/mothur-1.27.0-r1.ebuild,v 1.1 2015/07/27 18:42:15 jlec Exp $
-EAPI=4
+EAPI=5
-inherit eutils toolchain-funcs flag-o-matic
+inherit eutils flag-o-matic fortran-2 toolchain-funcs
DESCRIPTION="A suite of algorithms for ecological bioinformatics"
HOMEPAGE="http://www.mothur.org/"
@@ -24,9 +24,9 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/Mothur.source
pkg_setup() {
+ fortran-2_pkg_setup
use mpi && export CXX=mpicxx || export CXX=$(tc-getCXX)
- use amd64 && append-flags -DBIT_VERSION
- tc-export FC
+ use amd64 && append-cppflags -DBIT_VERSION
}
src_prepare() {
@@ -35,12 +35,8 @@ src_prepare() {
"${FILESDIR}"/${P}-overflows.patch
}
-use_yn() {
- use $1 && echo "yes" || echo "no"
-}
-
src_compile() {
- emake USEMPI=$(use_yn mpi) USEREADLINE=$(use_yn readline)
+ emake USEMPI=$(usex mpi) USEREADLINE=$(usex readline)
}
src_install() {